SGX Video Acceleration Under Ubuntu

1074 views
Skip to first unread message

jmar...@gmail.com

unread,
Aug 12, 2013, 4:48:04 PM8/12/13
to beagl...@googlegroups.com, mjoh...@baytekgames.com

I am attempting to follow the instructions at http://elinux.org/BeagleBoardUbuntu to get the SGX Video Acceleration and Ubuntu working on my Beagle Bone Black.  My OpenGL app runs too slow without acceleration.

The SGX Video Acceleration section says "test with Precise 12.04 armhf demo image with 3.4.5-x1".  I don't think that's available for Beagle Bone Black or at least it's no longer a wget option listed on the elinux web site.

Is anyone working toward this or have any advice on how to get SGX / Ubuntu working on Beagle Bone Black?

Thanks,

Mark J


Charles Steinkuehler

unread,
Aug 12, 2013, 4:52:23 PM8/12/13
to beagl...@googlegroups.com, jmar...@gmail.com, mjoh...@baytekgames.com
On 8/12/2013 3:48 PM, jmar...@gmail.com wrote:
> Is anyone working toward this or have any advice on how to get SGX / Ubuntu
> working on Beagle Bone Black?

There's not SGX driver for the AM335x 3.8 kernel AFAIK. If you dig
through the archives, there was someone asking questions about this
looking to add support as part of a GSOC project. I haven't heard
anything about this for a while...if he's made progress that's likely
your best bet. Otherwise it's wait for TI to provide the driver code,
or try your hand at getting the 3.8 driver for another SoC working on
the AM335x.

--
Charles Steinkuehler
cha...@steinkuehler.net

signature.asc

Spenser Gilliland

unread,
Aug 12, 2013, 5:08:33 PM8/12/13
to beagl...@googlegroups.com, jmar...@gmail.com, mjoh...@baytekgames.com
Hey Charles,

> There's not SGX driver for the AM335x 3.8 kernel AFAIK. If you dig
> through the archives, there was someone asking questions about this
> looking to add support as part of a GSOC project. I haven't heard
> anything about this for a while...if he's made progress that's likely
> your best bet. Otherwise it's wait for TI to provide the driver code,
> or try your hand at getting the 3.8 driver for another SoC working on
> the AM335x.

This would most likely be me. This is one of many tasks I'm working
on for the GSoC, so I've had to put it on the backburner till more
documentation is available. The main issue stems from how to
configure the the TI DRM framebuffer to support the SGX core.

If anyone has any information on how to configure the DRM framebuffer
for use with the SGX please respond. OpenGL support is a major feature
currently lacking from the BBB/BBW in 3.8 kernels.

Thanks,
Spenser

Charles Steinkuehler

unread,
Aug 12, 2013, 5:41:11 PM8/12/13
to beagl...@googlegroups.com, Spenser Gilliland, jmar...@gmail.com, mjoh...@baytekgames.com
I've crawled through the documentation from TI for the SoC, and if
there's anything it would be in the LCD controller portion of the docs.

You might try asking TI directly. This is really more of an end user
forum, and not the best place for developer questions. The TI folks
have generally been pretty helpful when I've had problems, but then my
company buys a lot of TI stuff and I haven't asked about the SoC parts
before, which is probably a totally different group (I'm usually dealing
with the guys supporting linear, interface, and clock chips).

Of course, the best example is probably the drivers for the previous
kernel, which did actually work, unless too much of the code is just a
binary blob (I haven't really looked). That ought to at least provide
hints for how to set the hardware up properly.

--
Charles Steinkuehler
cha...@steinkuehler.net

signature.asc

William Hermans

unread,
Aug 12, 2013, 10:45:12 PM8/12/13
to beagl...@googlegroups.com
It is my understanding that the SGX/DRM drivers are due this quarter. Originally it was due when the BBB was released, but they've since pushed the release date back to quarter 4 this year. I half expect that to be pushed back yet again, but we'll see soon enough.

Chris Vella

unread,
Aug 12, 2013, 11:08:08 PM8/12/13
to beagl...@googlegroups.com
I've been doing a lot of digging to find the availability of these as I'm struggling with my project also, without OPENGL support.

Once these are out, I'm assuming someone will need substantial time to tie these into the 3.8 kernel or is it a matter of once the drivers are installed we could simply compile them and we're off?

William Hermans

unread,
Aug 12, 2013, 11:19:40 PM8/12/13
to beagl...@googlegroups.com
All i can say is that when they're available they'll be available. What i have said here was said on these very same forums a few months back when the BBB was released.

I did notice that Robert C Nelson has SGX drivers for the XM with kernel 3.7.x, but when i asked about this I was told that this was not related to the BBB. So. . . yeah we're all playing the waiting game waiting for TI to make something happen as far as I know.


--
For more options, visit http://beagleboard.org/discuss
---
You received this message because you are subscribed to the Google Groups "BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email to beagleboard...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Chris Vella

unread,
Aug 12, 2013, 11:28:44 PM8/12/13
to beagl...@googlegroups.com
Thanks William.

Where did you hear when they will provide the drivers?  I've posted something on the TI and Im just waiting a response.


You received this message because you are subscribed to a topic in the Google Groups "BeagleBoard" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/beagleboard/08PyCP3d94c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to beagleboard...@googlegroups.com.

William Hermans

unread,
Aug 12, 2013, 11:33:33 PM8/12/13
to beagl...@googlegroups.com
Gerald made a post early on after the BBB was being sold to the general public. Replying to someone else asking essentially the same question. It should still be here on the groups somewhere. 

I asked Robert C Nelson directly on his eewiki "channel" semi recently. You can look there and see the response he gave me. 


Question and answer should be close to the bottom.

Spenser Gilliland

unread,
Aug 13, 2013, 7:27:58 PM8/13/13
to beagl...@googlegroups.com
William,
Just as a comment, I've looked at the boot log described in the
comment on eewiki. The insmod errors are related to the device tree
not defining the sgx_ck node for the clock of the GPU. The EGL error
exists because the GPU is not running. Also, you will not be able to
read any of the registers on the SGX to perform detection for the same
reason.

Thanks,
Spenser


--
Spenser Gilliland
Computer Engineer
Doctoral Candidate

mail.ar...@gmail.com

unread,
Oct 24, 2013, 2:36:27 PM10/24/13
to beagl...@googlegroups.com, mjoh...@baytekgames.com, jmar...@gmail.com
Hi,

Any progress on that? I need OpenGL support and worked the last few days on getting this damn thing to work. Any idea how to proceed? Here is my post in the E2E forums:

Regards
Alexander
Reply all
Reply to author
Forward
0 new messages