DEW works (again) (almost) was: [apidesign] Question for DEW

Skip to first unread message

Jaroslav Tulach

Sep 3, 2017, 8:59:53 AM9/3/17
to Wooguil Pak,
Hello Wooguil & co.,
I've spend few more hours with the new DEW and I can announce that its Beta version is ready for testing:

Most of the examples seem to run (yet some need to be executed twice). I solved the problem with "targetId" and main method by rewriting the code snippets while loading them. Seems to work for all the standard snippets. I also made sure that the proper "ko4j" library is loaded into the system to animate the UI.

Please let me know what are the major blockers now. Once they are removed, I will replace the old DEW with the new version.

2017-09-02 7:50 GMT+02:00 Jaroslav Tulach <>:
Hello again.

2017-08-31 11:07 GMT+02:00 Wooguil Pak <>:
Hello, Jaroslav Tulach.

I'm very happy to hear the good news from you.
However, I cannot still run any example in DEW because some errors are
generated during compiling. I attached the screenshot named test1.png.

Looking at test1.png, I'd say everything is good. Have you tried to click on the "Press me!" button? It works for me. If I go to

Reloading doesn't work properly yet, but the first run seems to be fine both on chrome and firefox.

I don't see your error message, but the reason for it is probably that the new version tries to invoke a main method. The old examples store the initial code is static initializers:

static {
  // do something

to avoid the main method problem it is possible to change that to

public static void main(String... args) {
  // do something

then the "main method not found" exception in console shall disappear.

I also tried to run a simple example in a html-java document.
I could compile but it failed when I press the button.
Please refer to the attached file, test2.png.

applyBindings() has private access in 

This is caused by the fact that the GIST examples are made for too old version of HTML/Java API. The new versions (since 1.1) require one to provide targetId attribute to the @Model annotation (see

As such one has to modify the PrimeUI examples as

@Model(className="PrimeUI", targetId="", properties={
  @Property(name="number", type=int.class),
class PrimeDemo {

then the compilation succeeds. However the code still doesn't execute properly. I'll take a look at it now.
I tested in ubuntu 16.04.1 using openjdk version "1.8.0_131".

Anyway, it was improved greatly and I really appreciate of your efforts.

Thanks. Your interest motivates me to get the system running.

2017-08-30 14:17 GMT+09:00 Jaroslav Tulach <>:
> Hello Wooguil & others interested in Bck2Brwsr and DEW,
> on Sunday I managed to bring the DEW repo into relatively usable state. I
> was able to compile and run simple examples (those that throw an exception
> in initializer, run for sure ;-). Feel free to give it another try:
> Let me know what problems you find. I'll polish the state a bit more over
> next weekend.
> -jt
> 2017-08-19 11:06 GMT+02:00 Jaroslav Tulach <>:
>> Hello Wooguil,
>> thanks for your interest in DEW and your nice words. I haven't touched the
>> DEW project for a few years and I have to admit it is not in a good shape.
>> I've just taken a look and tried to polish it a bit. You can update to new
>> version, but the tests still don't fully run and there are other problems.
>> It may take a while before I manage to fix that. Anyway:
>> dew$ mvn clean install -DskipTests
>> should give you
>> dew$ ls static-dew/target/
>> static-dew/target/
>> which may contain something to work on. If you interest persists, ping me
>> in a week or so... maybe I have time to do more fixes.
>> -jt
>> 2017-08-18 8:30 GMT+02:00 Wooguil Pak <>:
>>> Hello, My name is Wooguil Pak.
>>> At first, I should say "Thank you for your great work". It is really
>>> amazing.
>>> Currently, I'm trying to run DEW from github,
>>> But it seems that is missing in bck2brwsr.js.
>>> When I am trying, web console of browser says like that.
>>>    Reading JARs is only possible with  module
>>> included: org.apidesign.bck2brwsr.vmzip.ZipResources
>>> bck2brwsr.js:1332:37
>>>    java.lang.ClassNotFoundException:
>>> org.apidesign.bck2brwsr.vmzip.ZipResources  bck2brwsr.js:115028:14
>>>    Cannot load static-dew-0.3-SNAPSHOT.jar -
>>> org.apidesign.bck2brwsr.vmzip.ZipResources
>>> Could you explain how to solve this problem and what should I do?
>>> Although I compiled bck2brwsr obtained from github, I don't know how
>>> to add to bck2brwsr.
>>> Thanks in advance.
>>> Best Regards,
>>> Wooguil
>>> --
>>> =========================================================
>>> Wooguil Pak, Ph.D, Assistant Professor
>>> Security and Wireless Network Lab. Dept. of Computer Engineering,
>>> Shindang-Dong, Dalseo-Gu, Daegu, Keimyung Univ. 704-701, Korea
>>> Office:+82-53-580-5229, Cell phone: +82-10-2753-1027
>>> Fax: +82-53-580-6275, Email:
>>> =========================================================
>>> --
>>> You received this message because you are subscribed to the Google Groups
>>> "apidesign" group.
>>> To unsubscribe from this group and stop receiving emails from it, send an
>>> email to
>>> To post to this group, send email to
>>> To view this discussion on the web visit
>>> For more options, visit

Wooguil Pak, Ph.D, Assistant Professor
Security and Wireless Network Lab. Dept. of Computer Engineering,
Shindang-Dong, Dalseo-Gu, Daegu, Keimyung Univ. 704-701, Korea
Office:+82-53-580-5229, Cell phone: +82-10-2753-1027
Fax: +82-53-580-6275, Email:

Jaroslav Tulach

Sep 10, 2017, 7:23:23 AM9/10/17
to Wooguil Pak,
Hello Wooguil,
I have found some time today to play with the example again.

2017-09-04 4:18 GMT+02:00 Wooguil Pak <>:
Hello, Jaroslav Tulach.

Thank you very much for your fast revision.
I really appreciate of your effort.

Currently some examples do not work such as
- Renders analog clock -- does not update clock image.

This works for me, from time to time, but when it doesn't there is a following error in the console:

java.lang.ClassNotFoundException: java.util.Timer
c.warn__VLjava_lang_String_2 @ vm.js:122403

when this happens, the vm.java_util_Timer functions (which represents the class) is set to:

$ vm.java_util_Timer
ƒ () {
  var instance = arguments.length == 0 || arguments[0] === true;
  return lazy.load__Ljava_lang_Object_2Ljava_lang_String_2Z(dot, instance);

which is strange, this class should have already be in the VM, no need to load it lazily.
- Histogram in Java and HTML+CSS -- does not show the histogram.

Histogram now works again. There was a problem in finding the name of main class:
- List of favorite projects. 1st DEW demo -- does not list the items.

This one also seems to work. Probably, when you see the error again, send me what is captured in the browser's console. Maybe I find the reasons then.


Reply all
Reply to author
0 new messages