SlickRun interface not showing up, but process is running

182 views
Skip to first unread message

Jason Creviston

unread,
Nov 28, 2017, 1:07:06 PM11/28/17
to Bayden
First of all, thanks for the best utility app ever! If I could open the interface right now, it'd probably show that I have executed commands 10,000+ times in the last 17 months.


My issue may or may not have anything to do with the Microsoft Windows 10 Fall Creators Update install. I can't exactly remember when the SlickRun issue started to occur. I'd guess it was definitely after the update, but SlickRun may have worked at some point post-update, then started acting up later.

Version 4.4.0.0

So... the slickrun process loads at startup. Icon is in the notification area.

However, if I use my launch combo key, it doesn't show up.

If I open the Notification area, the icon is there, but as soon as I left or right click on the icon, it disappears. Then if I close and re-open the Notification area icon, the icon is back.

If I have the Notification area open, then hit my launch combo key, the icon disappears from the NA, but will show back up again if the NA is closed and reopened.

I can also open the NA, click the icon (it disappears), then click the taskbar, and the NA stays visible and the SR icon shows up again.

Really strange.

I've tried manually starting the app as an admin, but it has the same behavior.

Any ideas?

EricLaw

unread,
Nov 28, 2017, 1:13:58 PM11/28/17
to Bayden
Typically, this means that SlickRun's window position has somehow gotten "stuck" somewhere that isn't visible on your monitor. SlickRun includes code that attempts to prevent this from happening, but users still encounter this from time to time.

The quick fix is usually to hit SlickRun's hotkey, then blindly type corner and hit enter. SlickRun should jump to the nearest corner on the monitor. If that doesn't work, please let me know.

Ed Eichman

unread,
Jul 27, 2018, 4:43:48 AM7/27/18
to Bayden
Hi Eric,

I've been using slickrun for years (and years and years), and just started having the "disappearing slickrun" problem over the last week or two. Your "corner" solution is not working for me. When it disappears, it stays hidden no matter what I do.... killing the process and restarting it has it working OK for a while, and then it disappears again. Restarting the computer does not help. 

Windows 10 Pro, 1803, build 17134.165. If you need complete system info, let me know.

My ini file....

[Main]
ActiveOpacity=200
IdleOpacity=200
Ghost=0
AutoHide=0
Left=1659
Top=83
Width=188
Locked=0
LeftMargin=2
Color=8388608
EditColor=0
EditFontName=Tahoma
EditFontCharSet=1
EditFontColor=65535
EditFontSize=11
EditFontStyle=0
ColorDate=16777215
ColorTime=16777215
ColorMail=16777215
[General]
UseUTF8=1
AllowAltTab=1
ShowTrayIcon=1
ChaseCursor=0
StayOnTop=1
AutocompleteOffers=15
GrabWinR=0
GrabWinQ=0
GrabWinSpace=0
NoMouseActivation=0
BringUpKey=81
BringUpModifier=1
CommandsRunCount=9833
DefaultShowType=1
TimeFormat=h:nn am/pm
DateFormat="Mem: "%fm%" - "m/d
[LastPersist]
LastPersist=7-25-18 20:25:58
[Jot]
Height=307
Width=536
Left=-1187
Top=621
BringUpJotKey=74
BringUpJotModifier=1
Color=8421376
ColorText=16777215
[Setup]
Height=325
Width=450
Left=1136
Top=264
[Parameters]
Left=1186
Top=714
Width=280

Thanks!
Ed

Ed Eichman

unread,
Jul 27, 2018, 4:45:17 AM7/27/18
to Bayden
BTW, my slickrun version is  4.4.0.0

Ed Eichman

unread,
Jul 30, 2018, 3:15:51 AM7/30/18
to Bayden
Also, in the meantime, I de-installed and re-installed, and rebooted. But I still have the same problem.

EricLaw

unread,
Sep 6, 2018, 11:33:42 AM9/6/18
to Bayden
If typing "CORNER" doesn't help, that probably means that Windows thinks that it has a monitor that isn't actually attached.

In your INI file, you see the following:

   Left=1659
   Top=83

What is the resolution of your primary monitor?

Ed Eichman

unread,
Sep 10, 2018, 8:47:21 AM9/10/18
to Bayden
Hi Eric,

Sorry, I was on vacation. Have not seen the problem all days since coming back from vacation.


If typing "CORNER" doesn't help, that probably means that Windows thinks that it has a monitor that isn't actually attached.

In your INI file, you see the following:

   Left=1659
   Top=83

What is the resolution of your primary monitor?

1920x1080 

If I see this again, I will check the INI settings. Anything else I should look at?

Thanks,
Ed

Christian Herrera

unread,
Nov 6, 2018, 4:42:19 PM11/6/18
to Bayden
_ search slickrun in windows sear, click on the icon , typed "corner" and it appeared on the top left section of my screen.

Ed Eichman

unread,
Nov 7, 2018, 4:34:04 AM11/7/18
to Bayden
Hi Christian,

I tried that method, but when SlickRun is gone, it does not work for me.

In the meantime, I've seen it happen a few more times. I'm sure it has something to do with Jot being on my second screen and SlickRun being on my main screen, but I have yet to see a reproducible case.

Thanks in any case!
Ed
Reply all
Reply to author
Forward
0 new messages