PulseAudio support?

2650 views
Skip to first unread message

Sig Blip

unread,
Feb 28, 2010, 4:35:35 PM2/28/10
to baud...@googlegroups.com
Is there any value in adding PulseAudio support to baudline?

JACK seems like a much better low latency solution to me but it's a
bit more work to use and it isn't installed by default with most Linux
distributions. PulseAudio is used by Gnome and several mobile handsets
so it is more popular by default. Popularity isn't really important
but problem free audio usage is.

PulseAudio has a legacy compatibility layer and I haven't had any
reports of problems from baudline users. I recommend in the baudline
FAQ to disable sound daemons because they tend to create all sorts of
audio problems. So are people disabling PulseAudio or is the
compatibility layer working fine with baudline?

Lem

unread,
Mar 26, 2012, 9:10:43 AM3/26/12
to baud...@googlegroups.com
The PulseAudio compatibility doesn't seem to work in Ubuntu 12.04 Beta, invoked with:

padsp baudline audiofile.flac

There is an output device, but when trying to cause some sort of output, Baudline has an error:

Invalid argument SNDCTL_DSP_CHANNELS

Starting Baudline on Ubuntu 12.04 (and indeed Ubuntu 11.10 before it) results in no output devices being available. There is a workaround which is installing qjackctl to start jackd, and using baudline_jack instead.

Lem

unread,
Oct 1, 2013, 8:01:28 AM10/1/13
to baud...@googlegroups.com
Over 1 year later, and I have found a solution.

Baudline 1.08 (amd64 build) works fine on both Ubuntu 13.04 and 13.10 (beta 2 at time of posting). Very very simple to get going:

apt-get install osspd
sudo ln -s /dev/dsp /dev/audio

Run baudline.

I only ever used baudline for playback, and this seems to work perfectly.



On Monday, March 1, 2010 7:35:35 AM UTC+10, Sig Blip wrote:

Craig

unread,
Jun 8, 2014, 7:48:20 AM6/8/14
to baud...@googlegroups.com
I recently recently upgraded to Xubuntu 14.04 from Ubuntu 10.04 and wanted to let you know how Baudline works with it.

Previously, I was having no issues and I had a framerate of around 171FPS and 114FPS in play and record (respectively). However, due to the lack of the /dev/audio device, my experiences in 14.04 aren't so good.

"aoss baudline" results in Baudline producing the error message "No such device or address SNDCTL_DSP_SETFMT", while "padsp baudline" results in the error "Invalid argument SNDCTL_DSP_CHANNELS."
I've also tried both osspd-pulseaudio and osspd-alsa (the latter of which would give "Requested FragSize ignored" with all the sample rates I tried) as per Lem's suggestion, but I get about 2FPS when recording and 34FPS during playback.
Using JACK seems to work fine, but it's generally an inconvenience in my case.


At any rate, thanks for Baudline! I've used it for a few years now and have been very happy with it.

Best regards,
Craig

Jason Newton

unread,
Apr 19, 2016, 12:23:28 PM4/19/16
to baudline
This worked for me:
parec --format=s16le --channels=1 --latency-msec=2 -d alsa_output.pci-0000_00_1b.0.analog-surround-41.monitor | ./baudline -stdin #records from a device monitor
You can use --monitor-stream=$index as well

You can find these devices by looking at pacmd list (everything), pacmd list-source-outputs (monitors), pacmd list-sink-inputs (clients) depending on what you want to sift through/record from.

I'm fresh at baudline but its working well enough for me, FPS is variable and I'm seeing up to about 15 video FPS and 70-130 transforms/sec with this at 1.5% on a Xeon E3-1275 V2 @ 3.50GHz,
Reply all
Reply to author
Forward
0 new messages