P1.max FASTA file no longer being generated

14 views
Skip to first unread message

Bobby Read

unread,
Sep 20, 2020, 5:42:39 AM9/20/20
to bali-phy-users
Hi there!

I have been using BAli-Phy a little bit now to produce some great-looking trees, however, for some reason the P1.max.fasta file that was being produced when running the bp-analyze function is no longer being made.

I had to repeat a tree as i realised there was a sequence included that shouldn't have been! The commands were totally identical so i'm a little confused as to why the bp-analyse function is no longer making the P1.max.fasta file so i can view the alignment. 

I have tried reinstalling Cygwin and Bali-Phy itself, but still encountering the same error. Is there an easy fix or perhaps a separate command that will produce the alignment? 

Thanks in advance!
Ben

Bobby Read

unread,
Sep 20, 2020, 5:47:43 AM9/20/20
to bali-phy-users
Just to add a bit more information... here is what the cygwin console gives back to me when i run bp-analyze

$ bp-analyze ATPPRT_NEW-1/ ATPPRT_NEW-2/ --skip=11500
Renaming 'Results/' to 'Results.1'

Creating new directory Results/ for summary files.
Summarizing distribution of numerical parameters: done.
Analyzing scalar variables: done.

Summarizing topology distribution:  done.
Drawing trees: c50 c66 c80 c90 c95 c99 c100 greedy MAP . done.

Generate mixing diagnostics for topologies ...command: '/usr/bin/R' '--slave' '--vanilla' '--args' 'Results/LOD-table' 'Results/convergence-PP.pdf' < '/home/br33/Applications/bali-phy-3.5.0/lib/bali-phy/libexec/compare-runs.R'
 exit: 126

To clarify, the tree files are still being produced as normal, but the files containing the alignments are not

Benjamin Redelings

unread,
Sep 21, 2020, 3:56:11 PM9/21/20
to bali-ph...@googlegroups.com

Hi Ben,

It looks like somehow the bp-analyze script failed before it got to the part where it generates P1.max.fasta

One possibility is that you are trying to skip too many iterations -- i.e. you don't have enough iterations left after 11500.  That is just a guess though.

If you look in the Results directory, there should be a file called `commands.log`.  Does it give any more information on why the compare-runs.R script would have failed?

-BenRI

--
You received this message because you are subscribed to the Google Groups "bali-phy-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to bali-phy-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/bali-phy-users/776ec7d5-87e0-4b6b-b471-41f127febaaan%40googlegroups.com.

Bobby Read

unread,
Sep 23, 2020, 11:08:36 AM9/23/20
to bali-phy-users
Hi Ben 

Thanks for getting back to me. It appears that the program is having issues accessing R as it returns "permission denied" after the compare-runs.R script. I will try re-installing the Cygwin terminal again and make sure that everything has gone fine with the R package install.

Thanks again,
Ben

-----------------------------------------------------------
'statreport' 'ATPPRT_NEW-1/C1.log' 'ATPPRT_NEW-2/C1.log' '--skip=11500' > 'Results/Report'
'trees-consensus' '--map-tree=Results/MAP.PP.tree' '--greedy-consensus=Results/greedy.PP.tree' '--report=Results/consensus' 'ATPPRT_NEW-1/C1.trees' 'ATPPRT_NEW-2/C1.trees' '--support-levels=Results/c-levels.plot' '--skip=11500' '--consensus=0.5:Results/c50.PP.tree,0.66:Results/c66.PP.tree,0.8:Results/c80.PP.tree,0.9:Results/c90.PP.tree,0.95:Results/c95.PP.tree,0.99:Results/c99.PP.tree,1.0:Results/c100.PP.tree'
'tree-tool' 'Results/greedy.PP.tree' '--strip-internal-names' '--name-all-nodes' > 'Results/greedy.tree'
'tree-tool' 'Results/MAP.PP.tree' '--strip-internal-names' '--name-all-nodes' > 'Results/MAP.tree'
'tree-tool' 'Results/c50.PP.tree' '--strip-internal-names' '--name-all-nodes' > 'Results/c50.tree'
'tree-tool' 'Results/c66.PP.tree' '--strip-internal-names' '--name-all-nodes' > 'Results/c66.tree'
'tree-tool' 'Results/c80.PP.tree' '--strip-internal-names' '--name-all-nodes' > 'Results/c80.tree'
'tree-tool' 'Results/c90.PP.tree' '--strip-internal-names' '--name-all-nodes' > 'Results/c90.tree'
'tree-tool' 'Results/c95.PP.tree' '--strip-internal-names' '--name-all-nodes' > 'Results/c95.tree'
'tree-tool' 'Results/c99.PP.tree' '--strip-internal-names' '--name-all-nodes' > 'Results/c99.tree'
'tree-tool' 'Results/c100.PP.tree' '--strip-internal-names' '--name-all-nodes' > 'Results/c100.tree'
'draw-tree' 'c50.tree' '--layout=equal-daylight'
'draw-tree' 'c50.tree' '--layout=equal-daylight' '--output=svg'
'draw-tree' 'c66.tree' '--layout=equal-daylight'
'draw-tree' 'c66.tree' '--layout=equal-daylight' '--output=svg'
'draw-tree' 'c80.tree' '--layout=equal-daylight'
'draw-tree' 'c80.tree' '--layout=equal-daylight' '--output=svg'
'draw-tree' 'c90.tree' '--layout=equal-daylight'
'draw-tree' 'c90.tree' '--layout=equal-daylight' '--output=svg'
'draw-tree' 'c95.tree' '--layout=equal-daylight'
'draw-tree' 'c95.tree' '--layout=equal-daylight' '--output=svg'
'draw-tree' 'c99.tree' '--layout=equal-daylight'
'draw-tree' 'c99.tree' '--layout=equal-daylight' '--output=svg'
'draw-tree' 'c100.tree' '--layout=equal-daylight'
'draw-tree' 'c100.tree' '--layout=equal-daylight' '--output=svg'
'draw-tree' 'greedy.tree' '--layout=equal-daylight'
'draw-tree' 'greedy.tree' '--layout=equal-daylight' '--output=svg'
'draw-tree' 'MAP.tree' '--layout=equal-daylight'
'draw-tree' 'MAP.tree' '--layout=equal-daylight' '--output=svg'
'pickout' '--no-header' '--large' 'pi' < 'Results/consensus' > 'Results/partitions'
'trees-bootstrap' '--pred=Results/partitions.pred' '--LOD-table=Results/LOD-table' '--pseudocount=1' 'ATPPRT_NEW-1/C1.trees' 'ATPPRT_NEW-2/C1.trees' '--skip=11500' > 'Results/partitions.bs'
'/usr/bin/R' '--slave' '--vanilla' '--args' 'Results/LOD-table' 'Results/convergence-PP.pdf' < '/home/br33/Applications/bali-phy-3.5.0/lib/bali-phy/libexec/compare-runs.R'
  err: /usr/bin/R: line 271: /usr/lib/R/bin/exec/R: Permission denied
/usr/bin/R: line 271: /usr/lib/R/bin/exec/R: No error

 exit: 126
  err: /usr/bin/R: line 271: /usr/lib/R/bin/exec/R: Permission denied
/usr/bin/R: line 271: /usr/lib/R/bin/exec/R: No error

Bobby Read

unread,
Sep 23, 2020, 12:00:18 PM9/23/20
to bali-phy-users
Hi Ben,

Just an update...it turns out I had the wrong version of R installed! All is fixed now and working perfectly!

Benjamin Redelings

unread,
Sep 23, 2020, 12:10:15 PM9/23/20
to bali-ph...@googlegroups.com

Great!  Its good to have these kinds of problems/solutions available on the mailing list archives.

-BenRI

Reply all
Reply to author
Forward
0 new messages