Atualização para Bacula 15.0.2

128 views
Skip to first unread message

Ricardo Gomes

unread,
Mar 25, 2024, 10:15:03 AMMar 25
to Bacula Backup-Pt-Br
Olá,

Fiz a atualização do Bacula 13.0.3 para a versão 15.0.2

Uso Debian 10.13

O abri o console na porta IP:9595 aparece o erro:

Código do erro: 1000

Mensagem: Internal error. Component property 'ClientRecord.plugins' is not defined.

firefox_dia_25_mes_03_140.jpg


Alguém já passou por esse erro ?


Wellington Solution

unread,
Mar 27, 2024, 9:09:13 PMMar 27
to Bacula Backup-Pt-Br
Olá,
Eu não atualizei o meu bacula ainda para o 15.0.2,
mas pelo que vi houve mudanças no catálogo e outros recursos/funções.
então, você atualizou o Baculum?

Atualize o Baculum.
Ou você pode testar com o Bacularis (Fork/Alternativa ao Baculum)

Wellington

samuel...@gmail.com

unread,
Jun 5, 2024, 12:38:02 PM (10 days ago) Jun 5
to Bacula Backup-Pt-Br
Estava com o mesmo erro, instalação nova. No bacularis não deu erro. 

João Paulo de Sousa Costa

unread,
Jun 12, 2024, 2:00:29 PM (3 days ago) Jun 12
to Bacula Backup-Pt-Br
Boa tarde a todos,

Tive esse mesmo problema na atualização do bacula para a versão 15 e não testei com o bacularis. 
O que fiz para contornar a situação foi adicionar a variável que ele informa na mensagem de erro no arquivo /usr/share/baculum/htdocs/protected/API/Class/ClientRecord.php

adicionei na classe o conteúdo:  public $plugins;

outros erros irão aparecer, aí é só ir adicionando as variáveis nos arquivos corretos.


Mas enfrento outro problema: o baculum não está listando os arquivos que foram backapeados.

Wellington Solution

unread,
Jun 12, 2024, 5:37:13 PM (3 days ago) Jun 12
to Bacula Backup-Pt-Br
João:
Você deve atualizar o Baculum se quiser continuar a usá-lo, como não tem mais pacotes atualizados do Baculum/GUI via apt/yum, você deve baixar os arquivos fonte na página https://www.bacula.org/source-download-center/ e fazer o upgrade manualmente.
Do contrário você terá problemas e não é prático ficar modificando arquivos php.


Ou seguir o caminho mais prático e começar a usar o Bacularis que tem repo tornando a instalação e upgrades mais prático.


Wellington

João Paulo de Sousa Costa

unread,
Jun 13, 2024, 8:27:57 AM (2 days ago) Jun 13
to bacula-ba...@googlegroups.com
Vou fazer como indicado.

Obrigado Wellington

--
Você recebeu essa mensagem porque está inscrito em um tema no grupo "Bacula Backup-Pt-Br" dos Grupos do Google.
Para cancelar inscrição nesse tema, acesse https://groups.google.com/d/topic/bacula-backup-pt-br/snmsOOh5WtI/unsubscribe.
Para cancelar inscrição nesse grupo e todos os seus temas, envie um e-mail para bacula-backup-p...@googlegroups.com.
Para acessar essa discussão na Web, acesse https://groups.google.com/d/msgid/bacula-backup-pt-br/22b8ae88-1422-4a8c-99f0-ab195f0e721an%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages