Field solving on web-service but not on local install

24 views
Skip to first unread message

Samuel Grund

unread,
Nov 3, 2021, 4:16:36 PMNov 3
to astrometry
Hi, I have recently setup a local astrometry install for use in an image calibration pipeline. I have found that some images fail to solve on my local installation, but are solved when uploaded to the online service. An example of this is this image , which fails to solve locally with index files 4208, 4207.* , which should be appropriate for the field, and have solved many other exposures. Astrometry seems to detect ~2000 sources with the current settings, so I fail to see how it is unable to solve even with 600s cputime.
I am solving using the command:

solve-field {file} --overwrite --downsample 4 --ra 275 --dec -13.7 --radius 2 --scale-units degwidth --scale-low 0.4 --scale-high 0.6

Any clue why this file does not solve locally? I've tried with/without downsampling and manual ra/dec/radius inputs.

Thanks in advance,
Samuel

Dustin Lang

unread,
Nov 3, 2021, 4:30:07 PMNov 3
to Samuel Grund, astrometry
Hi,

The web service used index 4107 to get its solution.  You can get that here.

The web service also uses --downsample 2

Have a look at the *-objs.png plot to check the source detection.  To me, it does not look like this image contains more than a couple of hundred detectable stars at most, so if it reporting 2000 detected stars, that is probably an issue with estimating the noise level in the image, and generating too many false stars.  This can happen if the image is truncated to zero, for example.

cheers,
--dustin





--
You received this message because you are subscribed to the Google Groups "astrometry" group.
To unsubscribe from this group and stop receiving emails from it, send an email to astrometry+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/astrometry/20453cfa-4c43-48fe-bef5-6837624b4705n%40googlegroups.com.

Samuel Grund

unread,
Nov 4, 2021, 3:08:02 AMNov 4
to astrometry
Thanks Dustin, adding index 4107 solved the issue! 

I did not get the impression from reading the documentation on this page that indexes other than 42** would be necessary, but adding from the 41** sure helped computation time go down on all my fields.
If anyone else runs into the same issue, the matching index file from the web server can be found in the header of the new fits file.

Also, I must have seen incorrectly regarding the 2000 stars. My star finder indeed only finds a few hundred as you mention.

Reply all
Reply to author
Forward
0 new messages