problemas instalacion de Asterisk 18

23 views
Skip to first unread message

gabrie...@gmail.com

unread,
Nov 2, 2022, 11:03:28 AM11/2/22
to asterisk-es
Buenos dias estimados!

reciban mi cordial saludo, hoy les escribo quizas por una tonteria pero tengo poco mas de un dia y no lo he podido resolver, resulta que estoy tratando de instalar asterisk version 18, he seguido lo recomendado por el sitio de asterisk wiki , y sigo teniendo el mismo problema que son 2:

1.- la dependencia pjsip que solicita el ./configure de asterisk no lo baja directamente al parecer el sitio que tiene referenciado ya no existe, segui el paso alternativo de bajar los archivos compliarlos e instalarlos pero en el make install no existen unas referencias .so de la libreria y no lo puedo instalar inclusive bajandolo del github del proyecto.

2.- la libreria JANSSON, pasa lo mismo en la instalacion no la puede descargar pero intente compilarla y tambien hay referencias que no estan y arroja error.

estoy intentando instalar en un centos 7 server, y no he podido resolverlo me pueden ayudar con algun procedimiento o experiencia acerca de este problema.


Gaston Draque

unread,
Nov 2, 2022, 11:31:57 AM11/2/22
to aster...@googlegroups.com
Mis 2 centavos.

Asterisk 18 tiene pjsip bundled, no debiera ser necesario instalar el proyecto pjsip de ninguna otra fuente.

En ambos casos parece que tienes problemas de librerías requeridas, no son problemas de Asterisk.

Debieras ver cuales con las librerías que configure te tira como faltantes e ir instalándolas una por una.

Saludos y suerte!


--
Este email pertenece a la lista de Asterisk-ES (http://www.asterisk-es.org)
Normas de la lista Asterisk-ES: http://comunidad.asterisk-es.org/index.php?title=Lista:normas-asterisk-es
---
Has recibido este mensaje porque estás suscrito al grupo "asterisk-es" de Grupos de Google.
Para cancelar la suscripción a este grupo y dejar de recibir sus mensajes, envía un correo electrónico a asterisk-es...@googlegroups.com.
Para ver esta conversación en el sitio web, visita https://groups.google.com/d/msgid/asterisk-es/7dd22074-a6a4-4e2b-acab-b09e46c2b84bn%40googlegroups.com.


Juan Carlos Valero

unread,
Nov 2, 2022, 11:37:35 AM11/2/22
to aster...@googlegroups.com

Tu problema es que estas usando versiones obsoletas de asterisk, pero tambien de Linux. Por eso tienes los problemas.

Usa una distribución Linux actual (debian/redhat o similares) y la última version de Asterisk (20) para tener una instalacion limpia.


El 2/11/22 a las 16:03, gabrie...@gmail.com escribió:
--
Este email pertenece a la lista de Asterisk-ES (http://www.asterisk-es.org)
Normas de la lista Asterisk-ES: http://comunidad.asterisk-es.org/index.php?title=Lista:normas-asterisk-es
---
Has recibido este mensaje porque estás suscrito al grupo "asterisk-es" de Grupos de Google.
Para cancelar la suscripción a este grupo y dejar de recibir sus mensajes, envía un correo electrónico a asterisk-es...@googlegroups.com.
Para ver esta conversación en el sitio web, visita https://groups.google.com/d/msgid/asterisk-es/7dd22074-a6a4-4e2b-acab-b09e46c2b84bn%40googlegroups.com.
-- 
Un saludo,

Juan Carlos Valero
Capa Tres Soluciones Tecnológicas S.L.
Datos de contacto en http://capatres.tel
-------------------------------------------------------------------
LSSI: En cumplimiento de la Ley 34/2002, de 11 de Julio, de Servicios de la Sociedad de la Información y
de Comercio Electrónico (LSSI) , le comunicamos que sus datos forman parte de una base de datos
gestionada bajo la responsabilidad de CAPA TRES SOLUCIONES TECNOLÓGICAS S.L. con las finalidades de
atender el servicio contratado o del envio de información de nuestra empresa que pueda ser de su interés,
sea por su condición de cliente, porque nos haya solicitado información comercial en algún momento,
porque sus datos figuren en una fuente de acceso al público o sea porque usted ha autorizado que sus
datos figuren en un fichero comercial automatizado, así mismo le comunicamos que los datos se
conservaran mientras haya un interés mutuo para ello.
Si no quiere recibir ninguna comunicación de nuestra empresa conteste baja al correo recibido o envié
baja junto con su nombre y dirección de Correo electrónico a in...@capatres.com
Protección de Datos: De conformidad con lo dispuesto en la normativa de tratamiento de datos
personales, Reglamento (UE) 2016/679 del Parlamento Europeo y del Consejo y la Ley Orgánica 3/2018
LOPDGDD, le comunicamos que sus datos forman parte de una base de datos gestionada bajo la
responsabilidad de CAPA TRES SOLUCIONES TECNOLÓGICAS S.L.
Le informamos que puede ejercer sus derechos de acceso, rectificación, supresión y portabilidad de
datos y oposición y limitación a su tratamiento ante Capa Tres Soluciones Tecnológicas S.L. con CIF
B63846984 dirección Centro Negocios Networkia. Avda Portal de l’Angel 36. 08002 Barcelona y correo
electrónico in...@capatres.com adjuntando copia de su DNI o documento equivalente. Asimismo, y
especialmente si considera que no ha obtenido satisfacción plena en el ejercicio de sus derechos, podrá
presentar una reclamación ante la autoridad nacional de control dirigiéndose a estos efectos a la
Agencia Española de Protección de Datos, C/ Jorge Juan, 6 – 28001 Madrid.
Aviso Legal: La información contenida en este mensaje es confidencial y puede incluir datos de carácter
reservado. Esta información va dirigida únicamente a su destinatario. El acceso o su uso por parte de otra
persona no autorizada puede ser ilegal. Si no es usted la persona de destino, por favor, borre su contenido.
OpenPGP_signature

Gaston Draque

unread,
Nov 2, 2022, 11:45:10 AM11/2/22
to aster...@googlegroups.com
Ese es un buen consejo (ni hablar de esquivar Centos!) pero es bueno aclarar que Asterisk 18 no está obsoleto... aun.
Y si bien no lo elegiría para una instalación nueva, puede que OP tenga que usarlo por alguna razón que vaya a saber uno.
Ahora , si no tiene porque usar el 18, ni hablar, pasarse a la última LTS.



--
{
  "fullName" : "Gaston Draque",
  "email"    : "gaston...@gmail.com",
  "twitter"  : "@gdraque",
  "job"      : "VoIP Space Monkey",
  "tags"     : ["uc communications","telecom integrator","software developer","asterisk warrior","clouds builder"],
  "motto"     : "Clouds are made of pizza & coffee"
}

Gabriel Alejandro Mata

unread,
Nov 2, 2022, 11:53:55 AM11/2/22
to aster...@googlegroups.com
Gracias Gaston, efectivamente revise todas las dependencias están instaladas, el tema es que el ./configure de esta versión 18 incluso la 20 hace un paso de verificación de la librería pjsip y  trata de bajar los archivos de git pero esa ruta que intenta no existe lo que me pareció muy extraño intente hacerlo con la opcion --without-pjproject-bundled que aparece en la documentación y compilo bien, revise el make menu select y aparece el pjsip ¿? al final creo que el problema está en ese configure  esta obsoleto.

Por otro lado otro Juan Carlos gracias por tu ayuda me parece importante, use centos porque he visto que algunos paquetes de PBX lo usan pero si me puedes recomendar una versión de SO para probar agradecido de antemano.

Has recibido este mensaje porque estás suscrito a un tema del grupo "asterisk-es" de Grupos de Google.
Para cancelar la suscripción a este tema, visita https://groups.google.com/d/topic/asterisk-es/Uxrrsg8FsXg/unsubscribe.
Para cancelar la suscripción a este grupo y a todos sus temas, envía un correo electrónico a asterisk-es...@googlegroups.com.
Para ver esta conversación en el sitio web, visita https://groups.google.com/d/msgid/asterisk-es/CAN7SqB2-vt3u7bMqJZVFtTO-GQ%3Dm542LtWR%3DC6GhjLs%2BGM5RKg%40mail.gmail.com.


--
Ing.Gabriel Alejandro Mata
+573214814169

Gabriel Alejandro Mata

unread,
Nov 2, 2022, 11:59:21 AM11/2/22
to aster...@googlegroups.com
Gracias Juan y Gaston,

No escogí ver 18 por algo especial solo que he tenido una premisa siempre de usar versiones anteriores a la actual por cuestiones de documentación, pero tomare su consejo instalar sobre una versión más nueva y con un SO mejor si me aconsejan una agradecido.

Muchas gracias.

Gaston Draque

unread,
Nov 2, 2022, 12:28:07 PM11/2/22
to aster...@googlegroups.com
Ok, se entiende. Asterisk tiene versiones LTS y versiones Standard.
Siempre que haya una LTS *debiera* ser seguro pasarse.

OS... Debian o derivado es lo que yo prefiero, no puedo opinar de Fedora porque no lo uso, pero es la alternativa razonable si en tu empresa usan RHE.

Este email pertenece a la lista de Asterisk-ES (http://www.asterisk-es.org)
Normas de la lista Asterisk-ES: http://comunidad.asterisk-es.org/index.php?title=Lista:normas-asterisk-es
---
Has recibido este mensaje porque estás suscrito al grupo "asterisk-es" de Grupos de Google.
Para cancelar la suscripción a este grupo y dejar de recibir sus mensajes, envía un correo electrónico a asterisk-es...@googlegroups.com.
Para ver esta conversación en el sitio web, visita https://groups.google.com/d/msgid/asterisk-es/CAN7SqB2%2B4uEV2ZpkODXJ%2B0bA5o_peCpBUQySnW0G6OerJ%3DvdgA%40mail.gmail.com.


--
Ing.Gabriel Alejandro Mata
+573214814169

--
Este email pertenece a la lista de Asterisk-ES (http://www.asterisk-es.org)
Normas de la lista Asterisk-ES: http://comunidad.asterisk-es.org/index.php?title=Lista:normas-asterisk-es
---
Has recibido este mensaje porque estás suscrito al grupo "asterisk-es" de Grupos de Google.
Para cancelar la suscripción a este grupo y dejar de recibir sus mensajes, envía un correo electrónico a asterisk-es...@googlegroups.com.

gabrie...@gmail.com

unread,
Nov 3, 2022, 3:54:07 PM11/3/22
to asterisk-es
Saludos Estimados,

Este es el error que arroja el ./configure de asterisk 20, pude solucionarlo instalando la libreria manualmente, ese directorio git al que llama no existe, hice caso a sus atenciones instale en version 9 de redhat y no levantaba el servicio por alguna razon el funtions dentro del rc.d/init.d no estaba y no hubo forma, ahora estoy probando con la version 8 a ver como me va les adelanto esto que era lo que me paso al principio con la instalacion de centos.

lo solucione instalando la libreria pjsip y haciendo el configure asi ./configure --libdir=/usr/lib64 --without-pjproject-bundled

error_instalacion_ asterisk.png

Gaston Draque

unread,
Nov 3, 2022, 7:27:23 PM11/3/22
to aster...@googlegroups.com
Asi tenes que  mirar el directorio ./third-party/pjproject/ para ver que version bajar antes.

Rarisimo que te sigue fallando la bajada en configure, solo para verificar, probaste bajarlo desde ese box con wget o curl?
y si no funciona, fijate porque:

Por si le sirve a alguien o por si OP quiere cambiar de Distro (seguimos haciendo fuerza): La instalación estándar desde fuente funciona perfecto en Debian 11 / Asterisk 20.0.0 / PJSIP 2.12.2 

Saludos y suerte!

Gabriel Mata

unread,
Nov 3, 2022, 8:47:50 PM11/3/22
to aster...@googlegroups.com
Hola Gastón, si me pareció raro el tema si hice esa prueba y falla e intente también abrir la ruta en el navegador por descartar y no existe, pregunta ! Yo estoy bajando el asterisk del repo Que sale en la página digium pero vi por ahí qué hay un git también entonces eso me creo duda.

Por otro lado en redhat 8 probando hoy no pude instalar las dependencias porque no estaban en el repositorio epel en teoría aunque lo agregue.

Voy a probar con debían con Ubuntu server funciono Perfecto 

Muchas gracias por tu apoyo Gastón 

Saludos 

Ing. Gabriel Mata 

El 3/11/2022, a la(s) 6:27 p.m., Gaston Draque <gaston...@gmail.com> escribió:


Reply all
Reply to author
Forward
0 new messages