Problema uniendo Asterisk con Teams

70 views
Skip to first unread message

Javivi

unread,
Jul 20, 2022, 6:50:19 AM7/20/22
to asterisk-es
Hola buenos días, creo que esto es un Off-Topic, pero no estoy seguro de donde está el problema, si es del Asterisk o no, así que pregunto, sino disculpad..

Tengo mi Asterisk unido al Teams mediante kamailio.

Puedo recibir/hacer llamadas entre mi Asterisk y el Teams.

Hasta aquí todo bien. Desde el Teams puedo llamar al Asterisk y todo correcto, pero si llamo desde el Asterisk al Teams, en mi app del Teams recibo 3 notificaciones de llamada a la vez, tres popups, y al final quedan 3 llamadas en el historia.

Sacando una captura de la llamada, cuando llamo al Teams, veo tres 180, no se si será este el problema o no.

Y no se si será problema del Asterisk o no.

Alguna experiencia con esto?

Gracias


Pepelux

unread,
Jul 20, 2022, 6:54:36 AM7/20/22
to aster...@googlegroups.com
Buenas

Te recomiendo que uses sipdump de kamailio para ver qué se manda exactamente y qué devuelve Microsoft, porque con esta gente está todo muy oculto. A mi me pasó algo similar y era porque el servidor sip no siempre responde con la misma IP, y no sé quién será el ingeniero pero he llegado a ver que me cambia la resolución en mitad de un diálogo, por lo que te manda el 200 Ok desde una IP y cuando mandas el ACK te resuelve una IP diferente y no llega a donde debe, por lo tanto, varios replies y a los 30 seg timeout

No sé si este será tu caso, pero con el sipdump lo verás

Un saludo 

--
Este email pertenece a la lista de Asterisk-ES (http://www.asterisk-es.org)
Normas de la lista Asterisk-ES: http://comunidad.asterisk-es.org/index.php?title=Lista:normas-asterisk-es
---
Has recibido este mensaje porque estás suscrito al grupo "asterisk-es" de Grupos de Google.
Para cancelar la suscripción a este grupo y dejar de recibir sus mensajes, envía un correo electrónico a asterisk-es...@googlegroups.com.
Para ver esta conversación en el sitio web, visita https://groups.google.com/d/msgid/asterisk-es/281a2ae6-b37c-4102-8802-0754a05b55ben%40googlegroups.com.

Javivi

unread,
Jul 20, 2022, 10:45:47 AM7/20/22
to asterisk-es
Hola Pepelux, muchas gracias..

No es mi caso, la llamada va bien, la conversación va bien, no hay cortes, todo correcto, solo que me llegan 3 notificaciones, como si estuviera recibiendo 3 llamadas a la vez, si descuelgo una, las otras dos desaparecen y puedi mantener la conversación.

He sacado una captura y lo mismo, lo único que veo son tres 183, no veo nada más..

Q podría mirar?

Gracias

Pepelux

unread,
Jul 20, 2022, 10:56:58 AM7/20/22
to aster...@googlegroups.com
Son tres 183 desde tu Asterisk hacia Microsoft? no tendrás el usuario registrado 3 veces?

Javivi

unread,
Jul 20, 2022, 11:37:42 AM7/20/22
to asterisk-es
Si y no, ejejje, si son tres 183 desde mi Asterisk a mi Teams, pero solo lo tengo registrado una vez...

Javivi

unread,
Jul 21, 2022, 3:39:17 AM7/21/22
to asterisk-es
Buscando un poco mas y depurando las trazas, veo que en el mismo INVITE tengo tres 183, cada 183 tiene una IP diferente, como tú decias Pepelux..

Por ejemplo:

SIP/2.0 183 Session Progress

v=0
o=- 4396 0 IN IP4 127.0.0.1
s=session
c=IN IP4 52.112.151.187
b=CT:10000000
t=0 0
m=audio 50384 RTP/SAVP 8 101
c=IN IP4 52.112.151.187
a=rtcp:50385
a=label:main-audio
a=mid:1
a=crypto:1 AES_CM_128_HMAC_SHA1_80 inline:+gKw8zlMP07uokiw7iyHn/dNw86wYG4YtaB7z7nl|2^31
a=sendrecv
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20

Luego tengo varios 180 y de repente otro 183:

v=0
o=- 227889 0 IN IP4 127.0.0.1
s=session
c=IN IP4 52.113.59.61
b=CT:10000000
t=0 0
m=audio 50572 RTP/SAVP 8 101
c=IN IP4 52.113.59.61
a=rtcp:50573
a=label:main-audio
a=mid:1
a=crypto:1 AES_CM_128_HMAC_SHA1_80 inline:Ljp81mfvOi0T4vrcJfsygJ687NQdS/dWisUtFX34|2^31
a=sendrecv
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20

Luego otra vez varios 180 y otra vez un 183:

v=0
o=- 118195 0 IN IP4 127.0.0.1
s=session
c=IN IP4 52.112.197.237
b=CT:10000000
t=0 0
m=audio 52676 RTP/SAVP 8 101
c=IN IP4 52.112.197.237
a=rtcp:52677
a=label:main-audio
a=mid:1
a=crypto:1 AES_CM_128_HMAC_SHA1_80 inline:D3L14rEWXf5BU2JYG+j6SNOD/+0Qq7WAkh8N41Qo|2^31
a=sendrecv
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20

Y hasta ahí, esto te suena Pepelux? Como podría evitarlo?

Gracias

Pepelux

unread,
Jul 21, 2022, 5:54:58 AM7/21/22
to aster...@googlegroups.com
Buenas

No mires la IP del SDP sino de quién te manda los paquetes y a quién respondes. Con el sipdump te sale un resumen arriba de cada paquete.

Si es el caso, yo lo solucioné anotando la IP desde donde me llega el 200 Ok desde Teams (lo hice desde Kamailio) y respondiendo el ACK directamente a esa IP, en lugar de hacerlo al dominio sip.xxxxx.microsoft.com

Un saludo

Pepelux

unread,
Jul 21, 2022, 6:00:51 AM7/21/22
to aster...@googlegroups.com
Creo que te he contestado también a la lista de Kamailio ... o es otro Javi con el mismo problema xDD

Javivi

unread,
Jul 21, 2022, 6:39:03 AM7/21/22
to asterisk-es
Muchas gracias
.. Si soy yo.. no estab seguro de si era probnlema de Asterisk o del kamailio....

Respondo en la lista del Kamailio.

Muchas gracias

Javivi

unread,
Jul 21, 2022, 6:48:40 AM7/21/22
to asterisk-es
Todavía no estoy aprobado en la lista de kamailio y no puedo responder ahi..

En la traza veo que se generan 3 INVITE distintos a 3 IPs distintas de Microsoft, con sus respectivos tres TRYING, y sus tres 183... 180....

Es decir, parece que cuando lanzo la llamada desde, en este caso, el kamailio, se lanzan 3 ..

No se si podrá ser el caso o no, pero tengo el Asterisk y el Kamailio en la misma máquina, escuchando puertos diferentes.. podría venir por ahí el problema?

Gracias

Javivi

unread,
Jul 26, 2022, 6:51:00 AM7/26/22
to asterisk-es
Vale, solucionado, al final era problema de la configuración del kamailio.

Muchas garcias a todos.
Reply all
Reply to author
Forward
0 new messages