Duda de configuración para desvíos

10 views
Skip to first unread message

Javivi

unread,
Apr 27, 2022, 6:17:23 AMApr 27
to asterisk-es
Hola buenos días, tengo una duda, no tengo claro como hacer una cosa, o si la estoy haciendo bien o no.

Os explico, mis extensiones están por realtime, por lo que para llamarlas, en el extensions.conf, en el contexto adecuado, tengo un switch.

En el realtime, en la tabla extensions, tengo dicho que cuando se marca la 100, haga ciertas cosas, una de ellas es comprobar si un valor de la DB está a 1 o a 0, si está a 1 es que esa aextensión ha activado el desvío, y en otro campo tengo el destino, si está a 0 no lo tiene activado.

Si está a 1, cojo el valor del otro campo, el del destino, y hago una llamada a Local/${DESTINO}@contexo.

Es decir, si alguien marca 100 y esta tiene un desvío a un móvil, en vez de sonar la 100, suena el móvil.

Hasta aquí todo correcto, no se si estraá bien hecho o doy muchas vueltas..

La cosa es , si la extensión 101 llama a la 100 y esta tiene desviado al 600000000, cuando hago la llamada al 600000000 no veo la extensión que me ha llamada a la 100, solo veo, en el campo connectedlinenum la 100.

Habría alguna forma de poder saber la extensión que ha llamado a la 100, cuando tengo el desvío activado?

O si hay alguna forma mejor de hacer esto...

Muchas gracias.

Javivi

unread,
Apr 28, 2022, 5:04:12 AMApr 28
to asterisk-es
Nada, ya está, lo estaba sobreescribiendo yo..

Gracias
Reply all
Reply to author
Forward
0 new messages