Problème avec une propriété d'une entité !

5 views
Skip to first unread message

inform...@gmail.com

unread,
Apr 29, 2019, 4:13:51 AM4/29/19
to Association Francophone des Utilisateurs de Symfony
Bonjour
J'ai crée une entitée User avec cette propriété :
/**
 * @ORM\Column(type="json")
 */

 
private $roles = [];

Et j'obtiens cette erreur que json n'est pas supporté par la version du serveur. Je supprime alors la propriété ensuite je supprime même l'entité et vidé le cache, rien à faire ! 

Besoin d'aide ! et j'ai toujours cette même erreur, je vous montre l'ecran (voir PJ)

merci

Anouchka


Croquis (1).png

Crown Backend

unread,
Apr 29, 2019, 4:18:59 AM4/29/19
to asso...@googlegroups.com
C’est un problème de syntaxe sql tu utilise un mot réservé, tu utilise mariadb ou mysql ?

--
Vous recevez ce message, car vous êtes abonné au groupe Google Groupes "Association Francophone des Utilisateurs de Symfony".
Pour vous désabonner de ce groupe et ne plus recevoir d'e-mails le concernant, envoyez un e-mail à l'adresse asso-afsy+...@googlegroups.com.
Pour obtenir davantage d'options, consultez la page https://groups.google.com/d/optout.

Mathieu M

unread,
Apr 29, 2019, 6:48:39 AM4/29/19
to asso...@googlegroups.com
Visiblement tu utilises mariadb, essaie de vérifier si tu as bien la bonne version de configuré dans ta config doctrine et si ton serveur mariadb supporte le type json nativement

Crown Backend

unread,
Apr 29, 2019, 6:58:38 AM4/29/19
to asso...@googlegroups.com
J’ai eu le même soucis j’ai du changé et utilisé mysql 

Victor Brillant Mory Jinabo

unread,
Apr 29, 2019, 7:04:28 AM4/29/19
to asso...@googlegroups.com
Salut tout le monde,
J'ai une question, y t'il un bundle sur symfony 4 pour gérer les paiements en ligne comme Paypal, visa ?

Merci

inform...@gmail.com

unread,
Apr 29, 2019, 7:05:47 AM4/29/19
to Association Francophone des Utilisateurs de Symfony
j'ai résolu le problème en utilisant ces commandes:
php bin/console doctrine:schema:update --dump-sql
php bin
/console doctrine:schema:update --force

Avant j'utilisais ça et ça bloquait:
php bin/console doctrine:migration:diff
php bin
/console doctrine:migration:migrate

Reply all
Reply to author
Forward
0 new messages