Installer symfony 4 sur l'hébergement mutualisé 1&1

46 views
Skip to first unread message

MINKOUE OBAME Anouchka

unread,
Jul 10, 2019, 11:43:15 AM7/10/19
to Association Francophone des Utilisateurs de Symfony
Bonjour
Qui a déjà installé symfony 4 sur l'hébergement mutualisé 1&1 ? J'y arrive pas, je constate déjà que tous les dossiers vendor ne sont pas présents.
Comment faire svp ?
Merci de votre aide !

Franck R

unread,
Jul 10, 2019, 11:50:00 AM7/10/19
to asso...@googlegroups.com
Bonjour, il y a plusieurs manières de déployer un site Web. Il faut avant tout préparer l'environnement de production.
Pour les dépendances je te conseille d'utiliser composer pour les installer (comme en environnement dev).

--
Vous recevez ce message, car vous êtes abonné au groupe Google Groupes "Association Francophone des Utilisateurs de Symfony".
Pour vous désabonner de ce groupe et ne plus recevoir d'e-mails le concernant, envoyez un e-mail à l'adresse asso-afsy+...@googlegroups.com.
Cette discussion peut être lue sur le Web à l'adresse https://groups.google.com/d/msgid/asso-afsy/5401ac43-edd1-4aea-bff7-95b34a3e439a%40googlegroups.com.
Pour obtenir davantage d'options, consultez la page https://groups.google.com/d/optout.

Franck R

unread,
Jul 10, 2019, 11:58:04 AM7/10/19
to asso...@googlegroups.com
Je te conseille de visionner ce tuto de grafikart qui est bien expliqué

MINKOUE OBAME Anouchka

unread,
Jul 11, 2019, 9:52:24 AM7/11/19
to Association Francophone des Utilisateurs de Symfony
J'ai uploadé tous les dossiers et fichiers sur mon serveur 1&1 mais j'obtiens cette erreur:
Fatal error: require_once(): Failed opening required '/homepages/0/d513201601/htdocs/factures_devis_symfony4/vendor/composer/autoload_real.php' (include_path='.:/usr/lib/php7.3') in /homepages/0/d513201601/htdocs/factures_devis_symfony4/vendor/autoload.php on line 5

Quelqu'un peut-il m'aider ? 

MINKOUE OBAME Anouchka

unread,
Jul 11, 2019, 11:02:19 AM7/11/19
to Association Francophone des Utilisateurs de Symfony
Désolée je n'avais pas mis tous les fichier avec la comande mais j'ai uploadé tous manuellement. Mais j'obtiens cette erreur :

Fatal error: Uncaught RuntimeException: Please run "composer require symfony/dotenv" to load the ".env" files configuring the application. in /homepages/0/d513201601/htdocs/factures_devis_symfony4/config/bootstrap.php:12 Stack trace: #0 /homepages/0/d513201601/htdocs/factures_devis_symfony4/public/index.php(7): require() #1 {main} thrown in /homepages/0/d513201601/htdocs/factures_devis_symfony4/config/bootstrap.php on line 12

Quand je tape la commande  composer require symfony/dotenv  depuis mon dossier projet, la console 1&1 me dit qu'il ne reconnait pas la commande composer. J'ai bien installé composer à la racine de mon hébergement.
 

Le mercredi 10 juillet 2019 17:43:15 UTC+2, MINKOUE OBAME Anouchka a écrit :

Crown Backend

unread,
Jul 11, 2019, 11:51:45 AM7/11/19
to asso...@googlegroups.com
Salut à tu fait un composer install ? Y a t’il un dossier vendor sur ton serveur ?

--
Vous recevez ce message, car vous êtes abonné au groupe Google Groupes "Association Francophone des Utilisateurs de Symfony".
Pour vous désabonner de ce groupe et ne plus recevoir d'e-mails le concernant, envoyez un e-mail à l'adresse asso-afsy+...@googlegroups.com.

Awaki-Esso HOUZOU [ TPM - Engineering & Infrastructure | KuTiWa ]

unread,
Jul 11, 2019, 11:57:32 AM7/11/19
to asso...@googlegroups.com, MINKOUE OBAME Anouchka

IL faut tester ceci.

  • Copier le fichier composer.phar issue de l’installation de composer à la racine du projet symfony
  • Exécuter la commande suivante php composer.phar require symfony/dotenv  .
 
 
---

.

 

Cordialement.

— -- 
Awaki-Esso HOUZOU.
Technical Project Manager
Office : (+22177 362 16 30
Togo : (+228) 922 440 99
KuTiWa – Donnez de l'Elégance à votre travail. 
 
 

 

 

 

 

 

--
Vous recevez ce message, car vous êtes abonné au groupe Google Groupes "Association Francophone des Utilisateurs de Symfony".
Pour vous désabonner de ce groupe et ne plus recevoir d'e-mails le concernant, envoyez un e-mail à l'adresse asso-afsy+...@googlegroups.com.

MINKOUE OBAME Anouchka

unread,
Jul 11, 2019, 12:06:39 PM7/11/19
to Association Francophone des Utilisateurs de Symfony
Oui j'ai le dossier vendor mais il n'était pas complet avec la commande d'installation de symfony. J'ai tout complété manuellement. A près j'ai eu l'erreur 404 j'ai alors ajouter le fichier .htacess que j'ai trouvé sur gitthub maintenant j'ai une erreur 500, j'essaie de debugger en mettant dans .env , APP_ENV=dev et je n'ai pas accès au débogage 


Le mercredi 10 juillet 2019 17:43:15 UTC+2, MINKOUE OBAME Anouchka a écrit :

Franck R

unread,
Jul 11, 2019, 12:10:21 PM7/11/19
to asso...@googlegroups.com
Dans la console ssh chez 1and1 ionos ne pas oublier /usr/bin/php7. 1-cli avant la commande


--
Vous recevez ce message, car vous êtes abonné au groupe Google Groupes "Association Francophone des Utilisateurs de Symfony".
Pour vous désabonner de ce groupe et ne plus recevoir d'e-mails le concernant, envoyez un e-mail à l'adresse asso-afsy+...@googlegroups.com.

Crown Backend

unread,
Jul 11, 2019, 12:29:51 PM7/11/19
to asso...@googlegroups.com
Il faut configurer le fichier .env il le trouve pas il te le dit là 

--
Vous recevez ce message, car vous êtes abonné au groupe Google Groupes "Association Francophone des Utilisateurs de Symfony".
Pour vous désabonner de ce groupe et ne plus recevoir d'e-mails le concernant, envoyez un e-mail à l'adresse asso-afsy+...@googlegroups.com.

MINKOUE OBAME Anouchka

unread,
Jul 11, 2019, 4:12:38 PM7/11/19
to Association Francophone des Utilisateurs de Symfony
@Belhassen, le ficher .env avec les informations de la base de données est bien sur le serveur. Y a t-il quelque chose à faire en plus pour ce fichier ? 


Le jeudi 11 juillet 2019 18:29:51 UTC+2, Belhassen a écrit :
Il faut configurer le fichier .env il le trouve pas il te le dit là 
Le jeu. 11 juil. 2019 à 17:02, MINKOUE OBAME Anouchka <inform...@gmail.com> a écrit :
Désolée je n'avais pas mis tous les fichier avec la comande mais j'ai uploadé tous manuellement. Mais j'obtiens cette erreur :

Fatal error: Uncaught RuntimeException: Please run "composer require symfony/dotenv" to load the ".env" files configuring the application. in /homepages/0/d513201601/htdocs/factures_devis_symfony4/config/bootstrap.php:12 Stack trace: #0 /homepages/0/d513201601/htdocs/factures_devis_symfony4/public/index.php(7): require() #1 {main} thrown in /homepages/0/d513201601/htdocs/factures_devis_symfony4/config/bootstrap.php on line 12

Quand je tape la commande  composer require symfony/dotenv  depuis mon dossier projet, la console 1&1 me dit qu'il ne reconnait pas la commande composer. J'ai bien installé composer à la racine de mon hébergement.
 

Le mercredi 10 juillet 2019 17:43:15 UTC+2, MINKOUE OBAME Anouchka a écrit :
Bonjour
Qui a déjà installé symfony 4 sur l'hébergement mutualisé 1&1 ? J'y arrive pas, je constate déjà que tous les dossiers vendor ne sont pas présents.
Comment faire svp ?
Merci de votre aide !

--
Vous recevez ce message, car vous êtes abonné au groupe Google Groupes "Association Francophone des Utilisateurs de Symfony".
Pour vous désabonner de ce groupe et ne plus recevoir d'e-mails le concernant, envoyez un e-mail à l'adresse asso...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages