Problem with double-quotes

94 views
Skip to first unread message
Message has been deleted

Glenn Eychaner

unread,
Nov 4, 2010, 10:50:57 AM11/4/10
to asciidoc digest subscribers
[Sorry for forgetting to change the title on the initial send. I'm an idiot.]

Version: AsciiDoc 8.6.1
A simple piece of text that demonstrates a problem with the behavior of quotes:

The telescope server will respond to a wait request with a string containing a
zero (``+0\n+'') if the wait condition (e.g. telescope move) has completed, a
one (``+1\n+'') if the wait condition failed to complete, and a negative number
(usually ``+{amp}minus;1\n+'') if the wait request was rejected.

The quotes end up completely mangled. I want each parenthesized expression to have curly-quotes, but they don't. Changing to single-quotes doesn't seem to help.

-G.
--
Glenn Eychaner (geyc...@lco.cl)
Telescope Systems Programmer, Las Campanas Observatory

mattn

unread,
Nov 4, 2010, 11:59:07 PM11/4/10
to asciidoc
Every once in a while I just have to type literal curly quotes into
the document to handle this sort of situation. m.
> Glenn Eychaner (geycha...@lco.cl)

Stuart Rackham

unread,
Nov 7, 2010, 3:05:59 PM11/7/10
to asci...@googlegroups.com
Hi Glenn

On 05/11/10 03:50, Glenn Eychaner wrote:
> [Sorry for forgetting to change the title on the initial send. I'm an idiot.]
>
> Version: AsciiDoc 8.6.1
> A simple piece of text that demonstrates a problem with the behavior of quotes:
>
> The telescope server will respond to a wait request with a string containing a
> zero (``+0\n+'') if the wait condition (e.g. telescope move) has completed, a
> one (``+1\n+'') if the wait condition failed to complete, and a negative number
> (usually ``+{amp}minus;1\n+'') if the wait request was rejected.
>
> The quotes end up completely mangled. I want each parenthesized expression to have curly-quotes, but they don't. Changing to single-quotes doesn't seem to help.

The ` characters were being misinterpreted as inline literal passthroughs, I've
committed a patch that should fix the problem. Please test it and report back:

http://code.google.com/p/asciidoc/source/detail?r=01de53f4642e075615ea0e25d77ef377f91f97f2


Cheers, Stuart

GEychaner

unread,
Nov 11, 2010, 2:08:19 PM11/11/10
to asciidoc
On Nov 7, 5:05 pm, Stuart Rackham <srack...@gmail.com> wrote:
>
> The ` characters were being misinterpreted as inline literal passthroughs, I've
> committed a patch that should fix the problem. Please test it and report back:
>
> http://code.google.com/p/asciidoc/source/detail?r=01de53f4642e075615e...

Patch seems to have fixed the problem. And thankfully, the quotes
aren't too "grabby", so muliple quotes in a single line or paragraph
also work. Thanks!

-G.
Reply all
Reply to author
Forward
0 new messages