when using slidy backend, display of characters with accents is wrong because of "meta http-equiv" line missing

37 views
Skip to first unread message

themroc

unread,
Sep 1, 2011, 9:44:23 AM9/1/11
to asciidoc
Trying to convert an asciidoc document using the slidy backend.
The document is written in french and contains lots of accents.
The produced XHTML file is correctly written in UTF-8.
Konqueror and w3m are displaying the file correctly.
Iceweasel is displaying wrong wharacters like: é

In the produced XHTML, we expect such a line in the header but it is
not present:

<meta http-equiv="Content-Type" content="application/xhtml+xml;
charset=UTF-8" />

If i add this line to the XHTML file, the display is correct again.

The generation of this line should be added in the [header] section
of /etc/asciidoc/slidy.conf, like it is present in /etc/asciidoc/
xhtml11.conf :

<meta http-equiv="Content-Type" content="{quirks=application/xhtml+xml}
{quirks?text/html}; charset={encoding}" />

see : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=640013

Stuart Rackham

unread,
Sep 2, 2011, 11:04:06 PM9/2/11
to asci...@googlegroups.com
Thanks for reporting the problem Fabrice. I've fixed it in the trunk:

http://code.google.com/p/asciidoc/source/detail?r=e2207a36550c2580b5505cc81e0a792082137f72

Cheers, Stuart


On 02/09/11 01:44, themroc wrote:
> Trying to convert an asciidoc document using the slidy backend.
> The document is written in french and contains lots of accents.
> The produced XHTML file is correctly written in UTF-8.
> Konqueror and w3m are displaying the file correctly.

> Iceweasel is displaying wrong wharacters like: é

Fabrice Flore-Thébault

unread,
Sep 8, 2011, 9:23:55 AM9/8/11
to asci...@googlegroups.com
thanks a lot Stuart !

asciidoc is a great tool, i like it to write documentations and slides ;)
Reply all
Reply to author
Forward
0 new messages