cuda problem

70 views
Skip to first unread message

gd l

unread,
Feb 22, 2022, 8:03:07 AMFeb 22
to ArrayFire Users
I install ArrayFire-v3.8.1_Linux_x86_64_CUDA-11.4 on my ubuntu21.10.
both cpu and opencl backend work. But cuda crashed. And different examples different errors.
first one is like 
ArrayFire v3.9.0 (CUDA, 64-bit Linux, build 1d03d07)
Platform: CUDA Runtime 11.4, Driver: 470.103.01
[0] NVIDIA GeForce GTX 950M, 4047 MB, CUDA Compute 5.0
Create a 5-by-3 matrix of random floats on the GPU
A
[5 3 1 1]
ArrayFire Exception (Internal error:998):
In function print
In file src/api/c/print.cpp:99
 0# 0x00007F517EA515FF in /opt/arrayfire/lib64/libafcuda.so.3
 1# af_print_array_gen in /opt/arrayfire/lib64/libafcuda.so.3
 2# af::print(char const*, af::array const&) in /opt/arrayfire/lib64/libafcuda.so.3
 3# main in ./helloworld_cuda
 4# 0x00007F5179188FD0 in /lib/x86_64-linux-gnu/libc.so.6
 5# __libc_start_main in /lib/x86_64-linux-gnu/libc.so.6
 6# _start in ./helloworld_cuda

second is like
ArrayFire Exception (Internal error:998):
In function compileModule
In file src/backend/cuda/compile_module.cpp:279
NVRTC Error(7): NVRTC_ERROR_BUILTIN_OPERATION_FAILURE
Log:
nvrtc: error: failed to open libnvrtc-builtins.so.11.4.
  Make sure that libnvrtc-builtins.so.11.4 is installed correctly.

 0# 0x00007FDE9B59F9B0 in /opt/arrayfire/lib64/libafcuda.so.3
 1# 0x00007FDE9C82DBA2 in /opt/arrayfire/lib64/libafcuda.so.3
 2# 0x00007FDE9B9F906C in /opt/arrayfire/lib64/libafcuda.so.3
 3# 0x00007FDE9B9FD191 in /opt/arrayfire/lib64/libafcuda.so.3
 4# 0x00007FDE9B9FE017 in /opt/arrayfire/lib64/libafcuda.so.3
 5# 0x00007FDE9B53A269 in /opt/arrayfire/lib64/libafcuda.so.3
 6# af_eval in /opt/arrayfire/lib64/libafcuda.so.3
 7# af::array::eval() const in /opt/arrayfire/lib64/libafcuda.so.3
 8# 0x00007FDE9C763764 in /opt/arrayfire/lib64/libafcuda.so.3
 9# af::array::operator()(af::index const&, af::index const&, af::index const&, af::index const&) const in /opt/arrayfire/lib64/libafcuda.so.3
10# af::array::operator()(a


gd l

unread,
Feb 24, 2022, 10:19:46 AMFeb 24
to ArrayFire Users
I know how to solve it.
sudo apt install nvidia-cuda-toolkit

gd l <lgd144...@gmail.com> 于2022年2月22日周二 21:03写道:
--
You received this message because you are subscribed to the Google Groups "ArrayFire Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to arrayfire-use...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/arrayfire-users/f5c89757-ba41-4938-9c76-25eb96867bc5n%40googlegroups.com.

John Melonakos

unread,
Mar 1, 2022, 3:16:32 PMMar 1
to ArrayFire Users
Wonderful, let us know if there are any other questions as you make progress.
Reply all
Reply to author
Forward
0 new messages