Error with process function: package sfit not found

9 views
Skip to first unread message

Mirko Pisati

unread,
Nov 12, 2020, 3:43:54 PM11/12/20
to aroma.affymetrix
Hi ,
I have a problem with the process function where it says csC
csC <- process (acc, verbose = verbose)
print (csC).
Failed with error:  ‘there is no package called ‘sfit’’
I have copy number data of a geo dateset and i want to process it with this package. I saw the Vignette page of the package and I followed all the setup steps step by step.
R gives me the error in which it says it does not find the sfit package, if I try to install it from outside with different functions, they all tell me that the package is not found or not available for my version of r WHICH is 4.0.3 , the last.
> source('http://callr.org/install#HenrikBengtsson/sfit')
> install.packages("remotes")
> remotes::install_github("HenrikBengtsson/sfit")
Error in file (filename, "r", encoding = encoding):
  I can't open this connection
Also: Warning message:
In file (filename, "r", encoding = encoding):
  cannot open URL 'http://callr.org/install#HenrikBengtsson/sfit': HTTP status was '400 Bad Request'
> remotes::install_github("HenrikBengtsson/sfit")
Downloading GitHub repo HenrikBengtsson/sfit@HEAD
√  checking for file 'C:\Users\mirko\AppData\Local\Temp\Rtmp0U19NX\remotes46d42edc29b\HenrikBengtsson-sfit-dd85e19/DESCRIPTION' (736ms)
-  preparing 'sfit':
√  checking DESCRIPTION meta-information ...
-  cleaning src
-  checking for LF line-endings in source and make files and shell scripts (637ms)
-  checking for empty or unneeded directories
-  building 'sfit_0.3.1.tar.gz'
   
Installing package into ‘C:/Users/mirko/Documents/R/win-library/4.0’
(as ‘lib’ is unspecified)
* installing *source* package 'sfit' ...
** using staged installation
** libs
  running 'src/Makefile.win' ...
cc    -c -o cfit.o cfit.c
make: cc: Command not found
make: *** [<builtin>: cfit.o] Error 127
ERROR: compilation failed for package 'sfit'
* removing 'C:/Users/mirko/Documents/R/win-library/4.0/sfit'
Errore: Failed to install 'sfit' from GitHub:
  (contertito da avviso) installation of package ‘C:/Users/mirko/AppData/Local/Temp/Rtmp0U19NX/file46d4153539da/sfit_0.3.1.tar.gz’ had non-zero exit status
> sessionInfo()
R version 4.0.3 (2020-10-10)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 19041)

Matrix products: default

locale:
[1] LC_COLLATE=Italian_Italy.1252  LC_CTYPE=Italian_Italy.1252    LC_MONETARY=Italian_Italy.1252 LC_NUMERIC=C                   LC_TIME=Italian_Italy.1252    

attached base packages:
[1] parallel  stats4    stats     graphics  grDevices utils     datasets  methods   base    

other attached packages:
[1] SummarizedExperiment_1.18.2 DelayedArray_0.14.1         matrixStats_0.57.0          Biobase_2.48.0              GenomicRanges_1.40.0      
[6] GenomeInfoDb_1.24.2         IRanges_2.22.2              S4Vectors_0.26.1            BiocGenerics_0.34.0        

loaded via a namespace (and not attached):
 [1] compiler_4.0.3         BiocManager_1.30.10    XVector_0.28.0         prettyunits_1.1.1      R.methodsS3_1.8.1      bitops_1.0-6          
 [7] R.utils_2.10.1         remotes_2.2.0          tools_4.0.3            zlibbioc_1.34.0        pkgbuild_1.1.0         preprocessCore_1.50.0
[13] lattice_0.20-41        Matrix_1.2-18          cli_2.1.0              rstudioapi_0.11        curl_4.3               GenomeInfoDbData_1.2.3
[19] withr_2.3.0            rprojroot_1.3-2        grid_4.0.3             glue_1.4.2             R6_2.4.1               processx_3.4.4        
[25] fansi_0.4.1            callr_3.5.1            backports_1.1.10       ps_1.4.0               assertthat_0.2.1       affy_1.66.0          
[31] RCurl_1.98-1.2         crayon_1.3.4           affyio_1.58.0          R.oo_1.24.0          
Please, can someone help me ?  

Henrik Bengtsson

unread,
Nov 12, 2020, 7:58:34 PM11/12/20
to aroma-affymetrix
Hi.

The 'sfit' package is special, preventing me from submitting it to
CRAN without a major rewrite. Because of this, it's not available
from CRAN and there's no pre-built Windows binary for it either, which
is what you're running into here.

I basically have to manually build Windows binaries and make them
available elsewhere, which I've forgotten for a while now. I've made
one for R 4.0.x available, assuming that's what you're running. I've updated

https://github.com/HenrikBengtsson/sfit

with instructions for installing 'sfit', including on Windows.

Let me know if it works,

Henrik
> --
> --
> When reporting problems on aroma.affymetrix, make sure 1) to run the latest version of the package, 2) to report the output of sessionInfo() and traceback(), and 3) to post a complete code example.
>
>
> You received this message because you are subscribed to the Google Groups "aroma.affymetrix" group with website http://www.aroma-project.org/.
> To post to this group, send email to aroma-af...@googlegroups.com
> To unsubscribe and other options, go to http://www.aroma-project.org/forum/
>
> ---
> You received this message because you are subscribed to the Google Groups "aroma.affymetrix" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to aroma-affymetr...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/aroma-affymetrix/082efd76-8546-4708-9ef8-2b7618a64117n%40googlegroups.com.

Mirko Pisati

unread,
Nov 13, 2020, 10:13:06 AM11/13/20
to aroma.affymetrix
Hi, thanks for your help, now the package works.
Yesterday among the various attempts I made I ran the function in R in the image below and from there the package was active and worked correctly.
cordially Pisati Mirko

Reply all
Reply to author
Forward
0 new messages