Problems with sql database tables 2

38 views
Skip to first unread message

Marco C.

unread,
May 11, 2018, 5:30:53 AM5/11/18
to arkusers
Hi
I encountered the same problem Kristina experienced (see the topic 'Problems with sql database tables') . I installed Ark 1.1.2, I changed the user,I copied the tables php files from config_sgl_cxt to config folder  but now I cannot see any table.
Unlike Kristina, I don't get any error message.
After having checked admin and user manuals, I found this topic in the blog. However, it is not clear to me where to insert the SQL quoted by Michael in the previous topic.
So, does anybody have any suggestions about how adding pre-configured tables to the DB and/or how creating new ones manually?
Many thanks ;)

Marco

j.l...@lparchaeology.com

unread,
May 11, 2018, 10:13:15 AM5/11/18
to arkusers
Hi Marco,

Have you tried following the detailed instructions at https://ark.lparchaeology.com/wiki/index.php/Basic_Installation?

The general steps are:
* Unzip the download in the web server root folder (usually in a subfolder with the name of your site)
* Create a database and user, easiest done using phpMyAdmin
* Import the config_sgl_cxt/arkv1_1.sql file into the database
* Import the config_sgl_cxt/ark_cxt.sql file into the database
* Copy the config_sgl_cxt/*.php files into the config folder
* Edit the config/env_settings.php file to point to your install and to use your database

After that it should all work. Please let us know if it doesn't, and at what step above you have problems. One particular point to carefully check is that you have the correct $ark_dir and $ark_server_path set in env_settings.php.

Thanks!

John.

Marco C.

unread,
May 12, 2018, 1:05:03 PM5/12/18
to arkusers

Hi John

Thank you very much for your quick reply and detailed instructions.

I installed everything again from scratch and now I can see and manage the tables on the left panel.
Feasibly, I did not import the config_sgl_cxt/ark_cxt.sql file into the database during the previous installation (I just imported arkv1_1.sql file). I added it later using MyphpAdmin but it stalled.

In the import tab in MyphpAdmin I unticked: Do not use AUTO_INCREMENT for zero values.

Preflight checks have been passed with the sole exception of phMagick.

However, I still have encountered the following three problems:

1) As previously, I got the following error message when creating in Ark a new user in the User Administration Tab:

An Error occurred!Error in query Add user err: SQLSTATE[22007]: Invalid datetime format: 1292 Incorrect datetime value: '0000-00-00 00:00:00' for column 'cre_on' at row 1

I fixed it deleting the NO_ZERO_DATE flag set in the sql_mode setting of the MySQL ini file, as suggested here:


2) After log in Ark I get these two warning messages:

Warning: include_once(PEAR5.php): failed to open stream: No such file or directory in C:\wamp\www\kydb\lib\php\pear\PEAR.php on line 730

and

Warning: include_once(): Failed opening 'PEAR5.php' for inclusion (include_path='C:\wamp\www\kydb\lib\php\pear;.;C:\php\pear;C:\wamp\www\kydb\lib\php\pear;C:\wamp\www\kydb\lib\php\pear') in C:\wamp\www\kydb\lib\php\pear\PEAR.php on line 730


3) Eventually, I get the following warning message when creating a new record in the Data Entry tab, irrespective of the table I am using:

Warning: array_key_exists() expects parameter 2 to be array, string given in C:\wamp\www\kydb\php\update_db.php on line 128


I installed Ark 1.1.2. using the versions of the dependencies included in Wampserver 3.1.3.


Many thanks in advance for your support :)

Marco
Reply all
Reply to author
Forward
0 new messages