Error when open Argosoft

48 views
Skip to first unread message

Ken Poulsen

unread,
Jul 25, 2020, 2:00:36 PM7/25/20
to ArGoSoft Products
Hi Archi

Im getting this error when i try to open Argosoft mail. (if i click continue, it does open)

I can see it says im missing system.xml.xlm (what should that look like a where...)

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Configuration.ConfigurationErrorsException: Configuration system failed to initialize ---> System.Configuration.ConfigurationErrorsException: Root element is missing. (C:\Users\Administrator\AppData\Local\ArGo_Software_Design\MailServerUi.exe_Url_3vhhkgkf01ahwzvn2h41tcj3h40wlapl\1.2.4.0\user.config) ---> System.Xml.XmlException: Root element is missing.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at System.Configuration.XmlUtil..ctor(Stream stream, String name, Boolean readToFirstElement, ConfigurationSchemaErrors schemaErrors)
   at System.Configuration.BaseConfigurationRecord.InitConfigFromFile()
   --- End of inner exception stack trace ---
   at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
   at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
   at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(Object sender, InternalConfigEventArgs e)
   --- End of inner exception stack trace ---
   at System.Configuration.ConfigurationManager.PrepareConfigSystem()
   at System.Configuration.ConfigurationManager.RefreshSection(String sectionName)
   at System.Configuration.ClientSettingsStore.ReadSettings(String sectionName, Boolean isUserScoped)
   at System.Configuration.LocalFileSettingsProvider.GetPropertyValues(SettingsContext context, SettingsPropertyCollection properties)
   at System.Configuration.SettingsBase.GetPropertiesFromProvider(SettingsProvider provider)
   at System.Configuration.SettingsBase.SetPropertyValueByName(String propertyName, Object propertyValue)
   at System.Configuration.SettingsBase.set_Item(String propertyName, Object value)
   at System.Configuration.ApplicationSettingsBase.set_Item(String propertyName, Object value)
   at MailServerUi.Properties.Settings.set_WindowSize(Size value)
   at MailServerUi.MailServerMainForm.MailServerMainForm_FormClosing(Object sender, FormClosingEventArgs e)
   at System.Windows.Forms.Form.OnFormClosing(FormClosingEventArgs e)
   at System.Windows.Forms.Form.WmClose(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4069.0 built by: NET48REL1LAST_B
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
MailServerUi
    Assembly Version: 1.2.4.0
    Win32 Version: 1.2.4.0
    CodeBase: file:///C:/Program%20Files/ArGo%20Software%20Design/ArGoSoft%20Mail%20Server%20.NET/MailServerUi.exe
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4001.0 built by: NET48REL1LAST_C
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4042.0 built by: NET48REL1LAST_C
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3761.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
Argosoft.MailServer.Settings
    Assembly Version: 1.2.4.0
    Win32 Version: 1.2.4.0
    CodeBase: file:///C:/Program%20Files/ArGo%20Software%20Design/ArGoSoft%20Mail%20Server%20.NET/Argosoft.MailServer.Settings.DLL
----------------------------------------
Argosoft.MailServer.SettingsInterfaces
    Assembly Version: 1.2.4.0
    Win32 Version: 1.2.4.0
    CodeBase: file:///C:/Program%20Files/ArGo%20Software%20Design/ArGoSoft%20Mail%20Server%20.NET/Argosoft.MailServer.SettingsInterfaces.DLL
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3761.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3761.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4069.0 built by: NET48REL1LAST_B
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.ServiceProcess
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3761.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.ServiceProcess/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.ServiceProcess.dll
----------------------------------------
Argosoft.MailServer.Db
    Assembly Version: 1.2.4.0
    Win32 Version: 1.2.4.0
    CodeBase: file:///C:/Program%20Files/ArGo%20Software%20Design/ArGoSoft%20Mail%20Server%20.NET/Argosoft.MailServer.Db.DLL
----------------------------------------
Argosoft.MailServer.Data
    Assembly Version: 1.2.4.0
    Win32 Version: 1.2.4.0
    CodeBase: file:///C:/Program%20Files/ArGo%20Software%20Design/ArGoSoft%20Mail%20Server%20.NET/Argosoft.MailServer.Data.DLL
----------------------------------------
System.Data.SQLite
    Assembly Version: 1.0.111.0
    Win32 Version: 1.0.111.0
    CodeBase: file:///C:/Program%20Files/ArGo%20Software%20Design/ArGoSoft%20Mail%20Server%20.NET/System.Data.SQLite.DLL
----------------------------------------
System.Data
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3761.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
System.Transactions
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3761.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll
----------------------------------------
System.Web.Services
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3761.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Web.Services/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Web.Services.dll
----------------------------------------
System.EnterpriseServices
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3761.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.EnterpriseServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll
----------------------------------------
Argosoft.MailServer.Utils
    Assembly Version: 1.2.4.0
    Win32 Version: 1.2.4.0
    CodeBase: file:///C:/Program%20Files/ArGo%20Software%20Design/ArGoSoft%20Mail%20Server%20.NET/Argosoft.MailServer.Utils.DLL
----------------------------------------
Argosoft.Internet
    Assembly Version: 1.2.3.0
    Win32 Version: 1.2.3.0
    CodeBase: file:///C:/Program%20Files/ArGo%20Software%20Design/ArGoSoft%20Mail%20Server%20.NET/Argosoft.Internet.DLL
----------------------------------------
Argosoft.MailServer.Data.Records
    Assembly Version: 1.2.4.0
    Win32 Version: 1.2.4.0
    CodeBase: file:///C:/Program%20Files/ArGo%20Software%20Design/ArGoSoft%20Mail%20Server%20.NET/Argosoft.MailServer.Data.Records.DLL
----------------------------------------
Argosoft.Delivery
    Assembly Version: 1.2.4.0
    Win32 Version: 1.2.4.0
    CodeBase: file:///C:/Program%20Files/ArGo%20Software%20Design/ArGoSoft%20Mail%20Server%20.NET/Argosoft.Delivery.DLL
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.8.3761.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


Ken Poulsen

unread,
Jul 25, 2020, 2:24:50 PM7/25/20
to ArGoSoft Products
Noticed this, when its started it says it at the buttom


but at top i says stopped (and vice versa), think its related to the same.. 


Ken Poulsen

unread,
Jul 25, 2020, 2:33:14 PM7/25/20
to ArGoSoft Products
Well found the solution..

the user.config was gone empty..

copied the user.config from previus version (at appdata ect...)

<?xml version="1.0" encoding="utf-8"?>
<configuration>
    <userSettings>
        <MailServerUi.Properties.Settings>
            <setting name="WindowSize" serializeAs="String">
                <value>911, 595</value>
            </setting>
            <setting name="NoRunReminder" serializeAs="String">
                <value>True</value>
            </setting>
        </MailServerUi.Properties.Settings>
    </userSettings>
</configuration> 

now no errors…

(cant mark this as complete)

ArGoSoft Products

unread,
Jul 26, 2020, 9:51:20 AM7/26/20
to ArGoSoft Products

gyrosc...@gmail.com

unread,
Aug 21, 2022, 2:41:20 PM8/21/22
to ArGoSoft Products
Just had this happen to me after the server rebooted. File corrupted.

I have a suggestion: rather than give the "Root element is missing" error. Why not give that but add a little extra information. Such as giving a link to the FAQ page.

Or asking the user if they would like to attempt to use the backup file.

Reply all
Reply to author
Forward
0 new messages