[Fwd: Arch PPC: Install Media 2012.03.04: Missing Packages on Install Media]

Skip to first unread message


Mar 14, 2012, 6:46:16 PM3/14/12
to archlinu...@googlegroups.com
------- Messaggio inoltrato -------
Da: Jan Hartman <hart...@gmail.com>
A: jjdan...@gmail.com
Oggetto: Arch PPC: Install Media 2012.03.04: Missing Packages on Install
Data: Wed, 14 Mar 2012 21:54:05 +0100

Buona serata danimoth,

Because I'm not at all sure whether I should file a bug or post in the
arch forum or write you about this, I decided that it would not be too
terrible if I came to you directly, as this contains some suggestions.

I booted 2012.03.04 installation media just fine. (iMac G4, 17", 1.25
GHz, the 'iLamp')

When trying to start /arch/setup, the script got looped at line 74,
giving me this output:
/arch/setup: line 74: dialog: command not found
After installing the dialog package, the installer started alright.

Although the network (eth0) was already up using dhcpcd (the module
loaded automatically), the installer proceeded to tell me that it
"Cannot find any ethernet interfaces." (I ignored this warning)

I also needed to install mac-fdisk. (btw: Auto-Prepare is still the same
useless dialog as on the previous live-disk. I'm not sure, but shouldn't
it be possible to pipe these values to mac-fdisk?)
When it came to partitioning, mac-fdisk (as in previous versions) could
initialize a new map, but when trying to create a bootstrap-partition,
it suddenly changed the size of 'device' (an 80 GB P-ATA disk) from
~156'000'000 blocks to 4. Luckily, I could use my existing partition map
and could therefore proceed. => this has no obvious connection to Arch
PPC. I think this even happened when i tried out gentoo.

I then needed to run pacman-key --init... And that's where I got stuck.
It initialized well, but when I ran the package installer from
within /arch/setup, it couldn't verify the packages that had been

I'm fairly new to most things Linux (coming from an OS X background), so
please bear with me if this email was totally senseless.
Anyways, I'm taking the opportunity here to thank you for your efforts.

Rest Well ;)




Jul 23, 2012, 7:05:04 PM7/23/12
to archlinu...@googlegroups.com

the /arch/setup script needs to be modified to adjust for gpg keys by adding the line 'echo "SigLevel = Never" >>/etc/pacman.conf' to the prepare_pacman function
Reply all
Reply to author
0 new messages