Video issues on a Graphite G4, even with the latest 2011-03-07.ftp.iso

Skip to first unread message

Alex Perez

Feb 5, 2012, 12:02:41 PM2/5/12
I have a 1GHz Dual-CPU Graphite PowerMac G4, and can get the latest (both 2011-03-07 and 2011-03-05) CD's to boot, however once udev loads, it appers that all video stops being output.

I've tried video=ofonly and video=offb, both to no avail. I know the machine is running okay, because I can press ctrl-alt-del and the kernel responds, and reboots the machine.

This machine shipped with a GeForce2MX, not anything Radeon-based. I suspect the issue lies here, but that's just an informed guess.

Additionally, I have to disable SMP (maxcpus=1) to get Arch Linux kernel on the CD to the point where it hands off to arch init.

The video output halts after udev loads, at the point where it's waiting for udev rules to be applied or some-such.

I've tried passing init=/bin/sh to the bootloader, but apparently that doesn't work in Arch land.

Any suggestions?

Reply all
Reply to author
0 new messages