VirtualBox Guest Additions / Archivematica 0.8

37 views
Skip to first unread message

R Pearce-Moses

unread,
Feb 3, 2012, 5:26:14 PM2/3/12
to archivematica
After downloading and getting 0.8 up and running in VirtualBox 4.1.8,
I wanted to install the VBox Guest Additions. In particular, I wanted
to be able to resize the window easily.

It wouldn't load. I had similar problems with 0.7, and the following
fixed it for me.

1. sudo apt-get update
2. sudo apt-get upgrade
3. Determine which linux headers to get using uname -a
4. apt-get install linux-headers-2.6.33-32-generic -- replace version
based on info above as necessary
5. Via Synaptic package manager, install gcc

Restart to complete installation of the update.

From the VBox Device menu, click Install Guest Additions.
I closed the autorun prompt, then
cd /media/VBOXADDITIONS_4.1.8_75467
sudo ./VBoxLinuxAdditions.run

Restart and resizing will work.

Evelyn McLellan

unread,
Feb 3, 2012, 5:32:48 PM2/3/12
to archivematica
Thanks very much for the instructions, Richard. I'll add them to our
technical documentation.

Evelyn

R Pearce-Moses

unread,
Feb 6, 2012, 10:20:51 AM2/6/12
to archivematica
When testing these procedures on Amatica 0.8, I discovered that
skipping the option to update GRUB-pc made this go much faster. (When
checking for updates, I was prompted to do this with a popup box.)

-- R

Joseph Perry

unread,
Feb 7, 2012, 1:58:47 PM2/7/12
to archivematica
Great instructions!
I remember trying this in the past, and coming across Virtual Box
problems with the virtual box shared directories (shared host OS
directory, with client).
I tested and didn't come across those problems this time around.

note: mine was sudo apt-get install linux-headers-2.6.32-37-generic
I was running the VMDK 0.8 image on Virtual box 3.1.6 .

I did notice that after the apt-get update/upgrade, the ubuntu package
manager and aptitude, were still informing me of updates, including a
kernel image.
After installing those updates...
The kernal image updated me from 2.6.32-37 to 2.6.32-38, and must have
disabled some of the Virtual Box the kernel modules.
Installing the new kernel headers, and re-installing the Virtual box
add-ons worked. (after reboot).

I find it odd that apt-get and aptitude would get a different update
list, but based on what I've seen, I'd mildly revise your
instructions...
1. sudo aptitude update
2. sudo aptitude upgrade

Thanks again for this,
Joseph

Joseph Perry

unread,
Feb 7, 2012, 2:19:29 PM2/7/12
to archivematica

Joseph Perry

unread,
Feb 7, 2012, 2:29:47 PM2/7/12
to archivematica
I was reading through the virtual box instructions for this:
http://www.virtualbox.org/manual/ch04.html#idp11277648
"Be sure to install DKMS before installing the Linux Guest Additions.
If DKMS is not available or not installed, the guest kernel modules
will need to be recreated manually whenever the guest kernel is
updated using the command"

It sounds like the DKMS should have prevented the need to re-install
after updating the kernel, but didn't.
[it was already installed.]

Joseph
Reply all
Reply to author
Forward
0 new messages