New installation help

38 views
Skip to first unread message

Umesh Mohan

unread,
Dec 3, 2021, 8:40:14 AM12/3/21
to archivematica
Hi all,

I followed the manual ubuntu installation instructions from

After the post-install configuration step 4 (dashboard welcome page -> create administrative user), I am unable to login using the credentials I set.

I tried to  run the manage.py script from /usr/share/archivematica/dashboard after activating the virtualenv at /usr/share/archivematica/virtualenvs/archivematica but I get the following error:
Traceback (most recent call last):
 File "manage.py", line 13, in <module>
   execute_from_command_line(sys.argv)
 File "/usr/share/archivematica/virtualenvs/archivematica/lib/python3.6/site-packages/django/core/management/__init__.py", line 364, in execute_from_command_line
   utility.execute()
 File "/usr/share/archivematica/virtualenvs/archivematica/lib/python3.6/site-packages/django/core/management/__init__.py", line 308, in execute
   settings.INSTALLED_APPS
 File "/usr/share/archivematica/virtualenvs/archivematica/lib/python3.6/site-packages/django/conf/__init__.py", line 56, in __getattr__
   self._setup(name)
 File "/usr/share/archivematica/virtualenvs/archivematica/lib/python3.6/site-packages/django/conf/__init__.py", line 41, in _setup
   self._wrapped = Settings(settings_module)
 File "/usr/share/archivematica/virtualenvs/archivematica/lib/python3.6/site-packages/django/conf/__init__.py", line 110, in __init__
   mod = importlib.import_module(self.SETTINGS_MODULE)
 File "/usr/share/archivematica/virtualenvs/archivematica/lib/python3.6/importlib/__init__.py", line 126, in import_module
   return _bootstrap._gcd_import(name[level:], package, level)
 File "<frozen importlib._bootstrap>", line 994, in _gcd_import
 File "<frozen importlib._bootstrap>", line 971, in _find_and_load
 File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
 File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
 File "<frozen importlib._bootstrap_external>", line 678, in exec_module
 File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
 File "/usr/share/archivematica/dashboard/settings/local.py", line 27, in <module>
   from .base import *
 File "/usr/share/archivematica/dashboard/settings/base.py", line 32, in <module>
   from appconfig import Config, process_search_enabled
ModuleNotFoundError: No module named 'appconfig'


Please let me know how to proceed from here.

Thanks,
Umesh Mohan

jbel...@gmail.com

unread,
Dec 7, 2021, 10:33:56 AM12/7/21
to archivematica
I can let you know how I found the problem when I hit this error.  I  tried logging into mysql as the archivematica and SS users  using the default password and then the one I expected.   The default was still being used in the SS database which caused the problem.  It was easy to go back and correct the password reference. 
Reply all
Reply to author
Forward
0 new messages