[aprendendo-rails] Ajuda com versão do rails

18 views
Skip to first unread message

Eric Borba

unread,
Apr 16, 2010, 2:25:38 PM4/16/10
to aprendendo-rails
Pessoal,

Estou com um problema. Instalei 2 versões do rails no meu linux: 2.3.5
e 1.2.6 .....
Pq 2? Pq estou seguindo um livro que faz uso de scaffold que não
existe mais em versões atuais...
Porém algo estranho acontece; crio um projeto usando "rails
nomeDoProjeto" ...

Altero o arquivo : config/environment.rb com a linha
"RAILS_GEM_VERSION = '2.3.5' unless defined? RAILS_GEM_VERSION"

Porém ao rodar o webrick ele diz sempre que está rodando uma aplicação
rails 2.2.3 .... achei que ele deveria rodar o que eu colocar no
environment não?

Pq quando tentei usar scaffold ele deu pau, então tentei usar a versão
antiga, mas pelo que estou vendo ele não está alterando a versão do
rails que usa... ah, também deu erro : "undefined method `paginate'"

Alguem me socorre por favor hehe

--
You received this message because you are subscribed to the Google Groups "aprendendo-rails" group.
To post to this group, send email to aprenden...@googlegroups.com.
To unsubscribe from this group, send email to aprendendo-rai...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/aprendendo-rails?hl=en.

Dann

unread,
Apr 17, 2010, 8:24:14 PM4/17/10
to aprendendo-rails
Olha ele so vai definir a versao para 2.3.5 se ele não conseguir
encontrar a constante RAILS_GEM_VERSION, que no seu caso ela vale
2.3.5 tente retirar o unless defined? RAILS_GEM_VERSION e coloque em
RAILS_GEM_VERSION= o valor da versão que vc quer que seu ambiente
execute!
Reply all
Reply to author
Forward
0 new messages