admin server not starting

15 views
Skip to first unread message

accheddu

unread,
Nov 30, 2019, 12:28:43 PM11/30/19
to AppScale Community
Hi, the admin server is not working apparently on ubuntu 16.04.
This is the error in the log:

Traceback (most recent call last):
 
File "/usr/local/bin/appscale-admin", line 11, in <module>
    load_entry_point
('appscale-admin==0.0.5', 'console_scripts', 'appscale-admin')()
 
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 561, in load_entry_point
   
return get_distribution(dist).load_entry_point(group, name)
 
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2631, in load_entry_point
   
return ep.load()
 
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2291, in load
   
return self.resolve()
 
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2297, in resolve
   
module = __import__(self.module_name, fromlist=['__name__'], level=0)
 
File "/usr/local/lib/python2.7/dist-packages/appscale/admin/__init__.py", line 76, in <module>
   
from .resource_validator import validate_resource, ResourceValidationError
 
File "/usr/local/lib/python2.7/dist-packages/appscale/admin/resource_validator.py", line 7, in <module>
   
from jsonschema import (
 
File "/usr/local/lib/python2.7/dist-packages/jsonschema/__init__.py", line 33, in <module>
   
import importlib_metadata as metadata
 
File "/usr/local/lib/python2.7/dist-packages/importlib_metadata/__init__.py", line 9, in <module>
   
import zipp
 
File "/usr/local/lib/python2.7/dist-packages/zipp.py", line 12, in <module>
   
import more_itertools
 
File "/usr/local/lib/python2.7/dist-packages/more_itertools/__init__.py", line 1, in <module>
   
from more_itertools.more import *  # noqa
 
File "/usr/local/lib/python2.7/dist-packages/more_itertools/more.py", line 340
   
def _collate(*iterables, key=lambda a: a, reverse=False):
                               
^
SyntaxError: invalid syntax
Traceback (most recent call last):
 
File "/usr/local/bin/appscale-admin", line 11, in <module>
    load_entry_point
('appscale-admin==0.0.5', 'console_scripts', 'appscale-admin')()
 
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 561, in load_entry_point
   
return get_distribution(dist).load_entry_point(group, name)
 
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2631, in load_entry_point
   
return ep.load()
 
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2291, in load
   
return self.resolve()
 
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2297, in resolve
   
module = __import__(self.module_name, fromlist=['__name__'], level=0)
 
File "/usr/local/lib/python2.7/dist-packages/appscale/admin/__init__.py", line 76, in <module>
   
from .resource_validator import validate_resource, ResourceValidationError
 
File "/usr/local/lib/python2.7/dist-packages/appscale/admin/resource_validator.py", line 7, in <module>
   
from jsonschema import (
 
File "/usr/local/lib/python2.7/dist-packages/jsonschema/__init__.py", line 33, in <module>
   
import importlib_metadata as metadata
 
File "/usr/local/lib/python2.7/dist-packages/importlib_metadata/__init__.py", line 9, in <module>
   
import zipp
 
File "/usr/local/lib/python2.7/dist-packages/zipp.py", line 12, in <module>
   
import more_itertools
 
File "/usr/local/lib/python2.7/dist-packages/more_itertools/__init__.py", line 1, in <module>
   
from more_itertools.more import *  # noqa
 
File "/usr/local/lib/python2.7/dist-packages/more_itertools/more.py", line 340
   
def _collate(*iterables, key=lambda a: a, reverse=False):

Any clue about it?

Steve Jones

unread,
Nov 30, 2019, 3:18:54 PM11/30/19
to appscale_...@googlegroups.com


You may have a version of more-itertools installed that is not
compatible with python 2.7.

https://github.com/erikrose/more-itertools/issues/272

Looks like versions 6 and above are not compatible but may be installed
by old versions of pip.

Steve
> packages/more_itertools/more.py", line 340
> def _collate(*iterables, key=lambda a: a, reverse=False):
>
> Any clue about it?
> --
> You received this message because you are subscribed to the Google
> Groups "AppScale Community" group.
> To unsubscribe from this group and stop receiving emails from it,
> send an email to appscale_commun...@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/appscale_community/7294393f-1e9e-472d-83d8-73875bf1344f%40googlegroups.com
> .

accheddu

unread,
Dec 1, 2019, 6:31:50 AM12/1/19
to AppScale Community
Thanks.
Indeed I have pip 8.1.1 installed and I was not able to build from source lately.
The weird thing is that a paid image from Google Cloud Market had the same problem.
This solved the error:
pip install "more-iter==4.3.0"

But it turn out that tornado was on a wrong version as well.
To this:
pip install "tornado==4.2"

Reply all
Reply to author
Forward
0 new messages