Problems Deploying Application

57 views
Skip to first unread message

QAEngineer

unread,
Jan 24, 2014, 6:00:30 PM1/24/14
to appscale_...@googlegroups.com
Hi,

I am trying to deploy our google app to AppScale and I am having issues. When I try and upload a .tar or .zip file, it says it cannot find my yamo or appengine-web.xml file. My App is compiled by Maven, so it does not have a traditional war directory. 
Does anyone know what I can do to fix this? Thanks!

Jovan Chohan

unread,
Jan 24, 2014, 6:46:58 PM1/24/14
to appscale_...@googlegroups.com
Hi, 

Are you uploading your war directory? Where is your appengine-web.xml file located? Usually it should be in war/WEB-INF/appengine-web.xml.

You could also try using the command line tools to upload your app. 

-Jovan


--
You received this message because you are subscribed to the Google Groups "AppScale Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to appscale_commun...@googlegroups.com.
To post to this group, send email to appscale_...@googlegroups.com.
Visit this group at http://groups.google.com/group/appscale_community.
For more options, visit https://groups.google.com/groups/opt_out.

QAEngineer

unread,
Jan 27, 2014, 1:49:17 PM1/27/14
to appscale_...@googlegroups.com
Jovan,

Our appengine-web.xml file is located in the WEB-INF folder. Our directory is not named war, it is the name of our project with an id generated by Maven. the only difference I can
see in the file structure is that our file is not named war. I have tried to deploy on command line and I get the same error. Thank you for your help.


On Friday, January 24, 2014 4:46:58 PM UTC-7, Jovan Chohan wrote:
Hi, 

Are you uploading your war directory? Where is your appengine-web.xml file located? Usually it should be in war/WEB-INF/appengine-web.xml.

You could also try using the command line tools to upload your app. 

-Jovan
On Fri, Jan 24, 2014 at 3:00 PM, QAEngineer <markj...@gmail.com> wrote:
Hi,

I am trying to deploy our google app to AppScale and I am having issues. When I try and upload a .tar or .zip file, it says it cannot find my yamo or appengine-web.xml file. My App is compiled by Maven, so it does not have a traditional war directory. 
Does anyone know what I can do to fix this? Thanks!

--
You received this message because you are subscribed to the Google Groups "AppScale Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to appscale_community+unsub...@googlegroups.com.

Jovan Chohan

unread,
Jan 27, 2014, 2:04:10 PM1/27/14
to appscale_...@googlegroups.com
Can you try renaming the directory generated by maven to "war" and retry via the web and command-line?

-Jovan


To unsubscribe from this group and stop receiving emails from it, send an email to appscale_commun...@googlegroups.com.

QAEngineer

unread,
Jan 28, 2014, 1:03:46 PM1/28/14
to appscale_...@googlegroups.com
No. It turns out that maven organizes the files way differently than a typical google app. Does AppScale not support this? Isn't there a way I can make this work with Maven?


On Monday, January 27, 2014 12:04:10 PM UTC-7, Jovan Chohan wrote:
Can you try renaming the directory generated by maven to "war" and retry via the web and command-line?

-Jovan
On Mon, Jan 27, 2014 at 10:49 AM, QAEngineer <markj...@gmail.com> wrote:
Jovan,

Our appengine-web.xml file is located in the WEB-INF folder. Our directory is not named war, it is the name of our project with an id generated by Maven. the only difference I can
see in the file structure is that our file is not named war. I have tried to deploy on command line and I get the same error. Thank you for your help.


On Friday, January 24, 2014 4:46:58 PM UTC-7, Jovan Chohan wrote:
Hi, 

Are you uploading your war directory? Where is your appengine-web.xml file located? Usually it should be in war/WEB-INF/appengine-web.xml.

You could also try using the command line tools to upload your app. 

-Jovan
On Fri, Jan 24, 2014 at 3:00 PM, QAEngineer <markj...@gmail.com> wrote:
Hi,

I am trying to deploy our google app to AppScale and I am having issues. When I try and upload a .tar or .zip file, it says it cannot find my yamo or appengine-web.xml file. My App is compiled by Maven, so it does not have a traditional war directory. 
Does anyone know what I can do to fix this? Thanks!

--
You received this message because you are subscribed to the Google Groups "AppScale Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to appscale_community+unsubscribe@googlegroups.com.
To post to this group, send email to appscale_...@googlegroups.com.

Navraj Chohan

unread,
Jan 28, 2014, 4:03:40 PM1/28/14
to appscale_...@googlegroups.com
Hi Mark,
AppScale looks for the war directory when starting up java applications:

If your app is not using this layout, it will not work. If you can get your app to work using the Java developement server then it should work with AppScale.

Thanks
-Raj


To unsubscribe from this group and stop receiving emails from it, send an email to appscale_commun...@googlegroups.com.

To post to this group, send email to appscale_...@googlegroups.com.
Visit this group at http://groups.google.com/group/appscale_community.
For more options, visit https://groups.google.com/groups/opt_out.



--
Navraj Chohan (Raj), PhD
Co-Founder of AppScale Systems
A Google Cloud Partner 

and a GigaOm Structure/LaunchPad "Best of the Best" Startups


615 State Street

Santa Barbara, CA 93101
Reply all
Reply to author
Forward
0 new messages