Announcing Apostrophe 2.1.1: Windows compatibility restored

5 views
Skip to first unread message

Tom Boutell

unread,
Sep 18, 2016, 7:48:38 PM9/18/16
to apostr...@googlegroups.com
Apostrophe 2.1.1 was just released.

The only change concerns Windows: you no longer need Administrator
privileges to run Apostrophe 2.x.

Of course, running as Administrator is the moral equivalent of running
as root on Linux, which we would never recommend. So we regarded this
as a bug fix and took care of it.

Like the old 0.5 release, on Windows, 2.x now recursively copies the
public/ asset folders of your apostrophe modules to subdirectories of
your project's public/modules folder at startup. It takes a second or
two, but no longer, and it allows us to avoid using symbolic links,
which are an "administrator only" feature in Windows.

(On other operating systems symbolic links are still used.)

FYI, when installing ImageMagick on Windows, you must check the
"legacy executables" box in the installer. The so-called legacy
executables include the indispensable "convert" and "identify"
executables.

Enjoy!

--


THOMAS BOUTELL, SUPPORT LEAD
P'UNK AVENUE | (215) 755-1330 | punkave.com
Reply all
Reply to author
Forward
0 new messages