New release candidates: ansible-core 2.11.5rc1, ansible-base 2.10.14rc1, ansible 2.9.26rc1

11 views
Skip to first unread message

Matt Martz

unread,
Sep 8, 2021, 4:06:36 PMSep 8
to Ansible Development
Hi all- we're happy to announce the following release candidates:

- ansible-core 2.11.5rc1
- ansible-base 2.10.14rc1
- ansible 2.9.26rc1


How to get it
-------------

$ pip install ansible-core==2.11.5rc1 --user
or
$ pip install ansible-base==2.10.14rc1 --user
or
$ pip install ansible==2.9.26rc1 --user

The tar.gz of the release can be found here:

* ansible-core 2.11.5rc1
  https://pypi.python.org/packages/source/a/ansible-core/ansible-core-2.11.5rc1.tar.gz
  SHA256: 02a50bf19c4215aa919a695ff3b6553bc58d510642b839ccc8e50086a7547a8a

* ansible-base 2.10.14rc1
  https://pypi.python.org/packages/source/a/ansible-base/ansible-base-2.10.14rc1.tar.gz
  SHA256: 33d26bcef0b12ce21847a496721dd328994c869f42ef3c983c70ec4190dc5d18

* ansible 2.9.26rc1
  https://pypi.python.org/packages/source/a/ansible/ansible-2.9.26rc1.tar.gz
  SHA256: ec9ff9e80561d604a33b6dc4ed697d09287b3b774cfd5c22be897d178e8d1cdf


What's new
----------

This release is a maintenance release containing numerous bugfixes. The full
changelog is at:

* ansible-core 2.11.5rc1
  https://github.com/ansible/ansible/blob/v2.11.5rc1/changelogs/CHANGELOG-v2.11.rst

* ansible-base 2.10.14rc1
  https://github.com/ansible/ansible/blob/v2.10.14rc1/changelogs/CHANGELOG-v2.10.rst

* ansible 2.9.26rc1
  https://github.com/ansible/ansible/blob/v2.9.26rc1/changelogs/CHANGELOG-v2.9.rst


What's the schedule for future maintenance releases?
----------------------------------------------------

These release candidates will become general availability releases on 13 September 2021.

The next batch of release candidates is planned to be released on 4 October 2021.
The next general availability release will be one week after.


Porting Help
------------

If you discover any errors or if any of your working playbooks break when you
upgrade, please use the following link to report the regression:

  https://github.com/ansible/ansible/issues/new/choose

In your issue, be sure to mention the version that works and the one that
doesn't.

Thanks!

--
Matt Martz
@sivel
sivel.net
Reply all
Reply to author
Forward
0 new messages