ANN: Annif 0.57 released

25 views
Skip to first unread message

juho.i...@helsinki.fi

unread,
Mar 15, 2022, 12:03:59 PMMar 15
to Annif Users
Annif 0.57 has been released!


Training of NN ensemble models can now be performed in parallel (running suggest operations simultaneously for all source projects) on multiple CPUs; this is controlled by using the `--jobs` parameter of the `train` command. The compatibility of Annif with DVC is improved by supporting TOML file format for configuring Annif projects. The `--force` option is added to the `loadvoc` command that can be used to replace an existing vocabulary instead of updating it. This release includes many small maintenance tasks for the CI/CD pipeline, e.g. migrating Docker image builds to GitHub Actions from the Drone platform. 

Omikuji, TensorFlow and Connexion dependencies are upgraded to the latest available versions; retraining of projects should not be necessary. 

New features:
#526/#567 Add --force option to loadvoc CLI command

Improvements:
#429/#568 Perform suggest operations in parallel using multiprocessing in nn_ensemble
#547/#560 Support TOML as a configuration file format alongside CFG/INI for DVC compatibility

Maintenance:
#570 Use fulltext corpus in MLLM tests which is much faster
#571 Docker builds on GitHub Actions CI/CD
#572 Update Dockerfile v0.57
#573 Ensure setuptools and wheel are installed & up-to-date for tests in GitHub Actions CI
#574 Avoid running duplicated tests on PRs in GitHub Actions CI
#575 Resolve some Warnings by tests
#576 Enable pip cache in GitHub Actions CI
#577 Improved Project links in PyPI page
#578 Update dependencies v0.57
#581/#582 Add tags trigger to GH Actions CI/CD workflow

Parthasarathi Mukhopadhyay

unread,
Mar 27, 2022, 2:07:17 PMMar 27
to annif...@googlegroups.com
Dear all

I'm running Annif 0.56.0, which is installed on Ubuntu 20.04 LTS (Python 3.8.10).

Could you please direct me to documents that can help me in upgrading my Annif instance to the latest version 0.57?

Thanks and regards

--
You received this message because you are subscribed to the Google Groups "Annif Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to annif-users...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/annif-users/4b3d023b-a898-4f6a-9642-b3db9cadcb97n%40googlegroups.com.

Osma Suominen

unread,
Mar 28, 2022, 3:14:04 AMMar 28
to annif...@googlegroups.com
Hello Parthasarathi,

I assume you have installed Annif using the "pip install" method and not
via Docker, since you didn't mention it.

To upgrade you can use pip install -U / --upgrade. First you need to
activate the virtual environment. Then upgrade using:

pip install -U annif

This will install the latest available version. If you have installed
optional extras, make sure to mention them too, e.g.

pip install -U annif[fasttext,omikuji,nn]

Here is a link to the official documentation on the pip install command:
https://pip.pypa.io/en/stable/cli/pip_install/

Hope this helps!

-Osma

Parthasarathi Mukhopadhyay kirjoitti 27.3.2022 klo 21.07:
> Dear all
>
> I'm running Annif 0.56.0, which is installed on Ubuntu 20.04 LTS (Python
> 3.8.10).
>
> Could you please direct me to documents that can help me in upgrading my
> Annif instance to the latest version 0.57?
>
> Thanks and regards
>
> On Tue, Mar 15, 2022 at 9:34 PM juho.i...@helsinki.fi
> <mailto:juho.i...@helsinki.fi> <juho.i...@helsinki.fi
> <mailto:juho.i...@helsinki.fi>> wrote:
>
> Annif 0.57 has been released!
>
> https://github.com/NatLibFi/Annif/releases/tag/v0.57.0
> <https://github.com/NatLibFi/Annif/releases/tag/v0.57.0>
>
> Training of NN ensemble models can now be performed in parallel
> (running suggest operations simultaneously for all source projects)
> on multiple CPUs; this is controlled by using the `--jobs` parameter
> of the `train` command. The compatibility of Annif with DVC is
> improved by supporting TOML file format for configuring Annif
> projects. The `--force` option is added to the `loadvoc` command
> that can be used to replace an existing vocabulary instead of
> updating it.This release includes many small maintenance tasks for
> <mailto:annif-users...@googlegroups.com>.
> <https://groups.google.com/d/msgid/annif-users/4b3d023b-a898-4f6a-9642-b3db9cadcb97n%40googlegroups.com?utm_medium=email&utm_source=footer>.
>
> --
> You received this message because you are subscribed to the Google
> Groups "Annif Users" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to annif-users...@googlegroups.com
> <mailto:annif-users...@googlegroups.com>.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/annif-users/CAGM_5uY7AG2qNii5%2BLWY_tLDWc6%2Bmfjo84JcDHTf1zajH4-1DA%40mail.gmail.com
> <https://groups.google.com/d/msgid/annif-users/CAGM_5uY7AG2qNii5%2BLWY_tLDWc6%2Bmfjo84JcDHTf1zajH4-1DA%40mail.gmail.com?utm_medium=email&utm_source=footer>.

--
Osma Suominen
D.Sc. (Tech), Information Systems Specialist
National Library of Finland
P.O. Box 15 (Unioninkatu 36)
00014 HELSINGIN YLIOPISTO
Tel. +358 50 3199529
osma.s...@helsinki.fi
http://www.nationallibrary.fi

Parthasarathi Mukhopadhyay

unread,
Mar 28, 2022, 1:36:03 PMMar 28
to annif...@googlegroups.com
Dear Osma

The upgrade command pip install -U annif[fasttext,omikuji,nn] has worked like a charm for me.

Many thanks!

Regards

To unsubscribe from this group and stop receiving emails from it, send an email to annif-users...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/annif-users/993e9cac-1e2d-e50a-0a2e-b5bafddc542e%40helsinki.fi.

P Stacey

unread,
Mar 28, 2022, 2:35:58 PMMar 28
to Annif Users
This very helpful :)
Reply all
Reply to author
Forward
0 new messages