ESP32-cam flash: fatFS creation failed

39 views
Skip to first unread message

Lizby

unread,
Jan 27, 2021, 1:55:31 PM1/27/21
to Annex WiFi RDS
With the ESP32-cam which I flashed yesterday, when trying to flash with data, I got the message: "fatFS creation failed". I tried multiple times with multiple SD cards. I eventually just did "Flash firmware only". That worked, so I connected to 192.168.4.1 and set up the Config page as needed. Thanks to PeterN, I got the camera working.

Today I tried to flash another ESP32-CAM with "Flash Firmware + OTA + data" and again got the message, "fatFS creation failed", and from the log, "Hard resetting via RTS pin...
EXTRACT FILES FROM ZIP FILE; Create FATFS bin file; Failed to create fatfs filesystem: 14".

Is there something I should do to fix this so that I have a working SD card?

Can I at this point set up the fatFS system on the SD card?

cicciocb

unread,
Jan 27, 2021, 3:56:34 PM1/27/21
to Annex WiFi RDS
HI Lizby,
the flashing with data does not work on the ESP32-CAM as the size of the space dedicated to the filesystem is too little.
So this is a "normal" error.
The SDCARD works without any problem, independently of this problem.
Simply do not forget to enable it in the config page.

Reply all
Reply to author
Forward
0 new messages