flashing new esp32 chips fails

66 views
Skip to first unread message

Stuart Gillies

unread,
Jan 28, 2021, 12:02:30 PM1/28/21
to Annex WiFi RDS
I have just bought three ESP32 boards (AITRIP 3 Pack for ESP32-DevKitC core Board ESP32 Development Board ESP32-WROOM-32D for Arduino IDE (ESP32-WROOM-32D) on Amazon. I ran out of memory for my current project with the 8266.

Unfortunately none of them will flash. Details are:

Annex+32 toolkit 1.11
flash read err, 1000
invalid head of packet (0x46)

Chip reports as ESP32D0WDQ6 rev 1 (initially)

when it fails it is just after identifying the chip as ESP8266EX with a mac of 00 08 ff 00 00 00, which seems a bit unlikely and is not the mac it reports when asked to read the module.

I have tried wiping and redoing, slower baud rate, setting smaller flash size, etc. But all three chips fail the same way. Unfortunately I have to use another computer to flash as I can't run the toolkit on my usual ones (I haven't got it running under Virtualbox yet and it won't under wine - I don't usually use windows) - screen grab below (it wouldn't attach)

Any ideas?

Stuart


ciccio cb

unread,
Jan 28, 2021, 4:57:30 PM1/28/21
to Annex WiFi RDS
Yes Stuart,
you are trying to flash an ESP8266 firmware on the ESP32.

You must use a more recent version of AnnexToolkit that includes the ESP32 firmware

--
You received this message because you are subscribed to the Google Groups "Annex WiFi RDS" group.
To unsubscribe from this group and stop receiving emails from it, send an email to annex_wifi_rd...@googlegroups.com.
To view this discussion on the web, visit https://groups.google.com/d/msgid/annex_wifi_rds/7c64eac1-02f2-4d3a-baa6-0c7ce737e08ao%40googlegroups.com.

Stuart Gillies

unread,
Jan 29, 2021, 2:23:24 AM1/29/21
to Annex WiFi RDS
I just downloaded what I thought was the latest, and it is entitled "Annex+32". Where do I get a later version?

Glad it's nothing serious!

Stuart

cicciocb

unread,
Jan 29, 2021, 3:05:50 AM1/29/21
to Annex WiFi RDS
Stuart,
you might download what is called full package that contains both ESP32 and EP8266

Stuart Gillies

unread,
Jan 29, 2021, 5:20:43 AM1/29/21
to Annex WiFi RDS
Sorted, thanks. I did find the naming a little confusing.


On Thursday, 28 January 2021 17:02:30 UTC, Stuart Gillies wrote:
Reply all
Reply to author
Forward
0 new messages