AnkiDroid 2.9.2

360 views
Skip to first unread message

Tim

unread,
Jan 31, 2020, 11:25:38 AM1/31/20
to AnkiDroid
I just put a new beta release out for 2.9.2 this morning.
Most importantly, this build contains an important patch by Mike Hardy to support AnkiWeb encryption changes. If you have problems syncing with AnkiWeb please update to the beta while we work to get it out to production.

There are a bunch of other neat changes in this release, mainly geared towards Anki Desktop compatibility.
The only task left to do is to prepare a human readable set of release notes.
The branch history is a bit hard to read, but I did some editing foo and got this list of commits (in chronological order):

'c71c2fe04' Correct edition of card in filtered deck
'4f268342e' fix negative due dates in filtered decks
'ca42304ff' Clears undo before changing schedulers
'c8a20afbc' New card with same due are shown according to their ord
'bcc13aaf3' some html regexps should be case insensitive
'43ff6f7b6' fix crash on app startup with uninitialized collection
'ece0b5d33' escape backslash in find&replace
'c4865da41' Cloze menu (#5536)
'037219dc8' Fix Mathjax Cloze duplication issue.
'aa94e209f' Don't run gitflow-integrate script unless we're on correct branch
'21c1838bb' Adding missing Throw
'0c1847276' Fix sched v2 overflow bug (#5574)
'f609f4248' Adding method Parent from Anki
'dbf3c09d5' Decks#checkIntegrity
'c8e69040a' intNow to intTime
'd402073fa' Switch to okhttp for http connections, use TLS1.2 on API<=21 (#5658)

noleen...@yahoo.com

unread,
Feb 2, 2020, 10:25:10 AM2/2/20
to AnkiDroid
Hello,

Ran across this beta release looking for a solution for sync problems that started in February: Ankidroid 2.8.4 on Android 4.0.4 now fails to sync saying Network Error.
I then upgraded Ankidroid to the latest version available on PlayMarket (2.9.1?) and got a "SD card full" error. When I run AnkiDroid, I get an error "SD card full", I tap OK and then the program works just fine. Still was unable to sync - was even unable to log in (i enter login and pass and get a Network error)

My collection is rather small - 2.3mb, and my internal SD has 3,7 gb free.

i then tried your 2.9.2 beta and got all the same - SD card full and Network error when I try to login.

Rolled back to AnkiDroid 2.8.4 - no "SD card full" error on startup but still unable to log in (Network error).

Same password seem to work online.

Right now I have to export collection and email it to myself, then import it into AnkiDesktop and vise versa. :D

Apologies in advance if I posted in a wrong place - just let me know.

Mike Hardy

unread,
Feb 2, 2020, 10:52:57 AM2/2/20
to anki-a...@googlegroups.com


Yeah - Android 4.0.x won't sync with AnkiWeb after they implemented a security upgrade to TLS1.2. That is a shame of course but our stats indicate you are one of only around 300 people total (out of 1.3 million of our users) still using this operating system from 9 years ago. That OS simply doesn't support encryption that isn't shown to be vulnerable and the world has moved on


I love making things work and I was able to do so for Android 4.1.x+ but 4.0.x simply doesn't contain the necessary OS support to do TLS1.2 at all


You have one other option which would be to run your own Anki sync server. Not as hard as it sounds I think: https://github.com/tsudoko/anki-sync-server is the most vibrant current version of that code I believe.


-Mike

--
You received this message because you are subscribed to the Google Groups "AnkiDroid" group.
To unsubscribe from this group and stop receiving emails from it, send an email to anki-android...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/anki-android/9acf4b01-b55c-4984-b7a9-b24165ed7870%40googlegroups.com.

noleen...@yahoo.com

unread,
Feb 2, 2020, 3:38:22 PM2/2/20
to AnkiDroid
Thank you for your reply! Will try to upgrade to 4.1.2. I know it's doable. But what about the "SD card full" error? I wonder if it will go away if I upgrade.

Mike Hardy

unread,
Feb 2, 2020, 3:56:50 PM2/2/20
to noleenmegaair via AnkiDroid


Unsure on that one, but I tested on 4.1.x when I made the original patch to fix this networking error and I have an API17 tablet that I still actually use, I had no sync problems, for what it's worth. Back in those days of Android development though, filesystems and external storage etc were a lot more widely varied than they are now, so perhaps there is some edge case not working


-Mike


On 2/2/20 3:38 PM, noleenmegaair via AnkiDroid wrote:
Thank you for your reply! Will try to upgrade to 4.1.2. I know it's doable. But what about the "SD card full" error? I wonder if it will go away if I upgrade.
--
You received this message because you are subscribed to the Google Groups "AnkiDroid" group.
To unsubscribe from this group and stop receiving emails from it, send an email to anki-android...@googlegroups.com.

noleen...@yahoo.com

unread,
Feb 2, 2020, 5:16:34 PM2/2/20
to AnkiDroid
Upgraded to 4.1.2 and installed your 2.9.2
Sync ok but still get the annoying error about the SD card:

=cut=
SD card full

Backup not saved. Not enough space left on SD card. Lower the backup depth or remone some other files.
=cut=

This is going on on a newly updated phone with pristine empty internal memory and an empty SD card. I get this message even if I remove all the Anki data (including my 2.3mb collection) from android\data\com.ichi2.anki

Just like with 4.0.4, this message does not show up when I uninstall 2.9.2 and install 2.8.4 (which does not sync though :D)
Doesn't seem like a real problem but still annoying.

Thank you for the ability to sync again! :)

Mike Hardy

unread,
Feb 2, 2020, 6:48:50 PM2/2/20
to anki-a...@googlegroups.com


Interesting. What happens if you lower the backup depth?


What file system are you on, etc?


I'm thinking this FAQ entry is not even close to a direct hit but is in the area of what may be going on https://github.com/ankidroid/Anki-Android/wiki/FAQ#i-have-too-many-media-files-and-cant-copy-them-all-to-my-device

--
You received this message because you are subscribed to the Google Groups "AnkiDroid" group.
To unsubscribe from this group and stop receiving emails from it, send an email to anki-android...@googlegroups.com.

noleen...@yahoo.com

unread,
Feb 2, 2020, 7:07:14 PM2/2/20
to AnkiDroid
SD card is FAT32, not sure about internal storage.
My collection is under 5,000 items, and they are words and sentences. No pictures, no audio, no video, just text.

noleen...@yahoo.com

unread,
Feb 2, 2020, 7:09:58 PM2/2/20
to AnkiDroid
Sorry, forgot about backup depth. Default value was 8, I tried changing it to 0 but it did not help.
The 2.9.2 said about SD card full at the very first run when it did not sync yet and when it had 0 collection entries.
Like I said, I also tried to delete the collection and its files but this did not save me from that error message.

noleen...@yahoo.com

unread,
May 31, 2020, 6:05:38 AM5/31/20
to AnkiDroid
Hello again,

It's been a while, I updated from Android 4.0.4 to 4.1.2 and that solved the sync problem completely.

I am unable to sync for two days now - getting "sslException while building httpClient" error. AnkiDroid version 2.10.3. A fallback to 2.9.2 did not improve things.


My Anki for Desktop Version 2.1.14 syncs with my collection at https://ankiweb.net/decks/ just fine, so the problem I have is limited only to my AnkiDroid.

Any ideas what the problem could be?


On Friday, January 31, 2020 at 5:25:38 PM UTC+1, Tim wrote:

Mike Hardy

unread,
May 31, 2020, 12:16:55 PM5/31/20
to anki-a...@googlegroups.com


Should be working now - it was a problem with an intermediate certificate in the cert bundle expiring. Only devices that did not already have the certs in the store needed the full chain to be valid, so it is only affecting some Android devices. Should be fixed as of yesterday afternoon, maybe a phone reboot and it should work?


-Mike

--
You received this message because you are subscribed to the Google Groups "AnkiDroid" group.
To unsubscribe from this group and stop receiving emails from it, send an email to anki-android...@googlegroups.com.

55za...@gmail.com

unread,
May 31, 2020, 1:41:29 PM5/31/20
to AnkiDroid
Android 4.2.2 here.
I also had all the problems you had, and luckily fixed them all before. Last time updating my AnkiDroid fixed the sslException, and check media fixed my SD Card full problems. However, now I can't sync for 2 days in the AnkiDroid. Not only syncing, I can't even log in to my account.

Mike Hardy

unread,
May 31, 2020, 1:43:52 PM5/31/20
to anki-a...@googlegroups.com, 55za...@gmail.com


Hi there!


The AnkiWeb SSL certificate bundle had an intermediate certificate in it's trust chain expire, and older devices must validate the whole chain in order to work.


Version 2.10.4 is processing for release right now and should contain a fix


Version 2.10.4


== Version 2.10.4 (2020-05-31)
* Workaround expired AnkiWeb SSL Root certificate
* More details: https://github.com/ankidroid/Anki-Android/milestone/22?closed=1

On 5/31/20 9:36 AM, 55za...@gmail.com wrote:
Android 4.2.2 here.
I also had all the problems you had, and luckily fixed them all before. Last time updating my AnkiDroid fixed the sslException, and check media fixed my SD Card full problems. However, now I can't sync for 2 days in the AnkiDroid. Not only syncing, I can't even log in to my account.
--
You received this message because you are subscribed to the Google Groups "AnkiDroid" group.
To unsubscribe from this group and stop receiving emails from it, send an email to anki-android...@googlegroups.com.

noleen...@yahoo.com

unread,
May 31, 2020, 2:39:46 PM5/31/20
to AnkiDroid
Thanks a ton!!!
Updated to 2.10.4, everything works just great!



On Sunday, May 31, 2020 at 7:43:52 PM UTC+2, Mike Hardy wrote:


Hi there!


The AnkiWeb SSL certificate bundle had an intermediate certificate in it's trust chain expire, and older devices must validate the whole chain in order to work.


Version 2.10.4 is processing for release right now and should contain a fix


Version 2.10.4


== Version 2.10.4 (2020-05-31)
* Workaround expired AnkiWeb SSL Root certificate
* More details: https://github.com/ankidroid/Anki-Android/milestone/22?closed=1

On 5/31/20 9:36 AM, 55za...@gmail.com wrote:
Android 4.2.2 here.
I also had all the problems you had, and luckily fixed them all before. Last time updating my AnkiDroid fixed the sslException, and check media fixed my SD Card full problems. However, now I can't sync for 2 days in the AnkiDroid. Not only syncing, I can't even log in to my account.
--
You received this message because you are subscribed to the Google Groups "AnkiDroid" group.
To unsubscribe from this group and stop receiving emails from it, send an email to anki-a...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages