Connectivity with pc ?

110 views
Skip to first unread message

JAUREGUI

unread,
May 26, 2021, 1:38:54 PM5/26/21
to DroidScript
2 weeks ago I connected to my pc and it shows only 2 rows of apps, later I couldn't connect at all (it shows "error 500"). when I open Droidscript app and try to run some of my projects it shows this error "access denied" with black screen, I tried to reinstall droidscript app and still doesn't work. 

Has it happened to any one?

Steve Garman

unread,
May 27, 2021, 1:52:27 AM5/27/21
to DroidScript
I recommend deleting the DroidDcript/.edit folder
Then restart DroidScript

Also, when you connect from your PC, use your browser to connect directly to the ip address displayed on your phone screen

If this does not work please post more details of your system
Version of DroidScript
Version of Android
Name of browser
Make and model of phone/tablet

And if possible screenshots of any error messages you receive

JAUREGUI

unread,
May 27, 2021, 3:32:51 PM5/27/21
to DroidScript
HI, I tried deleting the .edit folder and didn't work, 
I restart my phone and reinstall DroidScript, the problem is that I delete the folder .edit before reinstall it and gave the option to remove the app internal data. Now It is working all fine with the connection with the my desktop but I don't see any app icons of my old projects, they are still there but I don't see them in droidscript. is there a way to fix it or I have to add them manually? 

Steve Garman

unread,
May 27, 2021, 4:16:16 PM5/27/21
to DroidScript
Before you do anything else, make sure you have a safe backup of all the projects from the DroidScript folder in your main storage.

Just copying DroidScript to DroidScriptOld with your file manager will be fine for now but you must not ignore this step.

And of course we always recommend you keep regular offline backups of your projects

Unfortunately you didn't answer my previous questions so I am going to assume that you were using Android 10 or newer when you uninstalled DroidScript and then reinstalled a recent version.

If that is not the case, stop and post details of your Android version and the make and model of your phone/tablet where you are seeing the problem.

Now a brief explanation of what has happened.

It was caused by uninstalling DroidScript before reinstalling it. 

I am not suggesting that was an unreasonable thing to do, just that it now has unexpected consequences.

Since Android apps have been forced to target Android 10, they are now forced to use Scoped Storage.

An exception was made for apps that are an update from a previous version but you broke that chain by uninstalling DroidScript.

Instead of being in the folder DroidScript in your internal storage, DroidScript is forced to use    

   Android/data/com.smartphoneremote.androidscriptfree/files/DroidScript in your internal storage

So you have 2 options
1) you can uninstall DroidScript, install an old version from  http://androidscript.org/apk/DroidScript_180/DroidScript_180.apk and then update DroidScript from Google Play

That should cause DroidScript to use traditional storage and your previous DroidScript file.

or

2) you can copy the contents of the old DroidScript file to the new DroidScript file using your file manager and starting from internal storage go to

   Android/data/com.smartphoneremote.androidscriptfree/files/DroidScript

Option 2 will allow you to continue using scoped storage, which will mean that apps in DroidScript will act more similarly to any APK you will build and run on Android 10+

Please note, taking either option could destroy your old DroidScript folder (though it may not) so please do not ignore the advice to make a copy first.

JAUREGUI

unread,
May 28, 2021, 12:48:29 PM5/28/21
to DroidScript
Thanks Steve for your time. My phone shows android version 11, I tried to follow the path "Android/data/com.smartphoneremote.androidscriptfree/files/DroidScript  " but the only part that I found is Android/data.. I tried to search any new file ( .js or .htm ) that I created yesterday and the file manager didn't find any, droidscript shows them but fiscally I can't find them.
**I haven't tried to install the  option 1 jet.

Reply all
Reply to author
Forward
0 new messages