Bluetooth audio stuttering or cutting out

34 views
Skip to first unread message

BrokenE39

unread,
Nov 28, 2021, 5:19:54 PM11/28/21
to Android-x86
I'm having this odd issue with my BT audio:

* Using Intel 7265 AC mini PCI-E card
* Was working perfecting fine with Android 9R2 with Kernel 4.19
* But all the sudden it would stutter and cut in and out
* Tried turning BT on and off and reboot but same problem
* Tried Android 9R2 with Kernel 5.10 and same problem
* Tried replacing the antenna attached to the card itself and same problem

Kind of lost on what to do next. May be a hardware issue with the card itself?

Antony Stone

unread,
Nov 28, 2021, 5:26:09 PM11/28/21
to andro...@googlegroups.com
On Sunday 28 November 2021 at 23:19:54, BrokenE39 wrote:

> I'm having this odd issue with my BT audio:
>
> * Using Intel 7265 AC mini PCI-E card
> * Was working perfecting fine with Android 9R2 with Kernel 4.19

Okay, so far, so good...

> * But all the sudden it would stutter and cut in and out

So, no software changes / updates, no hardware changes / new devices / new
environment, etc?

> Kind of lost on what to do next. May be a hardware issue with the card
> itself?

Could be - but what are you using it with? Presumably a BT headset or
speakers... does that still work fine with some other BT source?

Try to be specific about "what works with anything except X?" and "what changed
since it last worked?".

That process generally works for me in identifying (soft/hard)ware problems.


Antony.

--
The more 'success' you get, the easier it is to be disappointed by not getting
things.
The only difference is that now no-one feels sorry for you.

- Matt Haig

Please reply to the list;
please *don't* CC me.

Daniel Cheung

unread,
Nov 28, 2021, 5:33:53 PM11/28/21
to andro...@googlegroups.com
* But all the sudden it would stutter and cut in and out
There was no hardware change or software update at all. The computer is used as a media device to consume Plex videos and YouTube videos. Basically, I shut off one night, turn it back on another night and the BT audio is messed up. Laggy, cut in and out, or stutter. Anything after that bullet point is me trying to soft the problem. I have another set of BT earbuds and it's the same problem. 

BrokenE39

unread,
Dec 5, 2021, 12:04:17 AM12/5/21
to Android-x86
Update on the situation. I don't think it is Android related since installing Win10 produced the same BT audio issue. After another Andrid X86 installation and slight BIOS config, video in Plex actually will not render correctly at all using the i7-3770's onboard GPU. I install a spare AMD 5670 GPU and swap out the external antenna and now I don't have any video or BT audio issue. I'm suspecting a possible degrading CPU since it's pretty old. I'll keep monitoring it.
Reply all
Reply to author
Forward
0 new messages