Android-x86 > 4.0 on antiquarian hardware - Asus EEEPc 701 (4G)

115 views
Skip to first unread message

Diodosvet

unread,
Jan 11, 2022, 4:12:39 AMJan 11
to Android-x86
Hello everybody!
I would like to ask if it is possible at all to run not  eeepc-specific(like android-x86-4.0-r1-eeepc), but common Android x86 builds (like android-x86-4.4-r5)  on such an antiquarian netbook as Asus EEEPc 701 (4G)
I tried a lot with different builds but can't start GUI.
In LIVE CD mode , even with eeepc - specifiq GRUB options like:  

label livemeeepc
        menu label Live CD - ^Run EEEPc specific Android-x86 without installation
        kernel /kernel
        append initrd=/initrd.img root=/dev/ram0 androidboot.hardware=eeepc acpi_sleep=s3_bios,s3_mode SRC= DATA=
nor with  nomodeset i915.modeset=0,
nor with vga=ask,
UVESA_MODE=...  etc.
it can't start GUI
I even tried to attach external VGA monitor and switch off netbook LCD with video=LVDS-1:d
But it won't start GUI  (but I found that video=LVDS-1:d i915.modeset=0 simultaneously makes both displays working in "clone" mode in 4.4.4, but very very slow :)  )
Last thing that I did't succeeded yet to try is setting "set_property debug.drm.mode.force= 800x480@60" in system/etc/init.sh but i'm not sure if it will work on Android 4.4.4
At same time Android 4.0.4 (from eeepc.iso )  works very well
But it has no significant librarys which are present in 4.4.4 .iso's...
I need  "ftdi_sio" and "inputattach" modules to be present to use external monitor with serial touchscreen in this installation (works +\- normal in 4.4.4).
 Inputattach from android 4.4.4 works well on 4.0.4, but ftdi_sio.ko -  doesn't, and I can't find the right version over the Net.  Also can't compile it from sources...
And can't use more recent version of hardware - with Android 4.4.4  (I have also EEEPc 1000h) -  because it's too big :)

So please help with this question:  is it possible at all to run Android 4.4.4 on eeepc701?
How to tell it that native screen resolution is 800x480?  is it EDID  problem or I have to support this resolution in vesamenu?  
HOW this problem was solved in android-x86-4.0-r1-eeepc.iso well-known build???????
THANKS to those who read it all  :)  

Diodosvet

unread,
Jan 12, 2022, 10:49:38 AMJan 12
to Android-x86
Hello everybody!
Let me continue a little :)
I've tried  "set_property debug.drm.mode.force= 800x480@60" property in system/etc/init.sh but still not succeeded to start GUI in  android-x86-4.4-r5 on i915 VGA chipset
 

Here are parts of my logs of successfull (on 4.0 platform) and failed (on 4.4.4 platform) start. (see attached files) 
As I understood from those logs and learned from this link: https://2net.co.uk/tutorial/android-egl-cgf-is-dead

the main difference between  2 builds of android x86 is that  in Kit Kat 4.4, the OpenGL loader code has been changed and it works different than in 4.0
where both 
D/libEGL  ( 1462): loaded /system/lib/egl/libGLES_android.so
D/libEGL  ( 1462): loaded /system/lib/egl/libGLES_mesa.so
drivers are loaded and 
this fail :
W/EGL-GALLIUM( 1478): failed to create a pipe screen for i915
W/EGL-GALLIUM( 1478): failed to create DRM screen
W/EGL-GALLIUM( 1478): will fall back to other EGL drivers if any

is not leading to the looping of GUI start procedure

at same time in 4.4.4:
only 
D/libEGL  ( 2088): loaded /system/lib/egl/libGLES_mesa.so
is loaded and it's crash :
F/libc    ( 2088): Fatal signal 4 (SIGILL) at 0x417e9976 (code=2), thread 2088 (surfaceflinger)
I/DEBUG   ( 1198): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
I/DEBUG   ( 1198): Build fingerprint: 'Android-x86/android_x86/x86:4.4.4/KTU84Q/eng.cwhuang.20160206.120252:userdebug/test-keys'
I/DEBUG   ( 1198): Revision: '0'
I/DEBUG   ( 1198): pid: 2088, tid: 2088, name: surfaceflinger  >>> /system/bin/surfaceflinger <<<

leads to the looping of zygoteinit procedure..

D/AndroidRuntime( 2089): >>>>>> AndroidRuntime START com.android.internal.os.ZygoteInit <<<<<<

I really don't know what to try next and now reading only old threads like this one : https://groups.google.com/g/android-x86/c/Qz9QUSG_iDo  in order to find any kind of solution..
I would be very grateful for any help.



succ_4_0.txt
failed_4_4_4.txt

Jordan Livesey

unread,
Jan 12, 2022, 10:54:02 AMJan 12
to andro...@googlegroups.com
google officially stopped supporting google play on android 4.0icecream sandwich, you might be able to use android 5.1 which can at least run some apps, the last version of chrome was on 95, in fact, I would like to run googles talkback screen reader while installing and using android x86 itself but I can't because there is no way of turning it on like you can on a real android device just by pressing both volume keys, you also have the option of android 4.4 kitcat but you are better off with lollipop since play store still works on that version

--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/android-x86/17bf4646-6cff-463e-96ed-05003aa275b1n%40googlegroups.com.

Diodosvet

unread,
Jan 12, 2022, 11:10:23 AMJan 12
to Android-x86
Thanks for Your answer, but my problem is that i _can't_  use versions of  android newer than 4.0  on this netbook because I can't start GUI if  android is greater than 4.0.1
I tried 5.1, 6.0, 7.1, 8.1 - always tha same - GUI won't start

The only reason of using android on this hardware is to run special application for controlling automotive lighting system that we develop. Now it's running perfectly on phones, car multimedia dev and so on but i'd like to run it on PC

I don't need any google services like Google Play, I need only small size of netbook  and external VGA with serial touchscreen to work: 
изображение_2022-01-12_190514.png
like here, but this version of eeepc running kitkat 4.4.4 is too big to install in our test  car.

среда, 12 января 2022 г. в 18:54:02 UTC+3, jordanl...@gmail.com:

Jordan Livesey

unread,
Jan 12, 2022, 11:15:00 AMJan 12
to andro...@googlegroups.com
I would just run it in BlueStacks. On another PC.
From: andro...@googlegroups.com <andro...@googlegroups.com> on behalf of Diodosvet <eug...@gmail.com>
Sent: Wednesday, January 12, 2022 4:10:22 PM
To: Android-x86 <andro...@googlegroups.com>
Subject: Re: Android-x86 > 4.0 on antiquarian hardware - Asus EEEPc 701 (4G)
 

Diodosvet

unread,
Jan 12, 2022, 11:21:04 AMJan 12
to Android-x86
Maybe you're right...  windows xp runs very well on this old guy..  if I  won't find a way to run android x86 i'll try to collect glitches of both systems  :) 

среда, 12 января 2022 г. в 19:15:00 UTC+3, jordanl...@gmail.com:

Din Assegaf

unread,
Jan 12, 2022, 11:39:11 AMJan 12
to andro...@googlegroups.com

We cant doubt it, the easy way just run Bluestack, and everything just work fine... so what is the purpose of Android-86 ?
The community of helping each other to modify framework or add anything that benefit each other ... thats the spirit ...


Deen


Diodosvet

unread,
Jan 12, 2022, 11:44:39 AMJan 12
to Android-x86
I'm not sure that _everything_ (our application, bluetooth, CAN bus adapters etc) will work fine under bluestak, I'm only sure that i'll try it :)

среда, 12 января 2022 г. в 19:39:11 UTC+3, asseg...@gmail.com:

Jordan Livesey

unread,
Jan 12, 2022, 12:35:29 PMJan 12
to andro...@googlegroups.com
if you have an older android device handy you can also use that, if only the x86 builds came with talkback so that people like me who have a visual impairement and who love android could try this out, especially on an old lenovo like mine


Sent: Wednesday, January 12, 2022 4:44:39 PM

Diodosvet

unread,
Jan 28, 2022, 9:22:49 AMJan 28
to Android-x86
Hello   everybody!
I've fixed my problem with asus eeepc 701 & android 4.4.4 by changing asus eeepc 701 to asus eeepc 901  :)
it has the same size, but intel atom inside. 
now KitKat 4.4.4 work well  and I'm trying to solve last problem : getting work external touchscreen.  I'll start separate discussion for it.

среда, 12 января 2022 г. в 20:35:29 UTC+3, jordanl...@gmail.com:
Reply all
Reply to author
Forward
0 new messages