Ministro's SSL certificate expired?

57 views
Skip to first unread message

Tommy Griffith

unread,
Apr 27, 2016, 12:03:14 PM4/27/16
to android-qt
When trying to download qt libs from Ministro, I run into a CertificateExpiredException when using the OpenSSL certificate.

The date and time on my device are correct, so I'm assuming the server certificate is expired.

Is anybody else having this issue?

Thanks,
Tommy

Tommy Griffith

unread,
Apr 27, 2016, 11:10:46 PM4/27/16
to android-qt
Update: it appears legacy applications using http://download.qt-project.org/ministro/android won't work anymore without the server SSL cert being updated.  

I confirmed that the cert at the newer website https://download.qt.io/ministro/android is valid.

Is there any chance the certs on the legacy website can be updated so that legacy applications can still work?

Thanks,
Tommy

Willy Gardiol

unread,
Apr 28, 2016, 1:02:21 AM4/28/16
to andro...@googlegroups.com

Its sad to see that ministro has been basically abandoned. This toghether with the disaster of not working on any android >= 5 its the confirmation of the fears we had back in time when some people opposed it.

Anyway, lets move on and hope somebody still read this list and has time to do something.


Willy Gardiol
Inviato dal mio Note3
--
You received this message because you are subscribed to the Google Groups "android-qt" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-qt+...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

BogDan Vatra

unread,
Apr 28, 2016, 1:40:10 AM4/28/16
to android-qt
Hi,

We're working on it.

Yours,
BogDan.

Willy Gardiol

unread,
Apr 28, 2016, 1:47:18 AM4/28/16
to andro...@googlegroups.com

Sorry for the harsh words BogDan ;)



Willy Gardiol
Inviato dal mio Note3


Yury Lunev

unread,
May 15, 2016, 11:25:12 AM5/15/16
to andro...@googlegroups.com
BogDan Vatra <taipanromania@...> writes:
>
> Hi,
>
> We're working on it.
>
> Yours,
> BogDan.
>
> 2016-04-27 19:03 GMT+03:00 Tommy Griffith <lockawam@...>:
> > When trying to download qt libs from Ministro, I run into a
> > CertificateExpiredException when using the OpenSSL certificate.
> >

I vote for this problem too. The thing is, that Ministro does download .xml file
from qt.io site, but many (all?) links are pointing to download.qt-project.org
(see qt-5.4/stable/armeabi-v7a/android-19/libs-5.4.xml), so while the
downloading process works for some time, it doesn't finish successfully -
Minstro complains about QtQuick being inaccessible.

I use https://download.qt.io/ministro/android/qt5/qt-5.4 as qt_sources parameter
as my old production project is using 5.4 at the time.

*.qt-project.org certificate has been expired for 2 months already and
I seem to have to make my own mirror as the solution for this problem.


BogDan Vatra

unread,
May 16, 2016, 4:10:47 AM5/16/16
to android-qt
Hi,

Sadly I can't do anything, because qtproject.org is maintained by
The Qt Company, I pinged Qt folks again this morning and I hope they
will fix it soon.

Starting with 5.7 I switched to qt.io but I can't do anything for the
already deployed apps.

Yours,
BogDan.

BogDan Vatra

unread,
May 24, 2016, 4:28:52 AM5/24/16
to android-qt
Hello,

Finally The Qt Company managed to fix the SSL issue, I apologize again
for this inconvenience.

Yours,
BogDan.

Marco Bernasocchi

unread,
May 24, 2016, 5:45:40 AM5/24/16
to andro...@googlegroups.com
Hi Bogdan, Thanks.

just one question, am I missing something, ministro still doesn't work
with android 5+ right?

ciao
--
Marco Bernasocchi
opengis.ch - berna.io - 27summits.ch

BogDan Vatra

unread,
May 24, 2016, 5:57:35 AM5/24/16
to android-qt
Right, this weekend (or next week) I'll try to workaround this problem ...

Marco Bernasocchi

unread,
May 24, 2016, 6:21:36 AM5/24/16
to andro...@googlegroups.com, Matthias Kuhn
That would be really really great!
Thanks a lot
Marco

Marco Bernasocchi

unread,
Jun 7, 2016, 10:00:24 AM6/7/16
to andro...@googlegroups.com
Hi Bogdan did you get the chance/time to have a look at the android 5 issue?

ciao
Marco

On 24.05.2016 11:57, BogDan Vatra wrote:

BogDan Vatra

unread,
Jun 8, 2016, 5:37:59 AM6/8/16
to android-qt
Hi,

Yes, I tried these days lots of workarounds and, sadly, none of them worked ...

Cheers,
BogDan.

Roman Lebedev

unread,
Jul 1, 2016, 5:13:23 PM7/1/16
to android-qt
Hello.
It seems like C4droid can still use Qt even on Android 5.0 (and 6.0). Can you please provide and example of APK that doesn't work (and/or more info), so I can try to fix that (and find what is different in case of C4droid).

среда, 8 июня 2016 г., 15:37:59 UTC+6 пользователь BogDan написал:

Marco Bernasocchi

unread,
Jul 1, 2016, 6:46:48 PM7/1/16
to andro...@googlegroups.com
It is not QT the problem. It is ministro. If you bundle qt in the apk it works (like we do for qfield.org)

Ciao
--
Marco Bernasocchi (mobile).
OPENGIS.ch - berna.io - 27summits.ch

Roman Lebedev

unread,
Jul 2, 2016, 8:49:42 AM7/2/16
to android-qt
C4droid is actually using Ministro.
I'm its author :)

суббота, 2 июля 2016 г., 4:46:48 UTC+6 пользователь Marco Bernasocchi написал:

BogDan

unread,
Jul 4, 2016, 3:30:36 AM7/4/16
to android-qt
Hi Roman,

It is impossible to use Ministro on (non-rooted) Android 5.x+ devices because of this https://code.google.com/p/android/issues/detail?id=79478 bug.
Basically the linker refuses to load any libraries that don't belongs to current application user or "system" user.

Yours,
BogDan.

Roman Lebedev

unread,
Jul 4, 2016, 3:57:21 AM7/4/16
to android-qt
Well, for me Ministro still works (in case of C4droid), on all real Android 5+ devices and emulators I have (works on unrooted devices as well). Should be a bug in a bug.

понедельник, 4 июля 2016 г., 13:30:36 UTC+6 пользователь BogDan написал:

BogDan

unread,
Jul 4, 2016, 4:15:15 AM7/4/16
to android-qt
Hi,

Strange ... do you have a simple example that I can try?

Cheers,
BogDan.

Roman Lebedev

unread,
Jul 4, 2016, 4:31:25 AM7/4/16
to android-qt
I've attached an example exported from C4droid.
Source code for libcutehack.

понедельник, 4 июля 2016 г., 14:15:15 UTC+6 пользователь BogDan написал:
application.apk

Roman Lebedev

unread,
Jul 4, 2016, 4:37:19 AM7/4/16
to android-qt
By the way, as I remember, trying to run application without libcutehack caused some problems on some devices (don't remember what exactly), so ignoring JNI_OnLoad by using a proxy library was a solution.
Although, mainly this proxy library was used for other reasons.

понедельник, 4 июля 2016 г., 14:31:25 UTC+6 пользователь Roman Lebedev написал:

BogDan Vatra

unread,
Jul 4, 2016, 4:58:07 AM7/4/16
to android-qt
Hi,

Incredibly it works ...

A few questions:
- besides libcutehack, did you changed the java part?
- if yes, then can you share the changes?

Cheers,
BogDan.

Roman Lebedev

unread,
Jul 4, 2016, 5:07:27 AM7/4/16
to android-qt
I've changed the java part a bit, but it is way too ugly to share (most of the changes are C4droid-related).
The main changes are:
1) Using the libcutehack
2) Changing the repository when the arch is aarch64 or the files for current API don't exist.

понедельник, 4 июля 2016 г., 14:58:07 UTC+6 пользователь BogDan написал:

BogDan Vatra

unread,
Jul 4, 2016, 5:17:02 AM7/4/16
to android-qt
Hi,

Thanks, I'll check the code ... It seems in recent Android 5 versions
the linker problem was "fixed" but the bug report is still open :O ...

Cheers,
BogDan.
Reply all
Reply to author
Forward
0 new messages