install arm-v8a armeabi-v7a armeabi using sdk manager

194 views
Skip to first unread message

Eddy Alleman

unread,
Apr 1, 2018, 2:11:45 AM4/1/18
to android-qt
Hello,


I just got a new samsung Galaxy S9 and I want to deploy a Qt test program on it with no success.

I can do this for the Galaxy S5 without a problem. So I followed the same steps for the S9:
Developer mode is on the phone
Qt creator tells me:
  • Java settings are OK
  • Android settings are OK ( SDK version 25.2.5, NDK version 10.4.0)
  • SDK manager is not available with the current version of SDK tools. Use native SDK manager.

I installed API level 26 for android 8.0.0 using the SDK manager:

 










When running a test program from Qt Creator 4.6 I get the following message:
ABI is incompatible, device supports ABI's : arm64-v8a armeabi-v7a armeabi

So obviously I need to install that one.

Does anyone know a way to do this manually 
or do I have to be patient to see  arm64-v8a armeabi-v7a armeabi in the SDK manager list? When can we expect this to happen?

any insights or pointers to the matter are welcome,



Eddy


Eddy Alleman

unread,
Apr 1, 2018, 6:31:44 AM4/1/18
to android-qt
I found a solution and can deploy a Qt application now.

for anyone encountering the same :

Both - armeabi and armeabi-v7a - libraries run fine on newer devices with arm64-v8a instruction.

No need to install anything extra.

solution found at:

Cheers,

Eddy

Op zondag 1 april 2018 08:11:45 UTC+2 schreef Eddy Alleman:
Reply all
Reply to author
Forward
0 new messages