Boost, STLPort and Cygwin

105 views
Skip to first unread message

Bryan Ashby

unread,
Apr 29, 2010, 6:36:49 PM4/29/10
to android-ndk
Has anyone been able to get Boost compiling (with or without the
modified NDK enabling RTTI/exceptions) against STLPort under Cygwin?
I've been able to build bjam under Cygwin so the paths/etc. work
properly. Now I'm on to building Boost itself.

user-config.jam has been modified by adding the following lines:

using gcc : arm : /cygdrive/c/dev/ghoti/client/external/android/
android-ndk-r3/build/prebuilt/windows/arm-eabi-4.4.0/bin/arm-eabi-g+
+ ;

using stlport : : /cygdrive/c/dev/ghoti/client/external/android/ndk-
wrappers/stlport/stlport ;

From the boost directory & using my Cygwin-built bjam:
bjam toolset=gcc-arm target-os=linux stdlib=stlport cflags="-DANDROID"

This gives me tons and tons of errors about such things as:
/cygdrive/c/dev/ghoti/client/external/android/ndk-wrappers/stlport/
stlport/stl/_cstdio.h:26:42: error: ../include/stdio.h: No such file
or directory

Has anyone been able to get this to work? What am I missing here? Any
help appreciated. Without this, we'd have to re-implement tons and
tons of code.

Thanks!

--
You received this message because you are subscribed to the Google Groups "android-ndk" group.
To post to this group, send email to andro...@googlegroups.com.
To unsubscribe from this group, send email to android-ndk...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/android-ndk?hl=en.

Bryan Ashby

unread,
Apr 30, 2010, 2:57:34 PM4/30/10
to android-ndk
As a update, I've made it slightly further along (I think):

user-config.jam:
using gcc : arm : /cygdrive/c/dev/ghoti/client/external/android/
android-ndk-r3/build/prebuilt/windows/arm-eabi-4.4.0/bin/arm-eabi-g+
+ : \
<cxxflags>-pthread \
<cxxflags>-DBOOST_HAS_THREADS \
<cxxflags>-DANDROID \
<cxxflags>-DBOOST_NO_TYPEID \
<cxxflags>--sysroot=$NDK_ROOT/build/platforms/android-4/arch-arm
<cxxflags>-D__NEW__ \
<cxxflags>-D__SGI_STL_INTERNAL_PAIR_H \
<cxxflags>-DBOOST_NO_CWCHAR \
<cxxflags>-DBOOST_NO_CWCTYPE \
<architecture>arm \
;

using stlport : : /cygdrive/c/dev/ghoti/client/external/android/ndk-
wrappers/stlport/stlport ;

Can't seem to get past this error during bjam build:
./boost/iostreams/char_traits.hpp:26: error: '::wint_t' has not been
declared

Again, would love any help anyone can provide -- It seems from
previous messages in the groups that people are using Boost with
STLPort on Android.
Reply all
Reply to author
Forward
0 new messages