Unparsed aapt error

10066 views
Skip to first unread message

Patrick Noffke

unread,
Mar 16, 2010, 9:57:13 AM3/16/10
to android-d...@googlegroups.com
Hi all,

I found some old posts on this problem, and I was having a similar issue, so I thought I'd share what I learned.

I was getting this error after modifying an XML file, and I was unable to start a debug session until I fixed the problem.  It seems if there are errors that cause aapt to fail, eclipse can get in a state where it doesn't know when the problem gets fixed.  Deleting R.java did not work for me.  What I ended up doing after I fixed the XML file is right-clicking on the error message in the Problems view, and deleting the error.  Then modify some files to force a rebuild and you should be okay.

I found it helps to turn the android log level to Verbose (Preferences -> Android -> Build).  This led me to know that once I fixed the XML file, aapt was happy, but eclipse was not.

Hopefully this will save someone else the 3 hours I burned trying to figure it out!

Patrick

sfoye

unread,
Mar 18, 2010, 8:43:02 PM3/18/10
to Android Developers
Thank you - I just ran into this problem and your solution worked
great. Luckily I only spent 15 minutes trying to solve before I found
your post.
-sfoye

Peter

unread,
Apr 10, 2010, 10:20:18 AM4/10/10
to Android Developers
Thanks! Worked like a charm for me too.

Saurabh

unread,
Apr 13, 2010, 11:08:51 PM4/13/10
to Android Developers
Amazing!! Thanks a ton for this fix! You just saved a ton of my
time :)

WebEtToile

unread,
Apr 20, 2010, 10:15:16 AM4/20/10
to Android Developers
Thanks, only 20 minutes lost here. I hadn't even thought about right-
clicking the error message.
--
You received this message because you are subscribed to the Google
Groups "Android Developers" group.
To post to this group, send email to android-d...@googlegroups.com
To unsubscribe from this group, send email to
android-develop...@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/android-developers?hl=en

Christopher

unread,
Apr 21, 2010, 4:02:12 PM4/21/10
to Android Developers
Doing "Project" > "Clean" in Eclipse helped clear up the problem for
me.

Kantesh

unread,
Apr 27, 2010, 4:31:32 AM4/27/10
to Android Developers
Hey still i coudn get rid of it..

Kantesh

unread,
Apr 27, 2010, 4:35:57 AM4/27/10
to Android Developers
Hey please help.. i followed u.. but still cudn get rid of it..its
showing error in java file.. werever r.layout is there..

Carlito

unread,
May 1, 2010, 4:24:45 PM5/1/10
to Android Developers
Thanks! Lost only 10 minutes.

Peeyush

unread,
Jun 17, 2010, 3:18:17 PM6/17/10
to Android Developers
Dear All,

I am not able not fix this issue by given solution.
After doing right click and deleting the error, it does not show the
error in project explorer and error window.
but the project is not getting run.
if i delete "gen" folder and give clean build, it does not generate
R.java.
even it is not creating apk also.

I have got one more error: "Project has no default.properties file!
Edit the project properties to set one."
how to fix it.
> For more options, visit this group athttp://groups.google.com/group/android-developers?hl=en- Hide quoted text -
>
> - Show quoted text -

Harsha

unread,
Jun 29, 2010, 3:27:21 PM6/29/10
to Android Developers
Thanks a lot it took me just 5 mins to rectify the error because of
your post

On Jun 17, 12:18 pm, Peeyush <varshney.peey...@gmail.com> wrote:
> Dear All,
>
> I am not able not fix this issue by given solution.
> After doing right click and deleting theerror, it does not show theerrorin project explorer anderrorwindow.
> but the project is not getting run.
> if i delete "gen" folder and give clean build, it does not generate
> R.java.
> even it is not creating apk also.
>
> I have got one moreerror: "Project has no default.properties file!
> Edit the project properties to set one."
> how to fix it.
>
> On May 2, 1:24 am, Carlito <carl.dhall...@gmail.com> wrote:
>
>
>
> > Thanks! Lost only 10 minutes.
>
> > On Mar 16, 3:57 pm, Patrick Noffke <patrick.nof...@gmail.com> wrote:
>
> > > Hi all,
>
> > > I found some old posts on this problem, and I was having a similar issue, so
> > > I thought I'd share what I learned.
>
> > > I was getting thiserrorafter modifying an XML file, and I was unable to
> > > start a debug session until I fixed the problem.  It seems if there are
> > > errors that causeaaptto fail, eclipse can get in a state where it doesn't
> > > know when the problem gets fixed.  Deleting R.java did not work for me.
> > >  What I ended up doing after I fixed the XML file is right-clicking on the
> > >errormessage in the Problems view, and deleting theerror.  Then modify
> > > some files to force a rebuild and you should be okay.
>
> > > I found it helps to turn the android log level to Verbose (Preferences ->
> > > Android -> Build).  This led me to know that once I fixed the XML file,aapt
> > > was happy, but eclipse was not.
>
> > > Hopefully this will save someone else the 3 hours I burned trying to figure
> > > it out!
>
> > > Patrick
>
> > --
> > You received this message because you are subscribed to the Google
> > Groups "Android Developers" group.
> > To post to this group, send email to android-d...@googlegroups.com
> > To unsubscribe from this group, send email to
> > android-develop...@googlegroups.com
> > For more options, visit this group athttp://groups.google.com/group/android-developers?hl=en-Hide quoted text -

Patrick Noffke

unread,
Jul 26, 2010, 9:17:03 AM7/26/10
to android-d...@googlegroups.com
Are there any google devs on here?  I get about one "thanks" a week (off list) for my post.

Is there somewhere I can file this as a bug?

Pat

On Mon, Jul 26, 2010 at 6:01 AM, parag <parag.sh...@gmail.com> wrote:
thanks man,
u really saved my time..

RichardC

unread,
Jul 26, 2010, 11:08:45 AM7/26/10
to Android Developers
b.android.com

On Jul 26, 2:17 pm, Patrick Noffke <patrick.nof...@gmail.com> wrote:
> Are there any google devs on here?  I get about one "thanks" a week (off
> list) for my post.
>
> Is there somewhere I can file this as a bug?
>
> Pat
>

Patrick Noffke

unread,
Jul 27, 2010, 10:58:58 AM7/27/10
to android-d...@googlegroups.com
Bug submitted here:

http://code.google.com/p/android/issues/detail?id=10012

Others may want to "star" the issue so it gets some visibility.

Thanks.

Ranhiru

unread,
Sep 14, 2010, 2:58:26 PM9/14/10
to Android Developers
Phew! Just saved a few hours of my time... You are a life saver! :D

On Jul 27, 7:58 pm, Patrick Noffke <patrick.nof...@gmail.com> wrote:
> Bug submitted here:
>
> http://code.google.com/p/android/issues/detail?id=10012
>
> Others may want to "star" the issue so it gets some visibility.
>
> Thanks.
>
> On Mon, Jul 26, 2010 at 10:08 AM, RichardC
> <richard.crit...@googlemail.com>wrote:
> > Groups "Android Developers" group.> To post to this group, send email toandroid-...@googlegroups.com
> > To unsubscribe from this group, send email to>android-develop...@googlegroups.com<android-developers%2Bunsu...@googlegroups.com>

kiki

unread,
Sep 21, 2010, 7:52:43 AM9/21/10
to Android Developers
hey thanx a lott...helped me out too...
but really!.. what a terrible bug in eclipse!!!
> > > To unsubscribe from this group, send email to>android-develop...@googlegroups.com<android-developers%2Buns­ubsc...@googlegroups.com>
> > > For more options, visit this group at
> > >http://groups.google.com/group/android-developers?hl=en- Hide quoted text -

Indicator Veritatis

unread,
Sep 21, 2010, 4:15:53 PM9/21/10
to Android Developers
Eclipse and APT have much bigger problems than this one...
> > > >http://groups.google.com/group/android-developers?hl=en-Hide quoted text -
Reply all
Reply to author
Forward
0 new messages