Javascript problem with Webview runing under a HTC Desire

342 views
Skip to first unread message

Huahe

unread,
May 31, 2010, 6:31:57 AM5/31/10
to Android Developers
Hello.

I am developing an application with Webview. The web app that runs
inside the Webview is loaded from internet, and it is a single HTML
file. I use javascript for showing and hiding the divs, depending on
the section button the user had tapped on.

The problem is simple: after a little while (this time period seems to
be random), javascript stops working inside the Webview object. Then,
after a few seconds (10-30 seconds), javascript works again. It
doesn't work any javascript. Nothing.

The strange thing is that the problem only happens when the
application runs in a HTC Desire. I tested it in two different HTC
Desire, and the problem happens in both devices. I tested it in a
Motorola Milestone, in a HTC Hero and under emulator (1.5,1.6,2.1) and
the application works fine, no error at all.

The problem happens using Wifi or mobile network.

I tried the debugger, but "Dev tools" crashes when I tap in
"Development Settings". I also tried to compile the application for
debugging under Eclipse, but adb does not show me info about the
WebView object.

The HTC Desire firmware version is 2.1-update1. Kernel version:
2.6.29-3cb3dfbf. Build number: 1.15.161.4 Webkit 3.1

Thanks, any help will be appreciated.

N@oj

unread,
Jun 14, 2010, 7:43:15 AM6/14/10
to Android Developers
Hello,

Got the same problem with my HTC Desire firmware version is 2.1-
update1. Kernel version:
2.6.29-97da29ed. Build number: 1.15.405.4 Webkit 3.1.

I'm developping an application in GWT which works under emulator (1.6,
2.1), Samsung Galaxy, Galaxy Spica, Acer Liquid.

Sometimes asynccallback doesn't return, animation, etc...


On 31 mai, 12:31, Huahe <jua...@gmail.com> wrote:
> Hello.
>
> I am developing an application with Webview. The web app that runs
> inside the Webview is loaded from internet, and it is a single HTML
> file. I usejavascriptfor showing and hiding the divs, depending on
> the section button the user had tapped on.
>
> The problem is simple: after a little while (this time period seems to
> be random),javascriptstops working inside the Webview object. Then,
> after a few seconds (10-30 seconds),javascriptworks again. It
> doesn't work anyjavascript. Nothing.
>
> The strange thing is that the problem only happens when the
> application runs in a HTCDesire. I tested it in two different HTCDesire, and the problem happens in both devices. I tested it in a
> Motorola Milestone, in a HTC Hero and under emulator (1.5,1.6,2.1) and
> the application works fine, no error at all.
>
> The problem happens using Wifi or mobile network.
>
> I tried the debugger, but "Dev tools" crashes when I tap in
> "Development Settings". I also tried to compile the application for
> debugging under Eclipse, but adb does not show me info about the
> WebView object.
>
> The HTCDesirefirmware version is 2.1-update1. Kernel version:
Reply all
Reply to author
Forward
0 new messages