Upgrading androidx prebuilts in android-10?

64 views
Skip to first unread message

Ryen Twok

unread,
Aug 24, 2022, 5:50:50 PMAug 24
to Android Building
I'm trying to upgrade AndroidX libs for my local aosp branch android-10.0.0_r41.

I've tried import_maven_artifacts.py which seems to place new libs in prebuilts/androidx/internal & external but doesn't actually replace those in sdk/current (i'm guessing this isn't the intended usage for that script).

I've also tried prebuilts/sdk/update_prebuilts.py using a recent build_id from Android CI.  This downloaded a new m2repository within prebuilts/sdk/current, but now leaves undefined modules when trying to build (see error below).

Could it have something to do with the contents of androidx-api.txt (in prebuilts/sdk/current)?  The script update_androidx-api.sh looks for current.txt in frameworks/support, but that doesn't look to be available anymore.

Error from make:

FAILED: out/soong/build.ninja
out/soong/.bootstrap/bin/soong_build -t -l out/.module_paths/Android.bp.list -b out/soong -n out -d out/soong/build.ninja.d -globFile out/soong/.bootstrap/build-globs.ninja -o out/soong/build.ninja Android.bp
error: frameworks/opt/photoviewer/Android.bp:47:1: "libphotoviewer" depends on undefined module "androidx.legacy_legacy-support-core-ui"
error: frameworks/opt/photoviewer/Android.bp:47:1: "libphotoviewer" depends on undefined module "androidx.legacy_legacy-support-core-utils"
error: prebuilts/sdk/current/androidx/Android.bp:348:1: "androidx.core_core" depends on undefined module "annotation-experimental"
error: prebuilts/sdk/current/androidx/Android.bp:1262:1: "androidx.recyclerview_recyclerview" depends on undefined module "customview-poolingcontainer"
Reply all
Reply to author
Forward
0 new messages