Gem::Exception: can't activate ParseTree (= 2.1.1), already activated ParseTree-2.0.1

19 views
Skip to first unread message

femto

unread,
May 5, 2008, 3:10:07 AM5/5/08
to ambition.rb
while trying to use ambitions, it reports the following error:
Gem::Exception: can't activate ParseTree (= 2.1.1), already activated
ParseTree-2.0.1.
And also ambitious-activerecord can't be installed:

Install required dependency ambition? [Yn] Y
ERROR: While executing gem ... (Gem::GemNotFoundException)
Could not find ambition (>= 0.5.3) in any repository
while the most recent version of ambition thru gem install is
0.5.2

Allan

unread,
May 5, 2008, 3:22:41 AM5/5/08
to ambition.rb


On May 5, 8:10 am, femto <femto...@gmail.com> wrote:

> And also ambitious-activerecord can't be installed:
>
> Install required dependency ambition? [Yn] Y
> ERROR: While executing gem ... (Gem::GemNotFoundException)
> Could not find ambition (>= 0.5.3) in any repository
> while the most recent version of ambition thru gem install is
> 0.5.2

The workaround I used to get round this issue was to put ambition into
my vendor/plugins directory straight from the git repository.

Allan

festiv...@gmail.com

unread,
May 14, 2008, 8:04:00 PM5/14/08
to ambition.rb
Allan,

I assume you did this by cloning ambition:
git clone git://github.com/defunkt/ambition.git (?)

This seems to pull in ambition just fine, but where is ambitious-
activerecord at that point? The requires on ambition.rubyforge.org
for ambitious-activerecord fail:
require 'rubygems'
require 'ambition/adapters/active_record'

because there's no adapters present I guess. The URL on the blog:
http://github.com/defunkt/ambition/tree/master/adapters/ambitious_activerecord

Also doesn't appear to exist.

I'm lost :(

Chris Wanstrath

unread,
May 14, 2008, 8:05:08 PM5/14/08
to ambit...@googlegroups.com
The ActiveRecord adapter is at http://github.com/defunkt/ambitious_activerecord

I'll update the blog soon.

--
Chris Wanstrath
http://github.com/defunkt

thoraxe

unread,
May 14, 2008, 8:12:02 PM5/14/08
to ambition.rb
Roger that. I can clone it just fine but I'm not sure how to
"install" it... or does just having ambition and ambitious-
activerecord in the vendor/plugin area suffice?

On May 14, 8:05 pm, "Chris Wanstrath" <ch...@ozmm.org> wrote:
> The ActiveRecord adapter is athttp://github.com/defunkt/ambitious_activerecord

Gordon Thiesfeld

unread,
May 15, 2008, 8:46:41 AM5/15/08
to ambit...@googlegroups.com
On Wed, May 14, 2008 at 7:12 PM, thoraxe <erikm...@gmail.com> wrote:
>
> Roger that. I can clone it just fine but I'm not sure how to
> "install" it... or does just having ambition and ambitious-
> activerecord in the vendor/plugin area suffice?
>

You can run `rake gem && gem install pkg/*.gem` to install it as a
gem. You might also have luck with rake install, or rake install_gem.
I didn't, but I assume that's because I'm on Windows.

Gordon

thoraxe

unread,
May 15, 2008, 9:02:45 AM5/15/08
to ambition.rb
Once I installed Echoe (echoe) I was able to rake install_gem on both
Ambition 0.5.4 and ambitious-activerecord.

Unfortunately, this doesn't work with STI, so I'm back to square zero.
Reply all
Reply to author
Forward
0 new messages