Warning: doesn't support net5.0 and has not been tested with it. Consider upgrading your TargetFramework to net6.0 or later.

2 views
Skip to first unread message

Carlos Admirador

unread,
Dec 3, 2022, 1:47:14 AM12/3/22
to AltNet-Hispano

En VS2022, con un proyecto Blazor con librerías, todo net5, al actualizar una dependencia en una librería, me aparecen un montón de warning de este estilo:

Warning        Microsoft.Extensions.DependencyInjection.Abstractions 7.0.0 doesn't support net5.0 and has not been tested with it. Consider upgrading your TargetFramework to net6.0 or later. You may also set <SuppressTfmSupportBuildWarnings>true</SuppressTfmSupportBuildWarnings> in the project file to ignore this warning and attempt to run in this unsupported configuration at your own risk.    xxxxxxxx.WebApiV1    C:\Users\zzzzzzzzz\.nuget\packages\microsoft.extensions.dependencyinjection.abstractions\7.0.0\buildTransitive\netcoreapp2.0\Microsoft.Extensions.DependencyInjection.Abstractions.targets    4    
  
Y muchos más, en varias librerías:

Warning        Microsoft.Extensions.Configuration.Abstractions 7.0.0 
Warning        Microsoft.Extensions.Http 7.0.0 
Warning        Microsoft.Extensions.Configuration 7.0.0
....

Alguna sugerencia?
Reply all
Reply to author
Forward
0 new messages