Suggest Additional Repositories

0 views
Skip to first unread message

Paul R Schmidtbleicher

unread,
Dec 29, 2021, 1:41:10 PM12/29/21
to
Here are 2 examples of "Problems" I receive with a "zupper dup" command
In each case the second file (after "requires" is not available)

EXAMPLE-1
libavfilter7-4.2.2-6.1.x86_64 requires 'libavresample.so.4()(64bit)

ADDITIONAL INFO EXAMPLE 1
not installable providers: [MAYBE AVAILABLE, BUT NOT IN RPM FORMAT??]
libavresample4-4.2.2-6.1.x86_64[openSUSE-20200604-0

EXAMPLE-2
perl-5.34.0-1.1.x86_64 requires 'perl-base = 5.34.0

In the solutions suggested I end up keeping the older obsolete files and
it resolves the problem to proceed.

MY QUESTION: I have the default repositories PLUS (1) a packman mirror
and (2) a repository added by my "Brave Browser" MINUS "source"
repositories.
ARE THERE OTHER General Repositories you might suggest I add to my
repository list?
Paul

Carlos E.R.

unread,
Dec 29, 2021, 9:56:08 PM12/29/21
to
Insufficient information to process request.

--
Cheers, Carlos.

Paul R Schmidtbleicher

unread,
Dec 31, 2021, 4:14:01 PM12/31/21
to
On Thu, 30 Dec 2021 03:52:29 +0100, Carlos E.R. wrote:

>Insufficient information to process request.

I should have added this is for my OpenSuse Tumbleweed installation
I am puzzled that in the examples I gave that they are suggesting an
update of files that need an unavailable dependency. My thought is there
may be additional repositories outside of the default ones at installation
of Tumbleweed where these files are available.

Carlos E.R.

unread,
Dec 31, 2021, 4:36:08 PM12/31/21
to
On 31/12/2021 22.13, Paul R Schmidtbleicher wrote:
> On Thu, 30 Dec 2021 03:52:29 +0100, Carlos E.R. wrote:
>
>> Insufficient information to process request.
>
> I should have added this is for my OpenSuse Tumbleweed installation

Better.

> I am puzzled that in the examples I gave that they are suggesting an
> update of files that need an unavailable dependency. My thought is there
> may be additional repositories outside of the default ones at installation
> of Tumbleweed where these files are available.

I would prefer to see a copy paste of the full command sequence, from
the point you type the command, with all the responses, copy pasted in a
single mouse sweep.

Preferably using long lines with no wrapping.


Otherwise, your description is too confusing to form a reply, sorry.

I could guess and say that perhaps the problem goes away if you try an
hour later or the next day.


The only repository normally added is Packman.


Also I assume you are using:

zypper refresh
zypper dup


never "zypper up" - in Tumbleweed. The advice for Leap would be the reverse.

--
Cheers, Carlos.
Reply all
Reply to author
Forward
0 new messages