Problem installing FreeDOS on vintage 486 PC

57 views
Skip to first unread message

logic...@gmail.com

unread,
Apr 5, 2019, 9:58:58 PM4/5/19
to
I am trying to install FreeDOS 1.2 on a vintage 486 PC I have been playing around with lately. It is a Soyo motherboard made in 1994 with ISA slots and 3 VLB slots. The processor is an Intel 486DX4 100MHZ. I have 16MB of memory. I already have OS2/2.11 and MSDOS 6.22 running fine on this machine in separate hard disk partitions. I am trying to install FreeDOS in a separate primary partition. This machine can't boot from a CDROM so I using the floppy boot disk and the legacy CDROM.

I can't get the floppy boot disk to boot very far. It gets to the point where it prompts me to press F8 to trace fdconfig.sys and autoexec.bat and then starts spewing endless garbage to the screen. I have verified that the integrity of the FD12FLOPPY.zip file is good and that the FLOPPY.img file was written successfully to the diskette. (I did this by using rawread to dump the contents of the diskette to temp.img and then did a binary compare between temp.img and FLOPPY.img and verified that there were no miscompares.)

By pressing F8 at the prompt and stepping through the fdconfig.sys I have found the the problem is with HIMEMX.EXE. As soon as that file loads the screen goes bonkers. I have tried editing the fdconfig.sys file and playing with some of the HIMEMX.EXE options. I thought the trouble might have something to do with the control of the A20 line. I tried all possible /METHOD:xxx options. No luck. The only option that seemed to make a difference was /NOABOVE16, but it just caused the PC to hang instead of spewing out garbage text.

I tried copying HIMEM.SYS from MSDOS 6.22 to the diskette and modifying fdconfig.sys to point to that instead of HIMEMX.EXE. That made a big difference. That allowed me to get through fdconfig.sys and autoexec.bat and into the installation procedure. I got through a few screens, where it asked me for my language and if I really wanted to proceed with the install. Then a red screen popped up saying that it couldn't find the installation files. It said that a "reboot might help". I had the legacy CDROM in the CDROM drive and I saw in the bootup messages that it had recognized the CDROM drive. I let it reboot. I got some error message about something was already loaded (don't remember what) and got as far as the message "Gathering some information to prepare for installation..." and there it seemed to hang.

I tried again from the beginning and this time, at the red screen, I told it to return to DOS instead of rebooting. From the DOS prompt I could see my C drive (it's empty, haven't installed FD there yet), the contents of my D drive, but, when I try to see the contents of the E drive, which should be the CDROM drive, it says "Error reading from drive E: data area: drive not ready".

So, I have two problems (so far):
1. HIMEMX.EXE hangs spewing out garbage text
2. If I get past that stumbling block then FD can't read the CDROM. (I have verified that I can browse the CDROM from my MSDOS installation on this same PC.)

Any suggestions?
Charles Bailey

francisk...@gmail.com

unread,
May 7, 2020, 1:29:46 PM5/7/20
to
See my post about the cdrom drive issue
Reply all
Reply to author
Forward
0 new messages