Playlists...again?

29 views
Skip to first unread message

Ross D

unread,
Jun 10, 2013, 3:38:33 PM6/10/13
to allo...@googlegroups.com
Matt,

I am at a stop on trying to figure out how to get playlists to work reliably.  I use them for ITunes radio stations.  I can drill down to the playlist itself but they will not populate.  They had been spotty for months but now I can not get them to populate whatsoever.  I have installed and reinstalled ITunes several times as well as Signal.  Any ideas would be apprecited. All other features do appear to work normally.

Thanks,
Ross

Matt Stevens

unread,
Jun 10, 2013, 3:50:12 PM6/10/13
to allo...@googlegroups.com
Hi Ross,

Can you explain what you mean by populate? Populate where? I just tried starting a playlist with a couple of radio stations in iTunes 11 through Signal then moving between the stations and this worked as expected.

Matt

--
You received this message because you are subscribed to the Google Groups "Alloysoft" group.
To unsubscribe from this group and stop receiving emails from it, send an email to alloysoft+...@googlegroups.com.
To post to this group, send email to allo...@googlegroups.com.
Visit this group at http://groups.google.com/group/alloysoft?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.
 
 

Ross D

unread,
Jun 10, 2013, 4:00:54 PM6/10/13
to allo...@googlegroups.com
Sure, thanks.

In this case..

Media Library/Music/Playlist/Misc Radio/

However anything below /Playlist once I drill into my "Playlists" of which I have six, thier contents do not display.



When I press the "List icon (upper right) it responds "No Items".





I created a new list but no elements within it display.

Signal 1.7.4.1
Itunes 11.0.4.4


Ross

Ross D

unread,
Jun 10, 2013, 4:29:08 PM6/10/13
to allo...@googlegroups.com
Matt,
I also just did a clean install on a different comp. of ITunes and Signal.  I then created Playlists 1...6 and put into each several podcasts, radio staions and a mix with only radio and only podcast.

I am geeting some odd behaviors from Signal.  As for eample only this first item in a playlist will show in Signal. In the case of the podcast, though several podcsasts, only one shows and when I go into it and use "List" I see all the other podcasts in one long list.

Let me know how I can help further.


Ross

On Monday, June 10, 2013 12:50:12 PM UTC-7, Matt Stevens wrote:

Matt Stevens

unread,
Jun 12, 2013, 12:28:59 AM6/12/13
to allo...@googlegroups.com
Hi Ross,

One thing that's important here is that with iTunes 11 Signal doesn't show the contents of the playlist but rather what is in Up Next in iTunes, so that's what you want to compare the list view against. For example, if playing the last item in a playlist Up Next would be empty because there is nothing further in the queue. iTunes also sometimes queues up additional content on its own.

If Signal doesn't match up with what is appearing in Up Next then we'll have to look into it further. If after starting a playlist if Up Next is populated but Signal's list view doesn't show anything, does the list view update when you move to the next song?

Another thing to check is Signal's debug log, on Windows you can get to that by opening Signal's settings interface and pressing Ctrl+Shift+D. Let me know if any errors are reported here.

Matt

Ross D

unread,
Jun 12, 2013, 12:42:53 AM6/12/13
to allo...@googlegroups.com
Matt,
I was literally just sitting down to work on this when I received this post.  Ill try this now.  However, I am curious as I had this working several weeks back (apparently a fluke), is there a way to see Radio stations?  Is there any type of work around that would allow for this via Signal?

Thanks,
Ross

Ross D

unread,
Jun 12, 2013, 12:51:27 AM6/12/13
to allo...@googlegroups.com
[06/11 11:52:47] Signal 1.7.4.1
[06/11 11:52:47] --------------
[06/11 11:52:47] Copyright (c) 2005-2013 Alloysoft, LLC
[06/11 11:52:47]
[06/11 11:52:47] OS: Windows 7
[06/11 11:52:47] Server Name: 340-Desk
[06/11 11:52:47] Media Library Update Started
[06/11 11:52:47]
[06/11 11:52:47] Opening communication channels
[06/11 11:52:47] Initializing XML channel (port 3567)
[06/11 11:52:47] Initializing XML channel discovery (port 3568)
[06/11 11:52:47] Initializing HTTP channel (port 3569)
[06/11 11:52:47] Using Bonjour for Windows
[06/11 11:52:48] Server is started
[06/11 11:52:50] Media Library Update Finished (2.98s)
[06/11 11:52:59] iTunes service name 0E007C5D8E3CBDC7 could not be found, attempting direct connect
[06/11 11:53:02] DMCP request failed: http://127.0.0.1:3689/login?pairing-guid=0x5f4b6c8c14784814
    connection refused
[06/11 21:48:19] HTTP[3]: /state.json?rev=1180
[06/11 21:48:19] HTTP[2]: /state.json?rev=1181
[06/11 21:48:22] HTTP[3]: /media/Music/Playlists.json?start=0&count=35&includeTotalCount=true
[06/11 21:48:26] HTTP[3]: /xml
[06/11 21:48:49] HTTP[3]: /state.json?rev=1181
[06/11 21:48:49] HTTP[2]: /state.json?rev=1182
[06/11 21:49:19] HTTP[3]: /state.json?rev=1182
[06/11 21:49:19] HTTP[2]: /state.json?rev=1183
[06/11 21:49:26] HTTP[3]: /media/Music.json?start=0&count=35&includeTotalCount=true
[06/11 21:49:29] HTTP[3]: /media/Music/Songs.json?start=0&count=35&includeTotalCount=true
[06/11 21:49:31] HTTP[3]: /media/Music.json?start=0&count=35&includeTotalCount=true
[06/11 21:49:35] HTTP[3]: /media.json?start=0&count=35&includeTotalCount=true
[06/11 21:49:36] HTTP[3]: /media/Podcasts.json?start=0&count=35&includeTotalCount=true
[06/11 21:49:42] HTTP[3]: /media/Podcasts/Defected%20In%20The%20House.json?start=0&count=35&includeTotalCount=true
[06/11 21:49:49] HTTP[3]: /state.json?rev=1183
[06/11 21:49:49] HTTP[2]: /state.json?rev=1184
[06/11 21:49:49] HTTP[4]: /xml
[06/11 21:49:53] HTTP channel removed connection: 1 (active: 3)
[06/11 21:49:56] Closing idle connection: 1
Reply all
Reply to author
Forward
0 new messages