Issue with playlists from home shares

24 views
Skip to first unread message

Mick Davis

unread,
Feb 27, 2013, 2:58:20 PM2/27/13
to allo...@googlegroups.com
Hi,

I've been using Signal for years now and love it BTW

Seeing playlists on shares has always been a little iffy. Often I would have to restart Signal, or drop the share and reopen it before the share would show up in the browser.

I pretty much only use Signal in the summer to control the music while I'm sitting on the deck, so it's been at least 5 or 6 months since I used it last.

The newest version was installed today, along with an update to iTunes, and now I can't get Signal to show me the playlists on my share at all.

I'm running Signal 1.7.1.1, iTunes 11.0.2.25 on Windows XP. The machine that hosts the shared music is at the same level of iTunes also running Windows XP.

I'm accessing Signal via an Android phone and tablet with various browsers.

Any help would be appreciated.

Thanks.

Mick

Matt Stevens

unread,
Feb 27, 2013, 3:11:26 PM2/27/13
to allo...@googlegroups.com
Hi Mick,

Thanks for the report, I'll take a look. You're right that shared library support has been a bit iffy, iTunes does not really have a good API for this. I'd hoped that the DMCP interface would provide a more reliable means of accessing shared library information, but unfortunately this requires an authentication mechanism that is private to Apple.

Matt

Mick Davis

unread,
Feb 28, 2013, 11:25:21 AM2/28/13
to allo...@googlegroups.com
Thanks Matt, I appreciate it.  As I said, I love Signal, thanks for the great work!

Mick Davis

unread,
Apr 24, 2013, 9:58:22 PM4/24/13
to allo...@googlegroups.com
Hi Matt,

Any idea if this is something that you'll be able to get working again?

Mick

Matt Stevens

unread,
Apr 26, 2013, 1:39:19 AM4/26/13
to allo...@googlegroups.com
I should be able to get it going again but it's a bit of work to implement so I can't say exactly when it will be available. I do plan to fix it though.

Matt

Matt Stevens

unread,
May 16, 2013, 11:46:11 PM5/16/13
to allo...@googlegroups.com
I've just posted Signal 1.7.4 with a fix for this. Once the shared library has been connected to in iTunes Signal should pick it up.

Matt

Mick Davis

unread,
May 17, 2013, 10:31:35 AM5/17/13
to allo...@googlegroups.com
Fantastic Matt, thank you!  I'll give it a workout this evening.  Just in time for my memorial day party!

Have a great weekend and thank you again for an excellent little program.

Mick


On Thu, May 16, 2013 at 11:46 PM, Matt Stevens <ma...@alloysoft.com> wrote:
I've just posted Signal 1.7.4 with a fix for this. Once the shared library has been connected to in iTunes Signal should pick it up.

Matt

--
You received this message because you are subscribed to a topic in the Google Groups "Alloysoft" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/alloysoft/CXdB9oTKeLI/unsubscribe?hl=en.
To unsubscribe from this group and all its topics, send an email to alloysoft+...@googlegroups.com.
To post to this group, send email to allo...@googlegroups.com.
Visit this group at http://groups.google.com/group/alloysoft?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.



Reply all
Reply to author
Forward
0 new messages