UNABLE TO RUN PGADMIN3.EXE IN ALFRESCO ON WINDOWS SERVER 2016

8 views
Skip to first unread message

blueflame....@gmail.com

unread,
Feb 7, 2019, 8:12:59 AM2/7/19
to Alfresco Technical Discussion
Good day All,

Anytime i try to run "pgAdmin3.exe" in Alfresco community 5 on Windows Server 2016; i keep getting the error below:

"The application was unable to start correctly (0xc000007b)."

Please can anyone guide me on how to resolve this problem i encountered.

Thanks and BR,

Ejike Chiboka

Boriss Mejias

unread,
Feb 8, 2019, 1:56:25 PM2/8/19
to alfresco-techn...@googlegroups.com
Hi Ejike,

I stopped using pgAdmin3 since the release of Postgres 9.5 (4 years ago) as it stopped being compatible with the new versions. Anyway, I don't think your error message is related to that, otherwise it would have been a "connection error", not a "start up error". In any case, the pgAdmin team is highly focus on pgAdmin4 now. I never tried the version 4, as I moved to OmniDB, which also runs on Windows and MacOS (I run it on Linux): https://omnidb.org/en/

Now, the disclaimer is that I worked for 2ndQuadrant, the company behind the development of OmniDB. The project is open source by the way, and free of charge. Maybe you want to give it a try.

Good luck,
Cheers
Boriss

--
You received this message because you are subscribed to the Google Groups "Alfresco Technical Discussion" group.
To unsubscribe from this group and stop receiving emails from it, send an email to alfresco-technical-d...@googlegroups.com.
To post to this group, send email to alfresco-techn...@googlegroups.com.
Visit this group at https://groups.google.com/group/alfresco-technical-discussion.
For more options, visit https://groups.google.com/d/optout.

blueflame....@gmail.com

unread,
Feb 8, 2019, 3:11:14 PM2/8/19
to Alfresco Technical Discussion
Good day Boriss,

Thanks for your response, i really appreciate it.

I was able to resolve the problem by downloading and installing pgAdmin4 and this worked excellently.

I would like to ask this; when backing up DB in Alfresco, do you only back up the alfresco database or you back up both alfresco and postgres?

Looking forward to your feedback.

Regards,

Ejike

On Friday, February 8, 2019 at 7:56:25 PM UTC+1, Boriss Mejias wrote:
Hi Ejike,

I stopped using pgAdmin3 since the release of Postgres 9.5 (4 years ago) as it stopped being compatible with the new versions. Anyway, I don't think your error message is related to that, otherwise it would have been a "connection error", not a "start up error". In any case, the pgAdmin team is highly focus on pgAdmin4 now. I never tried the version 4, as I moved to OmniDB, which also runs on Windows and MacOS (I run it on Linux): https://omnidb.org/en/

Now, the disclaimer is that I worked for 2ndQuadrant, the company behind the development of OmniDB. The project is open source by the way, and free of charge. Maybe you want to give it a try.

Good luck,
Cheers
Boriss

On Thu, 7 Feb 2019 at 14:13, <blueflame....@gmail.com> wrote:
Good day All,

Anytime i try to run "pgAdmin3.exe" in Alfresco community 5 on Windows Server 2016; i keep getting the error below:

"The application was unable to start correctly (0xc000007b)."

Please can anyone guide me on how to resolve this problem i encountered.

Thanks and BR,

Ejike Chiboka

--
You received this message because you are subscribed to the Google Groups "Alfresco Technical Discussion" group.
To unsubscribe from this group and stop receiving emails from it, send an email to alfresco-technical-discussion+unsub...@googlegroups.com.

Zied Louhichi

unread,
Feb 10, 2019, 4:27:45 PM2/10/19
to alfresco-techn...@googlegroups.com
Hello,

For error with pgadmin3  i thing it's somme missing libraries in your system, .net framework and microsoft redistributr. For backup you have only to backup your data base and your alf_data.

Le Ven. 8 Fév. 2019 21:11, <blueflame....@gmail.com> a écrit :
Good day Boriss,

Thanks for your response, i really appreciate it.

I was able to resolve the problem by downloading and installing pgAdmin4 and this worked excellently.

I would like to ask this; when backing up DB in Alfresco, do you only back up the alfresco database or you back up both alfresco and postgres?

Looking forward to your feedback.

Regards,

Ejike

On Friday, February 8, 2019 at 7:56:25 PM UTC+1, Boriss Mejias wrote:
Hi Ejike,

I stopped using pgAdmin3 since the release of Postgres 9.5 (4 years ago) as it stopped being compatible with the new versions. Anyway, I don't think your error message is related to that, otherwise it would have been a "connection error", not a "start up error". In any case, the pgAdmin team is highly focus on pgAdmin4 now. I never tried the version 4, as I moved to OmniDB, which also runs on Windows and MacOS (I run it on Linux): https://omnidb.org/en/

Now, the disclaimer is that I worked for 2ndQuadrant, the company behind the development of OmniDB. The project is open source by the way, and free of charge. Maybe you want to give it a try.

Good luck,
Cheers
Boriss

On Thu, 7 Feb 2019 at 14:13, <blueflame....@gmail.com> wrote:
Good day All,

Anytime i try to run "pgAdmin3.exe" in Alfresco community 5 on Windows Server 2016; i keep getting the error below:

"The application was unable to start correctly (0xc000007b)."

Please can anyone guide me on how to resolve this problem i encountered.

Thanks and BR,

Ejike Chiboka

--
You received this message because you are subscribed to the Google Groups "Alfresco Technical Discussion" group.
To unsubscribe from this group and stop receiving emails from it, send an email to alfresco-technical-d...@googlegroups.com.

To post to this group, send email to alfresco-techn...@googlegroups.com.
Visit this group at https://groups.google.com/group/alfresco-technical-discussion.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Alfresco Technical Discussion" group.
To unsubscribe from this group and stop receiving emails from it, send an email to alfresco-technical-d...@googlegroups.com.

Boriss Mejias

unread,
Feb 10, 2019, 6:27:31 PM2/10/19
to alfresco-techn...@googlegroups.com
Hi Ejike,

Good that you fixed the issue with pgAdmin.

Regarding the other question, I just wanted to confirm what Zied said. You just need the 'alfresco' database. The 'postgres' database is only for administration of the database system.
And as Zied also mention, don't forget the content files on your alf_data. Also, backup of the Solr indexes in the right order.

Cheers
Boriss

On Fri, 8 Feb 2019 at 21:11, <blueflame....@gmail.com> wrote:
Good day Boriss,

Thanks for your response, i really appreciate it.

I was able to resolve the problem by downloading and installing pgAdmin4 and this worked excellently.

I would like to ask this; when backing up DB in Alfresco, do you only back up the alfresco database or you back up both alfresco and postgres?

Looking forward to your feedback.

Regards,

Ejike

On Friday, February 8, 2019 at 7:56:25 PM UTC+1, Boriss Mejias wrote:
Hi Ejike,

I stopped using pgAdmin3 since the release of Postgres 9.5 (4 years ago) as it stopped being compatible with the new versions. Anyway, I don't think your error message is related to that, otherwise it would have been a "connection error", not a "start up error". In any case, the pgAdmin team is highly focus on pgAdmin4 now. I never tried the version 4, as I moved to OmniDB, which also runs on Windows and MacOS (I run it on Linux): https://omnidb.org/en/

Now, the disclaimer is that I worked for 2ndQuadrant, the company behind the development of OmniDB. The project is open source by the way, and free of charge. Maybe you want to give it a try.

Good luck,
Cheers
Boriss

On Thu, 7 Feb 2019 at 14:13, <blueflame....@gmail.com> wrote:
Good day All,

Anytime i try to run "pgAdmin3.exe" in Alfresco community 5 on Windows Server 2016; i keep getting the error below:

"The application was unable to start correctly (0xc000007b)."

Please can anyone guide me on how to resolve this problem i encountered.

Thanks and BR,

Ejike Chiboka

--
You received this message because you are subscribed to the Google Groups "Alfresco Technical Discussion" group.
To unsubscribe from this group and stop receiving emails from it, send an email to alfresco-technical-d...@googlegroups.com.

To post to this group, send email to alfresco-techn...@googlegroups.com.
Visit this group at https://groups.google.com/group/alfresco-technical-discussion.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Alfresco Technical Discussion" group.
To unsubscribe from this group and stop receiving emails from it, send an email to alfresco-technical-d...@googlegroups.com.

blueflame....@gmail.com

unread,
Feb 12, 2019, 3:52:23 AM2/12/19
to Alfresco Technical Discussion
Hi Boriss,

Thanks for the response.

The Solr indexes and Solr backup are also found in the "alf_data" folder as well.

Regards,
Ejike

To unsubscribe from this group and stop receiving emails from it, send an email to alfresco-technical-discussion+unsub...@googlegroups.com.

To post to this group, send email to alfresco-techn...@googlegroups.com.
Visit this group at https://groups.google.com/group/alfresco-technical-discussion.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Alfresco Technical Discussion" group.
To unsubscribe from this group and stop receiving emails from it, send an email to alfresco-technical-discussion+unsub...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages