"Transport task update was cancelled"

Skip to first unread message

Witty Yonng

Apr 12, 2023, 2:54:51 AM4/12/23
to aiidausers
Dear AiiDA users,

I met the error "Transport task update was cancelled",  and checkerd the remote data and found the task was finished. So I ran "verdi process play <id>", and tried "verdi daemon restart", it still didn't work. Then how can I retrieve data back to my  database? 


Sebastiaan Huber

Apr 12, 2023, 3:02:09 AM4/12/23
to aiida...@googlegroups.com
Hi Witty,

You can try to up date AiiDA to v2.2 and run the following
verdi daemon stop
verdi devel rabbitmq tasks analyze

If there are problems detected, it will print something like:
Warning: There are active processes without process task: {26705}
Critical: Inconsistencies detected between database and RabbitMQ. Run again with `--fix` to address problems.
To fix the problem run
verdi devel rabbitmq tasks analyze --fix
verdi daemon start
This should hopefully fix the problem.

AiiDA is supported by the NCCR MARVEL (http://nccr-marvel.ch/), funded by the Swiss National Science Foundation, and by the European H2020 MaX Centre of Excellence (http://www.max-centre.eu/).
Before posting your first question, please see the posting guidelines at http://www.aiida.net/?page_id=356 .
You received this message because you are subscribed to the Google Groups "aiidausers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to aiidausers+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/aiidausers/c28ae75c-4950-4668-ace3-1689e1c27cb8n%40googlegroups.com.

Witty Yonng

Apr 17, 2023, 8:57:22 PM4/17/23
to aiidausers
Thanks, Sebastiaan. It solved my problem. For the most cases, we can use "verdi process play <pk>" to revive the process. 
Reply all
Reply to author
0 new messages