App Inventor in Android app test

573 views
Skip to first unread message

Gary

unread,
Dec 13, 2012, 1:48:10 PM12/13/12
to ai...@googlegroups.com
I am testing Fusion Tables with V1.4.4, getting them to work with an app I wrote that used the old Fusion Tables. Works well so far. 

I decided to see what happened when I put the code in an Android app. It took some work to get things smooth, but it works!

The app shows what ingredients you should mix in the game Skyrim.

It reads data from a fusion table. You pick what ingredient you are interested in and then which effect you want to look up. It then looks up other ingredients that have the same effect.


This is what the form looks like in App Inventor. 

This is what it looks like in an Android app with the App Inventor jars dropped into the app.

 The app has a start page with a button that displays the above form. 

It also has AdMob!!!


It took about two hours to get things built. I had to build the App Inventor jar, find new jar files that the jar needed and set the permissions in the manifest. It is still something I do by hand, but I am getting closer to being able to release the tools!


Gary








Sebastiano T.

unread,
Dec 14, 2012, 6:24:17 AM12/14/12
to ai...@googlegroups.com
Excellent work Gary ! as always! always looking to hear from you news and development about AI :)

Gary

unread,
Dec 23, 2012, 10:35:13 AM12/23/12
to ai...@googlegroups.com
I looked at the source and they have a special case for CREATE TABLE.

Set up you App Inventor app with an api key and set this as a query
  CREATE TABLE AnimalFood (animal: STRING, fav_food: STRING, population_size: NUMBER, location: LOCATION, timestamp: DATETIME)
and you are the proud owner of a fusion table named AnimalFood.

The code just does CREATE TABLE. The query does not currently take spaces in the table name or column name.


This does not work 
  CREATE TABLE 'Animal Food' (animal: STRING, fav_food: STRING, 'population size': NUMBER, location: LOCATION, timestamp: DATETIME)
you have to remove the quotes and the space around the names.

and???

I tried an insert
  INSERT INTO 1Jw-2Q8oxWD_tU6mLnYXyhflbg08YTrDYCwP8a74 (animal, fav_food) VALUES ('cat','milk');
and it worked? It should not have, the code is not there (time to read the code closer...)

hohoho

Gary
Reply all
Reply to author
Forward
0 new messages