Getting AQ/ZQ working under modern Linux?

12 views
Skip to first unread message

Derek Roberts

unread,
Jun 15, 2015, 1:04:49 AM6/15/15
to agrip-...@googlegroups.com
Hi all,

Has anyone tried compiling/using Audioquake and Zquake lately under Linux? I'm having some problems getting this all working.
What I've done so far:
Extracted the latest AQ/ZQ sources from Github.
Built the gl version (I got some weird c error when trying to build the SDL one, invalid storage class for function uninstall_grabs or something, I'll have to go check that again.)
Copied id1 and qw from Andre's Audioquake distribution to the release folder (I know that's probably not the best/cleanest way to go about it, but I was going more for proof of concept here.)

When I run it, I get a couple errors. It does connect to Andre's server, but complains that I'm using vanilla Quake (wtf?) It also apparently doesn't have the right privileges to render graphics, and is trying to use DMA mapping or something (not sure what that is) to access OSS. Naturally, running it under aoss doesn't fix that last problem.
So I thought I'd go see if Zquake itself had been updated recently. It apparently hasn't since 2011, but figured I'd give it a go... Except there are tons more compiler errors on that version.
Ugh! All I wanted to do was connect somewhere and brutally slaughter all my friends... ;(

Anyone got any pointers here? Should I try to investigate the SDL one a bit more?

Thanks for any help,
KJ4UFX

PS: In the GL build, you need -lGL -lX11 in the linking phase. Almost 600 lines of gcc output all because of a couple missing libs LOL.
Reply all
Reply to author
Forward
0 new messages